Sign in with
Sign up | Sign in
Your question

ATI HD 5700 Skyrim issue

Tags:
  • Radeon
  • Skyrim
  • HD
  • ATI
  • Graphics
Last response: in Graphics & Displays
Share
March 15, 2012 3:38:33 PM

Hi, I have a PC with an AMD ATI HD 5700, and was playing Skyrim just fine, (with most of the settings amxed out) for about 2 months. Last saturday I had a trojam problem and had to format my C: and install everything again. Now that I reinstalled Skyrim it plays ok but it is displaying a video bug. In all light sources like flames or torchs the glow shows flickering dots on the image. Already have updated my drivers and etc.
I have no idea on what's happening nor how to solve it. I'm really disapointed because the game was playing with really awesome visuals and now it's just frustrating me.

I wanted to post a screenshot of the issue, but I don't know how to take screenshots in Skyrim.

Thanks for any.
Felipe

More about : ati 5700 skyrim issue

March 15, 2012 3:47:58 PM

You could try another reinstall and this time turn off the pc and unplug from the wall , also remove the video card from the pc as well and cmos battery. That way you will get rid of any residual files or settings that may have been affected. Then put it all back together and do a clean install.
m
0
l
March 15, 2012 4:07:10 PM

did you reinstall the drivers when you reinstalled windows?
does the problem occur only in skyrim or in other games as well?
are all the cables connected properly?
you could try uninstalling vga drivers using driver sweeper and then clean installing the latest drivers from amd. also patch skyrim with latest updates.
m
0
l
Related resources
March 15, 2012 4:14:30 PM

de5_Roy said:
did you reinstall the drivers when you reinstalled windows?
does the problem occur only in skyrim or in other games as well?
are all the cables connected properly?
you could try uninstalling vga drivers using driver sweeper and then clean installing the latest drivers from amd. also patch skyrim with latest updates.

+1
m
0
l
March 16, 2012 10:42:21 AM

Yep, reinstalled and updated all the drivers.
Only happening in Skyrim. I've also installed Dragonsage 2 and Mass Effect 2, and they're perfect as ever.
What's driver sweeper? Think I should try that?


de5_Roy said:
did you reinstall the drivers when you reinstalled windows?
does the problem occur only in skyrim or in other games as well?
are all the cables connected properly?
you could try uninstalling vga drivers using driver sweeper and then clean installing the latest drivers from amd. also patch skyrim with latest updates.

m
0
l
March 16, 2012 10:58:48 AM

if the problem is with skyrim only, then try updating the game. install latest patches and updates. check skyrim's user forums if someone else is having the same problem as you and if it was solved.
this is driver sweeper's webpage:
http://www.phyxion.net/Driver-Sweeper/Driver-Sweeper/
m
0
l
March 19, 2012 2:13:03 PM

it is not a virus issue. Have the same problem and believe it is related to the latest ATI drivers that were being pushed towards the PC. Before this update all was well. Now I have the same issue as described by the originator.
m
0
l
March 20, 2012 2:55:58 AM

I'm having the same issue. It happened right after I installed the latest RADEON 5700 driver a few days ago.
m
0
l
March 20, 2012 3:44:52 AM

the problem is not your computer or the game or the video card.. but with the new 12.2 drivers.... unfortunately they are causing a corruption and pixelation.... if you install drivers 12.1 or earlier your issues will be fixed.... unfortunately amd really dropped the ball on this one
m
0
l
March 20, 2012 11:43:22 AM

I haven't played Skyrim in several days. Yesterday my computer prompted me to update to the 12.2 software... Now some things look all pixelated, and some places the ground looks like running water. It used to run great before the software/driver update.

I have system restore disabled. Does anyone know how to downgrade these back to 12.1?

EDIT:

Would this method work?
It suggests I should remove the problem hardware from my computer to start. Not really looking forward to pulling my graphics card, but I'll do it if it has to be done.
m
0
l
March 20, 2012 4:09:36 PM

plasticglock said:
I haven't played Skyrim in several days. Yesterday my computer prompted me to update to the 12.2 software... Now some things look all pixelated, and some places the ground looks like running water. It used to run great before the software/driver update.

I have system restore disabled. Does anyone know how to downgrade these back to 12.1?

EDIT:

Would this method work?
It suggests I should remove the problem hardware from my computer to start. Not really looking forward to pulling my graphics card, but I'll do it if it has to be done.


Yo plasticglock! The answer lies within this thread but I'll save you the effort of reading through it... :sarcastic: 

It's 100% related to anti-aliasing from withi the Skyrim GUI. All you have to do is turn off AA in the Skyrim GUI and open up CCC and change the 3d application settings from "use application settings" to something you set yourself. In other words, just untick the "use application settings" under SMOOTHVISION HD: Anti-Aliasing and set the Level to whatever you think is OK.

This should do the trick (at least it worked for me).
m
0
l
March 20, 2012 6:07:04 PM

___Malachi___ said:
Yo plasticglock! The answer lies within this thread but I'll save you the effort of reading through it... :sarcastic: 

It's 100% related to anti-aliasing from withi the Skyrim GUI. All you have to do is turn off AA in the Skyrim GUI and open up CCC and change the 3d application settings from "use application settings" to something you set yourself. In other words, just untick the "use application settings" under SMOOTHVISION HD: Anti-Aliasing and set the Level to whatever you think is OK.

This should do the trick (at least it worked for me).


Thank you Malachi. I built my pc only 2 weeks ago, and I have never had a computer with a graphics card before. I have never adjusted the settings for my ati card before but I will look for the Anti-Aliasing you mention. I do not see it in this thread at all. If that doesn't work I will revert the driver I suppose. I don't want to change too much because the game played just fine last week.
m
0
l
March 21, 2012 6:17:41 PM

You were right! I turned on Skyrim, went into options, and just disabled both the anti-aliasing values. Started the game and it was fine! What a relief.
m
0
l
March 23, 2012 2:56:34 PM

plasticglock said:
Thank you Malachi. I built my pc only 2 weeks ago, and I have never had a computer with a graphics card before. I have never adjusted the settings for my ati card before but I will look for the Anti-Aliasing you mention. I do not see it in this thread at all. If that doesn't work I will revert the driver I suppose. I don't want to change too much because the game played just fine last week.


Oops! You, sir, are correct. It was another Skyrim thread that I was checking out that spelled out the solution. Didn't mean to be sassy...

Don't be afraid to adjust the settings in CCC. The scenery will definitely look better with a little AA and/or morphological filtering. Just open up CCC (right click on the desktop and choose Catalyst Control Center). Make sure you're in Advanced View (preferences at the top right). Go to Gaming and 3D Application Settings.

There's a bunch of settings that you can play around with. Choose between Performance, Quality or somewhere in between, depending on your trust in your graphic card. Just make sure to un-check "Use application settings" for the ones you change.

And remember, none of these settings will do anything to the actual saved game (unlike .ini edits and such). They'll only make the Skyrim world look better (or worse) or cause your game to stutter like crazy (if you have low-end graphics and set everything to ultra high quality). But you can always change them back to the original and re-load your game.

Triple buffering is also highly recommended with Skyrim.
m
0
l
March 24, 2012 10:33:44 PM

___Malachi___ said:
Oops! You, sir, are correct. It was another Skyrim thread that I was checking out that spelled out the solution. Didn't mean to be sassy...

Don't be afraid to adjust the settings in CCC. The scenery will definitely look better with a little AA and/or morphological filtering. Just open up CCC (right click on the desktop and choose Catalyst Control Center). Make sure you're in Advanced View (preferences at the top right). Go to Gaming and 3D Application Settings.

There's a bunch of settings that you can play around with. Choose between Performance, Quality or somewhere in between, depending on your trust in your graphic card. Just make sure to un-check "Use application settings" for the ones you change.

And remember, none of these settings will do anything to the actual saved game (unlike .ini edits and such). They'll only make the Skyrim world look better (or worse) or cause your game to stutter like crazy (if you have low-end graphics and set everything to ultra high quality). But you can always change them back to the original and re-load your game.

Triple buffering is also highly recommended with Skyrim.


Malachi, I don't really get much time to play Skyrim. It is my sacred time, one of the few truly happy places in my life. After the driver update, I found this happiness marred by a graphics issue rendering the game almost unplayable. No happy place.

Your solution worked for me, it means that tonight and tomorrow (my 26th birthday) I can enjoy my happy place if even for a brief while before the trials and tribulations of my life take over once more.

Words cannot express my gratitude, but I had to register and try. Thank you so much, may you have a long and prosperous life.
m
0
l
March 24, 2012 11:10:10 PM

LOL, Well glad to hear we could help. If you still have issues or any other further questions. Please post this in a new thread or just feel free to ask one of our members!
m
0
l
!