Sign in with
Sign up | Sign in
Your question
Solved

Radeon 6990 under performing?

Last response: in Graphics & Displays
Share
March 16, 2012 6:43:09 PM

For someone reason whenever I play online, my GPU1 & GPU2 always stays between 40-56% usage. Temperature only gets as high as 62 degrees celsius, with a fan speed of 40%. Until I play single player, I then see it as high as 87% usage. I play on the high settings at 1920x1080 resolution with MSAA off, Vsync off, and motion blur off. Is this normal?

My specs are:
Asus M4N68T-M V2 Motherboard
ANTEC HCG 750W 80+ Bronze
Amd Phenom II X4 840 at 3.2 Ghz
HIS Radeon 6990
8gb Memory Ram
500gb HD

More about : radeon 6990 performing

March 16, 2012 6:46:55 PM

I don't know, you didn't mention any games. It is true that often online versions of games often require a lot more CPU power, which could cause a bottleneck.
m
0
l
March 16, 2012 6:55:45 PM

Sorry I forgot to mention the game I was playing was Battlefield 3.
m
0
l
Related resources
March 16, 2012 7:53:24 PM

Your CPU is the issues. Seems there's a lot of people with similar situations if you search online. BF3 depends more on CPU power in multi-player so there is nothing wrong with your Video card. You just need a faster CPU to keep up with it.
m
0
l
March 16, 2012 8:15:44 PM

megamanx00 said:
Your CPU is the issues. Seems there's a lot of people with similar situations if you search online. BF3 depends more on CPU power in multi-player so there is nothing wrong with your Video card. You just need a faster CPU to keep up with it.


Hmm I thought it was the CPU also. If I buy this CPU would it solve my problem?
http://www.newegg.com/Product/Product.aspx?Item=N82E168...

Or do I need something better?
m
0
l
March 16, 2012 8:27:34 PM

Yeah that's not much of an upgrade. Also you would need to have an AM3+ board with a BIOS update as it won't work in an older AM3 board like yours so no point there. The best thing you can do is overclock your CPU for now. You could get a Phenom II 965 BE which allows for easy overclocking as has that l3 cache for some extra performance

http://www.newegg.com/Product/Product.aspx?Item=N82E168...

but I don't really think it's worth it when you consider the difference from your current CPU OC'd to a similar clock speed.
m
0
l
March 16, 2012 8:29:36 PM

khamui434 said:
For someone reason whenever I play online, my GPU1 & GPU2 always stays between 40-56% usage. Temperature only gets as high as 62 degrees celsius, with a fan speed of 40%. Until I play single player, I then see it as high as 87% usage. I play on the high settings at 1920x1080 resolution with MSAA off, Vsync off, and motion blur off. Is this normal?

My specs are:
Asus M4N68T-M V2 Motherboard
ANTEC HCG 750W 80+ Bronze
Amd Phenom II X4 840 at 3.2 Ghz
HIS Radeon 6990
8gb Memory Ram
500gb HD



What drivers are you using?
m
0
l
March 16, 2012 8:54:26 PM

RussK1 said:
Newest set of profiles?

And what mode are the cards in?


The profiles on that site, is what I downloaded. I installed them but I don't know how to use them unless it does it automatically?
I left the cards in Default mode. Under the option AMD CrossfireX Mode for 3D Applications.
m
0
l

Best solution

March 16, 2012 10:06:59 PM

khamui434 said:
The profiles on that site, is what I downloaded. I installed them but I don't know how to use them unless it does it automatically?
I left the cards in Default mode. Under the option AMD CrossfireX Mode for 3D Applications.


It could be your Phenom II X4 840 bottlenecking the card. I don't know what cooling you have on the cpu, but it wouldn't hurt to OC the 840 to 4ghz. You should be seeing perfect scaling in single player. I have two 6990's and for the most part I get 99% usage on all four gpu's. But I have a 2600K at 4.5ghz though... you could try Catalyst pre-certified 12.3 drivers here~ http://downloads.guru3d.com/download.php?det=2858.

Battlefield 3 works well with Alternate Frame Rendering under AMD CrossfireX Mode for 3D Applications, so you could try that. If your interested I could write you a short guide.
Share
March 16, 2012 10:11:19 PM

RussK1 said:
It could be your Phenom II X4 840 bottlenecking the card. I don't know what cooling you have on the cpu, but it wouldn't hurt to OC the 840 to 4ghz. You should be seeing perfect scaling in single player. I have two 6990's and for the most part I get 99% usage on all four gpu's. But I have a 2600K at 4.5ghz though... you could try Catalyst pre-certified 12.3 drivers here~ http://downloads.guru3d.com/download.php?det=2858.

Battlefield 3 works well with Alternate Frame Rendering under AMD CrossfireX Mode for 3D Applications, so you could try that. If your interested I could write you a short guide.


Alright I will try the Alternate Frame Rendering. After that I will try those drivers you listed. If you can write me a guide that would be great. Also I've never overclocked before and don't really know how to. Would it be safe with my ANTEC 750W PSU?
m
0
l
March 16, 2012 10:38:11 PM

khamui434 said:
Alright I will try the Alternate Frame Rendering. After that I will try those drivers you listed. If you can write me a guide that would be great. Also I've never overclocked before and don't really know how to. Would it be safe with my ANTEC 750W PSU?


This works well for Crysis 2 as well...

Open CCC
Go to "Gaming" and open up "3D Application Settings"
At the bottom there is "AMD CrossfireX mode for 3D applications" pick "AFR friendly" and click "Apply" at the bottom.
Now go to the top where it says "Application Profiles" and click save.
Navigate your way to C:\Program Files (X86)\Electronic Arts\Battlefield 3 and click on bf3.exe
You'll be prompted notifying you that a pre-defined profile exists blah, blah, blah - click yes.
Now go back to "Gaming" and open up "Application Profiles" and see if "bf3.exe" is listed. If it is make sure "AFR Friendly" is listed.
If it is, your golden. Make sure to go back to "3D Application settings" and reset to defaults as the profile you made for BF3 is saved.
m
0
l
March 17, 2012 12:01:13 AM

RussK1 said:
This works well for Crysis 2 as well...

Open CCC
Go to "Gaming" and open up "3D Application Settings"
At the bottom there is "AMD CrossfireX mode for 3D applications" pick "AFR friendly" and click "Apply" at the bottom.
Now go to the top where it says "Application Profiles" and click save.
Navigate your way to C:\Program Files (X86)\Electronic Arts\Battlefield 3 and click on bf3.exe
You'll be prompted notifying you that a pre-defined profile exists blah, blah, blah - click yes.
Now go back to "Gaming" and open up "Application Profiles" and see if "bf3.exe" is listed. If it is make sure "AFR Friendly" is listed.
If it is, your golden. Make sure to go back to "3D Application settings" and reset to defaults as the profile you made for BF3 is saved.


Well after testing all the AMD Crossfirex settings. I can confirm that my CPU is bottle necking the GPU. I did a performance overlay graph in game and when I disabled a single card, the CPU and GPU lines were right on top of each other. But whenever I enable both cards the GPU would be above the CPU line. Thanks for the guide Russwood1488, I finally know how to use the settings.
m
0
l
March 17, 2012 12:02:09 AM

Best answer selected by khamui434.
m
0
l
March 17, 2012 12:09:12 AM

You're welcome and good luck!
m
0
l
!