Sign in with
Sign up | Sign in
Your question

Skyrim performance

Last response: in Graphics & Displays
Share
March 18, 2012 7:32:51 PM

Hey everyone,

I'm curious to hear from others running similar setups as my own.

Core i5-2500k @ 4.5
Radeon 6950 2GB @ 925 core and 1370 memory
8GB DDR3-1600

Running Skyrim at 1920x1080 on "ultra" settings with 8x AA and 16x AF, and the high-def pack, framerates are generally decent. Seems to hover in the low-to-mid 40's, sometimes higher. And of course, there's the occasional dip below 40...it happens. But certain areas are extremely problematic for me. The caves below Frostflow Lighthouse, for example, are guaranteed to bring my rig to its knees. I've seen my FPS go down as far as 20 in certain parts. And I'm not talking about a quick dip and immediately back up, it'll chug for a couple seconds or more.

Anyone else encounter problems like this? I know Bethesda hasn't had the best reputation for optimization, I'm no stranger to some of the issues that plagued Oblivion. But with Oblivion, interiors almost always ran smoother/faster than exteriors. So this cave chugging so bad surprised me, when exterior FPS are generally consistent and smooth.

Anyone? And on a sidenote, I'm curious as to what some of you other 6950 owners are overclocking your cards to. I should note, my card is not flashed, it's running stock 6950 firmware.

Thanks!

More about : skyrim performance

March 19, 2012 12:29:53 AM

I have been able to get to 925/1350 @ 1.175v. However, if I play Oblivion (I am a latecomer to TES lol) the game crashes at anything above stock settings. Not sure if it is the game, the card or the drivers/CCC.

What are you using to OC your card? I am using Asus SmartDoctor. Its the only way that I can adjust voltages.
March 19, 2012 12:46:34 PM

vollman1 said:
I have been able to get to 925/1350 @ 1.175v. However, if I play Oblivion (I am a latecomer to TES lol) the game crashes at anything above stock settings. Not sure if it is the game, the card or the drivers/CCC.

What are you using to OC your card? I am using Asus SmartDoctor. Its the only way that I can adjust voltages.


Better late to TES than never. In my opinion, with the right mods and a little tweaking, Oblivion can look darn near as good as Skyrim. And although I enjoy Skyrim immensely, I think Oblivion has a better main story and overall mechanics. So don't feel bad about playing it. Hell, I've been tempted to fire it up lately.

Anyway, sorry for the tangent. I use Sapphire Trixx for my overclocking. It also offers voltage control and has some useful tweaks for Crossfire setups, if you ever decide to go that route. I actually had to knock my core down to 900 due to occasional stability issues with Skyrim. I'm playing around with different voltages to see if I can get back to 925, but so far, it doesn't seem to like anything past 900. Strange since 3DMark and other games ran just fine before. Currently I'm up to 1.25v.
Related resources
March 19, 2012 1:02:35 PM

It's not all caves. Other interiors run like butter. The Frostflow area I referred to is real icy and occasionally has wind gusts blowing through. There's a few other areas that seem to follow this sort of format, and they all cause me problems.

Anyway, I'm not using any sort of optimizer. Thanks for the tip, I'll check it out. Might be time for a driver update too.

Edit: Ah crap, latest stable release of Skyboost only supports patch 1.3. I'm wary of trying the alpha.
March 19, 2012 4:08:02 PM

BigMack70 said:
Yeah this doesn't sound like a problem with your hardware it just sounds like a crap optimization issue or possibly a driver issue. If you haven't updated drivers in a while, you definitely should - I think AMD released recently a driver that helped Skyrim performance a lot.


So I upgraded to Catalyst 12.1 from 11.12. I intentionally skipped 12.2 because the release notes point out an issue with AA in Skyrim. I greatly enjoy AA, so I'm waiting for 12.3 (when the glitch will be fixed, according to AMD).

The driver upgrade didn't do much. Instead of hitting 20 FPS in this particular spot, now I'm around 24. Hey, I'll take it. I subsequently noticed something interesting, however: my framerate never exceeds 60.

I did some Googling (I'm coining this phrase, and yes this is different than what my wife and I did last night) and I discovered that Skyrim basically forces Vsync. Some of you probably already know this. It dawned on me that I never saw an option to toggle it in the options menu, so I figured I'd force it off in Catalyst. No dice. So yadda yadda, I applied the .ini tweak to disable it.

Long story short, areas that ran fine before run even better now, but areas that were choppy before are still choppy. My cave still runs around 25 FPS. Hopefully there aren't too many other quests in these sort of "ice caves."

The only reasonable and logical conclusion to this thread: I simply must have a 7970. :-)

March 19, 2012 5:44:58 PM

they say you should use some sort of frame limiter after disabling v-sync with .ini tweaks, it will keep the physics in check while allowing stutter free gameplay. The way the vsync is implemented causes nasty stuttering for some ppl even when at steady 60fps.
Also a lot of the skyboost tweaks were incorporated into the 1.4 update, I never tried skyboost but the 1.4 update improved my fps greatly in the low fps areas, mainly cities though...
Dropping shadows to medium might give a nice boost as well, the shadows arent exactly great anyways. Also the game engine seems to have problems with multiple light sources, might be related to shadows...
March 19, 2012 9:49:42 PM

Yeah I saw a Youtube video about all the havoc disabling vsync can wreak. I played for about an hour after making the tweak and haven't had any problems, but I probably should get a limiter anyway.

I get pretty decent framerates everywhere in the game: wilderness, cities, etc. Even most interiors run well. Just those ice caves give me problems. So I'll probably leave everything at ultra and just deal with it.

I agree that the shadow effects really aren't that great. With a couple of key mods, I think Oblivion's shadows can be more convincing than Skyrim's at times.

Poor Skyrim; for me, it will never live up to Oblivion.
March 19, 2012 11:14:59 PM

wow nvidia's driver helped out skyrim performance a ton, i get a steady 60 fps with the high res texture pack and ultra realistic water & terrain mod with a gtx 560 ti 2gb, with mild overclocking, pretty much equivalent to your hd 6950
March 20, 2012 2:34:11 AM

I like underdogs so I tend to root for AMD, but I'm not a fanboy...ultimately performance and value matter most. I've ran Nvidia before, they make a good product - but you sound like you're on the payroll.
March 20, 2012 3:31:00 AM

I downloaded a program called Dxtory. Awesome program. Has a lot of similar functions as Fraps, but also has a FPS limiter built in. Really easy to setup and works very well.

It's amazing that none (to my knowledge) of the mainstream PC gaming sites really promote programs like this. After doing some reading, it makes a lot of sense. The eye picks up on FPS fluctuations, which can make a game look choppy. Even when the framerate is considered "good," like above 40 example. For me, limiting Skyrim's framerate to 40 looks MUCH better than when it would fluctuate between 40-60. A lot of people will recommend limiting to 30, but that didn't look smooth to me.

As an added bonus, your GPU will run cooler and quieter, since it won't be working as hard to create those essentially wasted frames anymore.

I will run all my games like this from now on (assuming my video card is powerful enough to maintain ~40 FPS).
March 22, 2012 3:58:39 AM

Well nobody seems interested in this thread anymore, but I had to post one more thing.

You guys remember the scene in Empire Strikes Back after Luke is rescued and on the Falcon recovering, he whispers, "Ben, why didn't you tell me?" a couple of times...

I feel like that right now. Why didn't any of you tell me?? lol

Ok, so I'm rambling a bit. Anyway, disabling AA and AF in Skyrim's options and enabling it through CCC made all the difference in the world. HOLY CRAP. It's night and day. That cave that was running 25 FPS is now between 80-110 (remember I used the .ini tweak).

Anyone complaining of Skyrim performance should immediately be directed to try this first. Wow. I feel like an idiot, but a happy idiot at that.

Now I can play the game...like a boss.

Can I vote my own post as best answer? :-)
March 22, 2012 4:00:20 AM

Best answer selected by darth_adversor.
March 22, 2012 8:14:51 PM

darth_adversor said:

Ok, so I'm rambling a bit. Anyway, disabling AA and AF in Skyrim's options and enabling it through CCC made all the difference in the world. HOLY CRAP. It's night and day. That cave that was running 25 FPS is now between 80-110 (remember I used the .ini tweak).

ah yes, totally forgot that one :p 
When I got the game close at launch, I tried that as well. But for my setup the CCC settings didn't have any effect. If I disabled AA in skyrim the CCC settings didn't matter at all, there was none used in the game even when set at 4 or 8 in CCC.
I might need to give it another try with newer drivers and stuff...
!