Sign in with
Sign up | Sign in
Your question

Ghost Recon Advanced Warfighter 2 frame rates problem

Last response: in Graphics & Displays
Share
March 18, 2012 11:10:09 PM

i was installed Ghost Recon Advanced Warfighter 2.
But when I try to play the game, the frame rates drop dramatically.
I tried putting the settings to low and made the resolution minimum.
But it was of no use.
All other games work fine.
Help?

my pc configuration is this..
Intel dual Core 2.6 Ghz
Intel DG31PR motherboard
2 GB 667 Mhz RAM
250 GB Hard Disk space
450 W CoolerMaster power supply
9800gt (1GB) garaphic card

Help, guys?
March 19, 2012 3:22:04 PM

Thanks for reply

i agree with you my friend..
but i play battlefield 3 on my system and it was runing very good
and you know that battlefield 3 is a heavy game
m
0
l
March 19, 2012 3:29:36 PM

Ghost Recon is "Physix Enabled". Its a software that enables "supposedly better" hardware physics effects acceleration. Go though your game menu's and make sure that you have it turned off, since you have an ATI card. Physix is unique to Nvidia cards only.
m
0
l
Related resources
March 19, 2012 3:46:28 PM

Err, just to make sure that my reply did not confuse you:

Its not that you dont get physixs with an ATI card... (they do it without the need for extra drivers, or extra settings)
Its that Nvidia "supposedly does it better" since they have all that extra driver crap for it.

Whether or not its actually better...

Both card types make the game LOOK the same... however since the physics calculations are optimized for Nvidia cards, they typically get + 10-20% better framerate over ATI cards in those games only.
m
0
l
March 19, 2012 3:50:41 PM

9800gt is a Nvidia card, but anyway if I remember correctly when I used to play it using my 8800gt (the same as your card) I used to get bad frame rates untill they patched the game. For some reason they released it with a bug that they later patched so make sure you have the most up-todate version.
m
0
l
March 19, 2012 4:01:22 PM

thanks friend but i was already try it
m
0
l
March 19, 2012 8:25:08 PM

thanks to you all my friends...
i will follow your instructions
m
0
l
March 19, 2012 8:53:47 PM

ahh lol, my bad. I saw the 4 numbers, and assumes it was ATI. confusing how they label stuff these days =)
m
0
l
March 19, 2012 8:57:38 PM

but then again, the geforce 9800 is a very old card - not sure that it can support physix either... anyhow turn it off, and see what happens. Cant hurt anything.
m
0
l
March 20, 2012 8:45:38 PM

dear friend i have 9800gt green edition
m
0
l
!