Sign in with
Sign up | Sign in
Your question

New psu but still no power

Last response: in Components
Share
September 10, 2012 3:59:48 AM

my pc when i start up the window logo come up but after a few minute it shut down so i change the psu maybe the supply is not enough but when i place the new psu no power at all. somebody help me please.

More about : psu power

a b ) Power supply
September 10, 2012 4:51:18 AM

bernrom_05 said:
my pc when i start up the window logo come up but after a few minute it shut down so i change the psu maybe the supply is not enough but when i place the new psu no power at all. somebody help me please.

check that the cpu fan on right..if the system shut down it may have over heated. if the mb shuts down to save itself from overheat you have to clear the cmos.
m
0
l
September 10, 2012 5:24:14 AM

i change also the cmos baterry but still no power ive notice one of the socket from psu had burn the 12 pin socket 2 pins are burn
m
0
l
Related resources
September 10, 2012 5:31:25 AM

i tried also to reformat but still it shut down
m
0
l
September 10, 2012 5:55:45 AM

Burnt? Is the motherboard damaged? What are your specs?
m
0
l
September 10, 2012 7:22:47 AM

no damages on the motherboard only in the socket are burn. Pentium 4 !. There is small light green near cmos battery.
m
0
l
a c 144 ) Power supply
September 10, 2012 9:28:12 AM

System specs of all of the parts?
m
0
l
September 10, 2012 8:24:08 PM

Looks like you need a new motherboard if the socket is gone.
m
0
l
!