Sign in with
Sign up | Sign in
Your question

High CPU Usage "Interrupts"

Tags:
Last response: in CPUs
Share
September 10, 2012 11:15:47 AM

I recently build essentially a new comp after years of wanting one and as excited as I was - I haven't gotten to test it out.

When I first built it and installed Core Temp the cores were all running at less than 4%, as they should be. But later on once I finished installing drivers I noticed one core was at 70% with nothing running. Now it's usually 2 cores, sometimes 3. In Task Manager it shows nothing and says it's Idle using 99% of it, but when I open Process Manager there is something called "Interrupts" (Was originally "System Interrupts" but it's changed).

I spent 20 hours reading about it and trying every fix I could find, but no one elses fixes worked for me. Disabling "Audio Advancements" didn't, all of my hard-drives are set to DMA.

I did run "Latency Mon" to get an exact blame. It comes back with several errors. One being "Your computer can't process sound correctly." and blames the creative driver, I re-installed that multiple times, then it switched to something else (aspi.sys or something I think?) and usbbus.sys....

I'm not sure how to proceed from here at all. Last night I completely re-installed Windows and it didn't fix anything. I'm wondering if it's a problem with my SSD since I've never had one before I dunno what to set it up.

My build:
ASRock Z77 Extreme4
i5 3570k Stock
8GB-1333 DD3 RAM
Primary HD: Samsung 830SSD
Secondary: WD 800GB HDD
Third: WD 2TB HDD


I've updated and flashed BIOS as well as re-placing basically every driver so far. Currently all 3 of my hard-drivers are plugged into SATA 3 ports, even though 2 of them are using SATA 2 cable. Don't think that'd matter though.
a b à CPUs
September 10, 2012 11:32:40 AM

Did you format the SSD?

Is their an OS the other HDD's?

Try reinstalling Windows on the SSD with nothing but the SSD.Unplug the other HDD's.After you've installed it make sure you download all the drivers/chipset drivers from ASRock's website.

http://www.asrock.com/mb/Intel/Z77%20Extreme4/?cat=Down...(Just choose your OS)
I would suggest downloading only the essentials first,such as the Intel Chipsets.Of course you'll have to use the CD to install the LAN driver but that is the only one I would suggest installing from the CD.

If none of that works then you could try a BIOS update.
m
0
l
September 10, 2012 12:00:59 PM

I was going to try having only the SSD plugged in when I got home, but if that for whatever reason does fix it - What could I do? And none of them are formatted except the SSD. So the second drive still has the old Windows on it. I assumed it was something with the 3 drives/SATA set-up, but I dont know enough about it to change it.
m
0
l
Related resources
a b à CPUs
September 10, 2012 12:16:33 PM

I would try deleting Windows off of the HDD.

SATA III and SATA II are backwards compatible so you don't have to worry about it.I have both my SATA II SSD's plugged into the SATA III ports.No problems.
m
0
l
a b à CPUs
September 10, 2012 12:53:51 PM

Sata cables dont change specs between the revisions. And there's no specifications for Sata I/II/III cables, it's just a marketing crap.

After searching for your issue, it seems to be a bug with windows services and processes and your Audio drivers. I would suggest you to change your copy of Win 7, try to install Win7 Ultimate with the latest SP1 and essential updates then see how it works with the Windows generic driver for your Audio, before you install the Manufacturer's one.

Also, check all the pages in this thread.
http://answers.microsoft.com/en-us/windows/forum/window...
m
0
l
September 10, 2012 12:58:31 PM

When I get home tonight I'm going to start off with removing -both- HDDs and seeing if that fixes it, if it does add each one back one by one to see which causes it. If it doesn't, I'll remove my Wireless card and see if that fixes it.

I've tried disabling onboard sound in BIOS before but that didn't do anything. I'll try disabling "on board" video next.... But if disabling on-board video DOES do anything is it going to cause an issue with the IB? Figure if I slowly un-plug/move everything one by one, SOMETHING will fix it. Since with a brand new fresh Windows install, it was still at 70%.


The only thing that confuses me is when I first set it up and installed CoreTemp, I don't remember any core being over 5%.
m
0
l
a b à CPUs
September 10, 2012 2:46:28 PM

...you do know an OS is going to use thousands of interrupts every second, right? As long as its not eating up the CPU core, I fail to see the problem here?
m
0
l
September 10, 2012 3:04:49 PM

It is eating up the CPU. 70-80% on 2-3 cores at all times. I've also never seen "Interrupt" in a Process Viewer before. Even just the term "interrupt" isn't a good thing.
m
0
l
a b à CPUs
September 10, 2012 5:03:23 PM

Interrupt is when the OS has to communicate with some other hardware device. Its normal. You generate an interrupt every time you move the mouse, type a key, etc.

To be clear: What does Task Manager say about core usage, and what process is eating up the most processing time?
m
0
l
September 10, 2012 5:09:23 PM

Task Manager just states as Idle Process running at 99%. The reason I ended up digging deeper is because OCCT/Core Temp were stating my Core 1 was sitting at 70% Load with nothing running, and in all honesty. The speed of the CPU wasn't really feeling like what I figured a 3570K would.

So I installed Process Explorer and LatencyMon and that's when I saw 44+% of the CPU going to "Interrupts". Which I was told to use LatencyMon to figure out what the cause is, and it basically just keeps changing. Originally it was a Creative driver, then USB/ASCI etc. So tonight I'ma try changing hardware manually.

Maybe try disabling "On board video card." will help.
m
0
l
a b à CPUs
September 10, 2012 6:49:07 PM

I see no problems here. These are very lightweight tasks that HAS to be performed in order for the OS to do anything. There will be thousands (millions?) of interrupts going out every second on any modern OS.

I a particular service was eating up significant CPU time, you'd notice it in task manager.
m
0
l
a b à CPUs
September 10, 2012 6:53:20 PM

What PSU are you using?

What does the resource monitor say? Same thing?
m
0
l
September 10, 2012 8:08:04 PM

I'm using Corsair 750W something. Forget it's model.

The problem is basically that there is a constant never ending 60+% usage of the CPU. We're talking a 3570K so 60% usage is quite a lot. If I try to test it with a Full Load on OCCT it literally just freezes up because it attempts to maximize the load to test it's limits. I'ma try disabling Onboard video/removing both HDDs/switching video card seating/removing wireless card etc tonight and hope it goes away.

I was so excited about the PC upgrades, but it's running slower than it did before.

Sorry: Didn't see your second portion of the reply.

Task Manager under Processes will show "99 Windows Idle Performance." When you go to Performance though it shows the CPU Usage at 55+%. Which is why I re-downloaded Process Explorer but since "System Interrupts" is such a broad term, it doesn't give me anything more.

So I downloaded "LatencyMon" to see what system files are having a lot of errors, and at first it just gave me a sound card one and said "Your computer is having issues processing music." blah blah. But as I let it run the errors keep growing to a usbbus.sys, and an aspci.sys (Don't quote me on those acronyms, it probably was something else.)
m
0
l
a b à CPUs
September 10, 2012 8:21:03 PM

You should of done all that from the get go.Troubletshooting begins with 1 by 1.But in all honesty the Ivy Brdige i5 isn't THAT much better than the SandyNridge i5.The whole point of Ivy Brdige was for Laptops and Notebooks.Did you reinstall like I said in my previous post?
m
0
l
September 10, 2012 8:24:36 PM

Yea, I re-installed last night. Problem still persisted. Which is why -now- I'm thinking hardware. All signs before pointed to software but if post format it's the same.... I'm guessing hardware.

I just saw XPerf apparently has a GUI. I'll have to definitely try that tonight then, because while I didn't get much time to play with XPerf I figured it would be me thumbing through hundreds of .txt's to find the driver issue.
m
0
l
a b à CPUs
September 10, 2012 9:02:06 PM

Have you tried any of the solutions I said above?
Can you take a snapshot of the process tab and performance tab in task mgr, also a screenshot of CPU-Z and HWM BlackBox , download it from here
m
0
l
September 10, 2012 9:35:35 PM

ilysaml said:
Have you tried any of the solutions I said above?
Can you take a snapshot of the process tab and performance tab in task mgr, also a screenshot of CPU-Z and HWM BlackBox , download it from here


I've been at work this whole time. I'm going to work more with XPerf once I get home and I'll post you those pictures. I wasn't aware XPerf had a GUI so it should help me solve my issue by a lot. But yea, I'll get ya CPU-Z SSs once I get home. Not 100% sure what HWM BlackBox is but I'll check it out.

As for Win 7 ultimate, I actually already have Win7 Ultimate SP1.
m
0
l
September 11, 2012 11:58:18 AM

Having a bit of a problem attaching the pictures ATM but the problem still persists. I was working on it for 6 hours last night.

Things I did:
Un attach every piece of hardware either one at a time, or in bulk - Except for the video card. my DVI port doesn't plug directly into on-board video so no source for video without it. I did switch it to a different PCI-E though, same issue.
Re-format with only one single drive in, and tried all 3 drives.
Try in a Clean boot, and safemode.
Ensure again every HDD is in DMA mode.
Tried switching SATA boot to IDE but the SSD wouldn't boot from then on.
Read hundreds of people with similar problem- All different solutions/hardware.

Tracked it down to 'atapi.sys' and bususb (Or usbbus.sys, I forget). The USBBus won't isn't constant - the atapi.sys is. From what I can gather atapi.sys handles hard-drives so it told me to upgrade Firmware etc. My Samsung 830 already has latest F/W and I tried running the Optimization to no avail.

I'm not sure how else to do anything to this atapi.sys file - It's mostly in the BIOS/firmware which is all updated. Once I get home I'm going to try flashing my BIOS back to an early-early version. As I said when I -first- set this comp up the cores were reading at less than y'know 2-3% per core while doing random stuff. But once I took it home that night, THAT'S when I noticed suddenly Core 1 is at 70% 24/7, and others getting up there.

Sometimes when it's bad it completely lags up having issues playing music, or sound files. I'm not sure where to go from here - I'ma read the Extreme4 Manual up and down to see if maybe there is an option in the BIOS I'm missing. Maybe I'll get lucky and just flashing the BIOS back to 1.0 or maybe mid 1 range will fix it... I doubt it though.

Someone says on a forum they fixed it by Uninstalling "Primary IDE Channel" and letting it re-download. Guess another thing I'll try tonight. I just wish I knew how to manually change this atapi.sys file
m
0
l
a b à CPUs
September 11, 2012 3:45:39 PM

To see if the problem is a software or a hardware related, make a primary partition and throw on it Win XP and see how it goes.
m
0
l
September 11, 2012 4:54:43 PM

ilysaml said:
To see if the problem is a software or a hardware related, make a primary partition and throw on it Win XP and see how it goes.


That is actually a -very- good idea and I can't believe I didn't think of it. If uninstalling the IDE drivers to force Windows to re-populate them doesn't fix I'ma do that. I'm -really- hoping it isn't hardware.
m
0
l
September 12, 2012 12:40:12 PM

Update: Got it home last night and tried a few other things, finally playing around with disabling every IDE device etc I got it down to 0% usage until it reloaded them, so I installed "Intel Smart" service yadayada, and then atapi.sys being the high user turned into iasmart.sys - I finally gave up around 1AM and decided to bring it to work with me today.

I hook it up this morning - It's perfectly fine.... Every core at 0-1% while installing programs. Out of curiosity I plug something into the USB 3.0 slot and just for a minute it shoots up to 80% on two cores, but settles down to 20. I'm thinking having that USB hub I have at home plugged into the 3.0 slot just caused it's bandwidth to skyrocket. But I disabled USB, 3.0/2.0, Legacy etc in my trouble shooting. I guess it just literally can't handle the HUB. I'll find out tonight but hopefully it's done with finally.

Maybe not: I went back to the PC and now it has Interrupt using 30% of the CPU again but when I run LatencyMon it doesn't state any system file causing a latency issue. Weird.
m
0
l
September 12, 2012 4:02:06 PM

Not sure if anyone has any ideas or not anymore but the current state of it is:

Interrupts is now down to using 15-20% of the CPU at all times, instead of 40. Which is a lot better - But the better point of it is that when I run LatencyMon I no longer get errors about "You'll have problems streaming music, your DPC count is also too high." etc etc either. So I guess the errors are gone, but still my entire Core 1 is occupied 24/7 due to "interrupts".

Does anyone know how to read XPerf graphs? I can send you mine.


EDIT: I opened a game with the latency checker going and it instantly went berserk. Killed off my mouse and everything (USBHub.sys being one of the files.) not sure what to do. Having a friend bring me his Windows 7 disc since maybe mine is jacked.
m
0
l
a b à CPUs
September 12, 2012 8:24:58 PM

Also I said try Win XP and avoid this hassle and time effort.
m
0
l
September 12, 2012 9:41:02 PM

Everytime I attempted to install Windows XP I got some BSOD with a "stop' code. When I looked it up it said I didn't have the proper SSD drivers (Raid drivers?) for it. I tried Vista and got the same result - High CPU usage.

So I'm thinking the motherboard might just be bad after-all, but MicroCenter is quite far, so I'm kind of hoping to know before hand. but I guess now, I do.
m
0
l
a b à CPUs
September 12, 2012 10:59:26 PM

Nope, When you set the SSD to AHCI mode, you need to install the AHCI drivers first, press F6 when prompted during the installation then make sure you're preparing the drivers on a Disk or a Flash Drive, otherwise put the SSD on IDE Mode.
m
0
l
a b à CPUs
September 13, 2012 3:18:54 AM

You can also download the driver from Microsoft within the OS and use the "fix it for me tool".

Has the whole problem been that you can't get it from IDE to ACHI mode?
m
0
l
September 13, 2012 1:15:33 PM

Nah, all 3 HDs were in ACHI mode.

I spent the better part of 11 hours last night editing registries, and switching parts out to make it so not a single avoidable IRQ was happening to minimize interrupts. I finally rage-quit and reluctantly took the motherboard back. They asked me to exchange it so I did. Just finished installing Windows and running different programs and Interrupts haven't gone above 1% CPU at all... So maybe I just had a faulty motherboard all along.
m
0
l
a b à CPUs
September 13, 2012 5:55:23 PM

Did you try updating the BIOS with the old board?
m
0
l
September 13, 2012 7:10:19 PM

Yea, I tried the newest, oldest, then looked at manual and saw 1.2 is the version it came with so I flashed back to it. None of them seemed to work. I finally found a forum today that someone had a problem VERY similar to mine, and they ended up having a busted sound processor on the mobo, so even with the onboard HD Audio disabled, it still caused issues (Because the HD Audio Codec was un-disable-able or something. I don't know, the ASRock reply was too complex for me. Blew my mind.)
m
0
l
!