Sign in with
Sign up | Sign in
Your question

GPU-Z (v0.6.0)showing Catalyst 12.2 as Catalyst 12.3?

Last response: in Graphics & Displays
Share
March 20, 2012 1:57:12 PM

Hello,
GPU-Z (v0.6.0) is showing catalyst version as Catalyst 12.3-

http://gpuz.techpowerup.com/12/03/20/bxy.png

The latest Catalyst driver is 12.2 according to AMD's site-

http://support.amd.com/us/gpudownload/windows/Pages/rad...

Is it a bug?Am asking this because ever since upgrading to 12.2,I have had a couple of "ATI Display Driver has stopped working and has recovered"." and a "Catalyst Control Center Host Application has stopped working." instances.Also,I cleaned out my GPU completely after asking Tom's Hardware but after upgrading to 12.2,my 6850 is back to 74'C while gaming(it had dipped to 67'C). The Catalyst package size is 119.3MB on AMD's page but when I downloaded it,it was 116MB.I downloaded it twice to make sure.Is it something to worry about?

More about : gpu showing catalyst catalyst

March 27, 2012 5:18:43 AM

Please help because now I am getting strange little squares in the tire-smoke and track-side grass while playing Need For Speed Shift when anti-aliasing is set to even 2xAA(I had earlier played it on 8xAA without any problems). I don't know the technical term for it.Also,the FPS dips to 2fps...........never had this stuttering problem before.The game is original with all patches installed.Also,I had a couple of Blue Screen errors but I don't know whether it's due to these drivers.I had even the hard disc replaced (due to the error-"C:\Program Files\Windows\System32\drivers\ndis.sys is corrupt")and did an absolutely fresh install of Windows Vista (32-bit,sp2) and the drivers from AMD but am getting the same errors and glitches.The support center for this title in India has closed and am getting no reply to my emails.
Even AMD's own Catalyst Control Center's software tab and update checker shows Catalyst as 12.3.I have also installed AMD_Catalyst_12.2_CAP1(the latest available,fresh install). There is no overheating and my PSU (Cooler Master eXtreme Power Plus 460 Watts) is working fine(except that the 12.13v reading sometimes dips to 12.06v even at idle- http://gpuz.techpowerup.com/12/03/27/dw6.png ).
Also,when I delete the graphicsconfig.xml file in user documents and restart the game,the image is sharp and crisp.But just as I try to even change the controls,the screen goes completely black (even the fraps reading disappears) and when the game restarts,the image is all blurry and softened.If it helps,all settings in-game are as follows-

<prop name="Name" data=""/>
<prop name="Mode" refresh="60" antialias="0" height="900" width="1600" adapter="0"/>
<prop name="Vsync" vsync="0"/>
<prop name="Windowed" windowed="0"/>
<prop name="TextureFilter" texturefilter="4"/>
<prop name="TextureResolution" textureresolution="2"/>
<prop name="Brightness" brightness="9"/>
<prop name="CarDetailLevel" cardetaillevel="2"/>
<prop name="TrackDetailLevel" trackdetaillevel="2"/>
<prop name="ShadowDetailLevel" shadowdetaillevel="3"/>
<prop name="MotionblurLevel" motionblurLevel="3"/>
<prop name="EffectsDetailLevel" effectsdetaillevel="2"/>

My pc is-

http://h10025.www1.hp.com/ewfrf/wc/document?docname=c01...

Any help would be sincerely appreciated.
m
0
l
March 27, 2012 6:45:16 AM

I have the same (V12.3) but directly in the Catalyst software.

On top of that I have started getting a bunch of BSODs after the upgrade. After cleaning out the driver and downgrading the "ATI Display Driver has stopped working and has recovered" message started coming.

No fix found yet, next step for me is to format and go to last known working which was 11.9 for me.

Running a 5870 and 3x screen eyefinity

/Agges
m
0
l
March 31, 2012 9:32:19 AM

Did you upgrade to the "real" Catalyst 12.3?I did and it resloved the issue in Need For Speed Shift but I too got a BSOD while uninstalling 12.2...... :) 
m
0
l
!