Sign in with
Sign up | Sign in
Your question

Major Network Problem

Last response: in Networking
Share
May 30, 2011 11:46:21 PM

Background
Originally before our modem was upgraded to a wireless one, we just had a standard one Ethernet port ADSL2+ modem. This modem was in the office and was plugged into an auxiliary phone jack, which was also in the office. At this time I acquired the D-Link wireless router and set it up as a wireless switch, this was also in the office and the xbox and the 2 pc’s were connected directly to it.

My dad then got a laptop, which he used down the other end of the house. Unfortunately the wireless signal wasn’t very strong. Also at this time I got a desktop pc which I was going to plug into the TV in the lounge to use as a media centre. So what I did was run two Ethernet cables under the house from the office. One to the lounge and one to the opposite end of the house next to the master phone jack (I was going to put wireless access point down the other end of the house).

However a month after the under house Ethernet cables were installed the phone jack in the office stopped working (I think that the wire was pulled out if the jack by cats under the house). It was also about this time when our internet speed significantly dropped and our ISP told us that they were going to send us out a new wireless modem/router. After finding this out, I thought I would kill two birds with one stone and not fix the phone jack in the office but instead move the modem down to the master jack and connect to the office through the under floor Ethernet cable.

Everything was working fine to begin with but sadly there was for devices and only three available ports and this is what brings us to the original problem.

Original Problem
The set up before I went out: Vodafone wireless modem/router at one end of the house. This was connected to the D-Link wireless router (which was acting as a switch) by 30m of Ethernet cable. Connected to the D-Link was two desktop pc’s and another 15m cable which ran to a media centre. The xbox was unplugged. See Figure 1 for more details.



Everything was working fine when I went out. While I was out however my brother and his mates wanted to play xbox so they started fiddling with plug in the back of the D-Link. When I came home the media centre was plugged into the WAN port of the D-Link and nothing else of the network worked.

So the next day I used the reset button on both the Vodafone wireless modem/router and the D-Link, as merely rebooting them didn’t change anything. I changed all the settings on the D-Link to how I had them before and then plugged everything back in, excluding the media centre (note: The modem sets itself up). After doing this however the network still refused to work. So I tried another router in the place of the D-Link (This router was setup exactly the same as the D-Link) and the network started working again.

New Problem
Ever since the original problem, the media centre has been left unplugged. Tonight however, my mum was going to use it to watch TV on demand, so I unplugged the xbox and plugged the media centre in. At this point the whole network crashed. First I went and checked the router in the office (the one that had been turned into a switch). The port light which the modem was attached to had a steady flash (1 second on 2 seconds off), while the other devices attached had a solid light. In seeing this I went and rebooted the modem, this did not solve the problem (the port light to the modem on the router/switch still had a steady flash). So I reset the modem. This didn’t work either and no computer that was attached to the router/switch would allow me to connect to the modem using 192.168.1.1.
After this I unplugged the switch from the modem and used my laptop to connect directly to the modem on a different port. The modem still wouldn’t allow me to connect. So I reset it again. It still didn’t work. So I unplugged the modem and got the old ADSL2+ modem out and plugged it in. The Ethernet connection was plugged into the router/switch in the office. I then tried to connect to this modem from one of the desktops in the office, and again I got connection failed. So again I tried plugging my laptop straight in. Another connection failed.


I have absolutely no clue what is wrong with the network. Does anyone have any ideas.

More about : major network problem

May 30, 2011 11:58:18 PM

After these various modem resets near the end of your *novel* :) , what are the status lights on the modems showing? Anything out of the ordinary? If connecting directly to either one of the modems is not yielding a connection, I would call your ISP and make sure there is nothing they can do from their end to allow your modem to connect.

Also, are either of those modems and modem/router combo box? If so, is there an administrative interface you can log into from your side? Perhaps something like MAC address filtering got turned on without the proper configuration to allow your computers to connect?
m
0
l
May 31, 2011 12:06:33 AM

All lights on the modem are normal, even the light for the port that the laptop is plugged into is green. This direct connection between my laptop and the modem will not let me connect to the interface. It almost seems like the ports on the modem are broken its just strange how when I changed the modem to another one I get the same problem. Only on the second modem the LAN port light has a constant flash.
The modem is a Wireless Modem/Router and the other router is just acting as a switch.

Sorry about the novel, I thought I would put all the information down :p 
m
0
l
Related resources
May 31, 2011 12:54:40 AM

Connect a router to the modem and then connect a PC to the router. Log into the router's admin interface and check the connection details. See if it's getting a proper IP address in the admin console.

Edit: If it's not getting an IP, call your service provider and ask them to verify that they can see your modem.
m
0
l
May 31, 2011 4:48:15 AM

Solved, turns out there was a faulty connection in the wiring and it was causing the auto setup to spaz out. So i fixed the connection and flashed the modem to get rid of the isp firmware and installed the factory firmware.
m
0
l
May 31, 2011 5:14:27 AM

Awesome! Glad to hear you got it sorted!
m
0
l
!