Sign in with
Sign up | Sign in
Your question

GIGABYTE GA-Z68A-D3H-B3 and ati radeon hd 6670 issue

Tags:
  • Radeon
  • HD
  • Graphics
Last response: in Graphics & Displays
Share
March 22, 2012 5:52:55 AM

Hello Guys/Gals:

Recently purchased ATI Radeon HD 6670 1GD GDDR5 video card, one by Asus, the other by MSI. Both these are NOT detected. I disable onboard graphic and force initial display from pcie x16 slot in BIOS. Cards were installed in x16, x8 slot separately. Uninstalled onboard graphics driver, boot, then install amd driver. Cards not detected under device mgr.


my system spec:
win7 x64 with sp1
500 gb hdd
pioneer 205 bd drive
8 gb ddr3 ram
intel i7-2600k 3.4ghz
GIGABYTE GA-Z68A-D3H-B3 with F11 bios version

is it because mobo is pcie x16 2.0 and video cards pcie x16 2.1?? I read and was told it should be compatible. Either way, cards not detected in win7. Does anyone have the same mobo and hd 6670 that work or know what I need to do?

Many thanks.

More about : gigabyte z68a d3h ati radeon 6670 issue

Anonymous
March 22, 2012 6:14:03 AM

Why did you buy two 6670's?, they don't support crossfire. pcie 2.1 and 2.0 is the same, not the issue. Are you saying that neither card will be recognized at one time?.
m
0
l
March 22, 2012 1:39:35 PM

No, I installed each card separately as Asus was not detected so I bought MSI same series and that too was not detected. I google pcie 2.1/2.0 thing and confident it's not the issue. When the card is in, the gpu fan is running so it's not the pciex16 slot itself either. Scratching my head.
m
0
l
Related resources
!