Sign in with
Sign up | Sign in
Your question

Please Help sabertooth z77 issue

September 13, 2012 9:52:05 PM

Hello,
Hello!
I have a problem with my computer. Basically when i press start button it loads to a sabertooth logo and than restarts. and keeps doing that in the endless loop. All leds on my mobo flash red one after another. This happened a week ago and i got a replacement motherboard. this replacement seems to have the same issue.
My specs are:
Sabertooth z77
3770k
680 classified
32gb ram corsair vengence (tried using 8gb but didnt work)
corsair ax1200i
also i had a corsair h100 cooling the cpu but when i installed everything on a new motherboard some smoke came out from the waterblock/pump and I kept getting the cpu fan error.(so i guess the h100 died) Currently i have a stock intel cpu fan installed. I have tried clearing Cmos using the jumper a few times but still cant boot even into bios. The logo that i am stuck at at the bottom says press del to enter bios, but i cant because the keyboard doesnt power on. I dont think I have a problem with the PSU as it has power on self check wich i have tried a few times and the led is green, so i think it is working properly. I checked all the motherboard connectors like 100 time now.
Please help. Sorry for bad english.
:cry:  :cry:  :cry:  :cry:  :cry:  :cry:  :cry:  :cry:  :cry:  :cry:  :cry:  :cry:  :cry:  :cry:  :cry:  :cry:  :cry:  :cry:  :cry:  :cry:  :cry:  :cry: 

More about : sabertooth z77 issue

!