AMD CCC 13.1 Drivers, Can't get them to work


So I have a fresh (oem) win8 64bit OS and I first had the last set of drivers in the 12.x series for the amd radeon hd 7970 and those worked fine, I was able to open the ccc and modify things etc..

But then I got a message that there was an update, so I download and install the update (13.1) but the ccc kept saying that it was the 12.x version, so I removed all amd related folders/programs and installed the 13.1 driver fresh from amd's site.

The installer was able to install everything but there were some errors it said, but if I open the log no errors appear at all, also the C:\Program Files\ATI Technologies folder is empty and there is nowhere a mention of ccc at all.

I have no idea how I can get ccc to work now, I tried using the drivers that came with the gpu but same story..
2 answers Last reply
More about drivers work
  1. You made the classic mistake of updating a driver that was working perfectly well, just because an update was available. Never update a driver unless the existing one is causing a specific problem which the update will definitely fix.
    Otherwise, leave properly functioning drivers alone.

    Go into Device Manager, double-click AMD Radeon in the Display adapters category.
    Click the Driver tab.
    Click Roll back driver.
  2. In the meanwhile I 'renewed' my win 8 and installed the new driver and now everything works.

    The problem was that the working driver did work but still had some quirks and I read that the new one fixed those in win 8.

    But thanks for your advice, I'll think about it in the future!
Ask a new question

Read More

Drivers AMD Windows 8