Sign in with
Sign up | Sign in
Your question

Microprocessor cooling fan not working

Last response: in Components
Share
September 16, 2012 7:41:09 AM

Can anyone help me? My computer suddenly shutdown when I was surfing the net. Then, I switched it on but it doesn't work. I tried it three times but there's still no power..Then, I checked the connections if everything is in good grip. After that, my computer powered on.

However, after using it about two times it suddenly didn't work again. Whenever I switched it on, the power led will light up and the fans will work but that only lasted for 3-5 seconds and it will turn off. I tried it several times but it doesn't really turn on.

I don't know what to do. I tried using a different power supply, a different power switch and I also cleaned all the fans inside but still it doesn't work. I don't know what the problem really is but the microprocessor cooling fan is also not working. Is the problem concerns my motherboard? Is it dead? Do I have to replace it??

It's a triple core computer and i have a video card on board.
a b ) Power supply
September 16, 2012 7:53:06 AM

did you check to make sure the fan cable for the cpu(processor) is connected correctly to the motherboard,should be a 4 pin connection,what type of cpu cooler(fan) are you using?if the cpu fan is not working the pc will shut down quickly after you turn it on
m
0
l
a b ) Power supply
September 16, 2012 7:53:11 AM

Sounds like your cpu fan has bitten the dust. Try buying and installing a replacement.
m
0
l
!