Sign in with
Sign up | Sign in
Your question
Closed

Wierd clicking sound PSU

Tags:
  • Power Supplies
  • Cases
  • Fan
  • Thermaltake
  • Components
Last response: in Components
Share
September 16, 2012 2:47:06 PM

I have a Thermaltake Element V tower with a Xion 850w Bronze PSU. After installing the PSU, plugging in the cables, and turning the computer on, the fan on the PSU starts making a clicking sound. The PSU is firmly in place and nothing appears to be sticking in the fan either from the PSU or the case. I know the sound is coming from the PSU's fan and not another fan. Could it be a defect in the manufacturing of either the case or the fan, or is it something I'm just overlooking.

Please help
-Will

More about : wierd clicking sound psu

a b ) Power supply
September 16, 2012 3:26:08 PM

You sure it isn't the hard drive?

Score
0

Best solution

a c 157 ) Power supply
September 16, 2012 4:06:33 PM

Hokiefan55 said:
I have a Thermaltake Element V tower with a Xion 850w Bronze PSU. After installing the PSU, plugging in the cables, and turning the computer on, the fan on the PSU starts making a clicking sound. The PSU is firmly in place and nothing appears to be sticking in the fan either from the PSU or the case. I know the sound is coming from the PSU's fan and not another fan. Could it be a defect in the manufacturing of either the case or the fan, or is it something I'm just overlooking.

Please help
-Will


Xion is a tier 4 or 5(not recommended) psu on this list.

http://www.eggxpert.com/forums/thread/323050.aspx

You might consider returniing it in favor of a higher quality unit.

You have covered the bases by verifying that nothing is interfering with the fan.
Share
Related resources
September 16, 2012 7:43:23 PM

Best answer selected by Hokiefan55.
Score
0
September 16, 2012 7:45:18 PM

Thanks for your help. I didn't realize that psu wasn't great. I'll try returning it in exchange for a better quality one.

Score
0
a b ) Power supply
September 16, 2012 9:08:22 PM

This topic has been closed by Mousemonkey
Score
0
!