Sign in with
Sign up | Sign in
Your question

Problems with CPU detection?

Tags:
  • CPUs
  • FPS
Last response: in CPUs
Share
September 17, 2012 5:05:36 AM

Hello, recently I noticed awful FPS in Guild Wars 2. While I am supposed to run the game smoothly, I sit in the 20-25 FPS range. This is with all settings on maximum, but I see minimal performance improvements when turning down settings (4-5 FPS). I believe I have isolated the problem though, as when I am at the Guild Wars 2 log in screen, there is a message that states: "Hardware Issues Detected: Click here for details." When I click on this option, a message pops up saying," Your system does not meet the following requirements: Dual Core 2.0GHz processor." My computer far exceeds minimum system specs, but it is not recognizing that. What could be the issue?

i5 2500k @4.7GHz
MSI Radeon HD 7950
ASUS P8Z68
Rosewill 1000w power supply
2x4gb 1600MHz RAM

More about : problems cpu detection

September 17, 2012 5:06:36 AM

hohehi1 said:
Hello, recently I noticed awful FPS in Guild Wars 2. While I am supposed to run the game smoothly, I sit in the 20-25 FPS range. This is with all settings on maximum, but I see minimal performance improvements when turning down settings (4-5 FPS). I believe I have isolated the problem though, as when I am at the Guild Wars 2 log in screen, there is a message that states: "Hardware Issues Detected: Click here for details." When I click on this option, a message pops up saying," Your system does not meet the following requirements: Dual Core 2.0GHz processor." My computer far exceeds minimum system specs, but it is not recognizing that. What could be the issue?

i5 2500k @4.7GHz
MSI Radeon HD 7950
ASUS P8Z68
Rosewill 1000w power supply
2x4gb 1600MHz RAM


*NOTE: I am seeing below average performance in all games, but Guild Wars 2 is the game that helped me isolate the problem.
m
0
l
a b à CPUs
September 17, 2012 9:10:42 AM

Try updating your BIOS? maybe it is bugged and not telling the OS the correct info on your CPU.

Not sure but worth a shot...
m
0
l
Related resources
a b à CPUs
September 17, 2012 9:45:02 AM

Download CPU-Z and see what it reports your chip as. You can also check the BIOS version from there and compare it to the latest available version for the board.

http://www.cpuid.com/softwares/cpu-z.html
m
0
l
September 17, 2012 10:53:36 PM

Well, my BIOS was extremely outdated, but updating it to current version did nothing in terms of performance. CPU-Z is recognizing the CPU and the correct clock speeds. It also reports the updated BIOS. Still getting "Hardware Issues Detected" message at the start of Guild Wars 2 as well.
m
0
l
a b à CPUs
September 18, 2012 6:57:37 AM

Do your CPU/GPU increase to their rated clock speeds under load?
m
0
l
September 18, 2012 10:46:50 PM

Under load, the GPU sits at around 25% usage, and is at the intended clock speeds. Core clock: 900MHz Memory clock: 1300Mhz. The CPU rises to 100% usage and also to its intended clock speeds.
m
0
l
a b à CPUs
September 19, 2012 7:06:33 AM

100% across all 4 cores or only one or two?
m
0
l
September 20, 2012 1:09:23 AM

How would I go about checking that? ASUS AI Suite and CPU-Z only report a Core 0. Does this mean anything?
m
0
l
a b à CPUs
September 20, 2012 6:59:50 AM

How about Windows Task Manager?

And how many cores/threads does CPU-z say you have?
m
0
l
a b à CPUs
September 20, 2012 7:48:21 AM

If it is showing only one core, perhaps the MB decided to only use one core. Go into BIOS and change cores to 4.
m
0
l
a b à CPUs
September 20, 2012 8:08:50 AM

That brings another thought to mind...

Type "msconfig" in the instant search box and run the program when it appears. It will open a window called "System configuration". Go to Boot->Advanced options and check the "Number of processors" parameter. If it's not on 4, set it to 4 explicitly and reboot.
m
0
l
September 21, 2012 5:20:51 AM

BIOS is reporting usage of all 4 cores, but System Configuration only reports 1 core. When I try to change that, it only gives me the option of using 1 core.
m
0
l
September 21, 2012 11:58:58 PM

I ended up just unchecking all of the boxes in the boot->advanced options page. That finally solved my problem. Thx for all of your help
m
0
l
a b à CPUs
September 22, 2012 9:37:37 AM

That's the other way to do it yes... Cool! Glad it worked.
m
0
l
!