Sign in with
Sign up | Sign in
Your question
Solved

Gigabyte z77x not working with corsair tx750?

Last response: in Systems
Share
May 27, 2012 5:34:28 AM

hi guys i need some help, im not getting any power to the mobo with the psu and this is the second one ive gotten figuring i received a defective tx750 the first time. But still no power any suggestions?

Best solution

May 27, 2012 5:45:23 AM

2611689,1,1216211 said:
hi guys i need some help, im not getting any power to the mobo with the psu and this is the second one ive gotten figuring i received a defective tx750 the first time. But still no power any suggestions?[/quotemsgtry runing the mb with one ram stick in the first ram slot. it could be a stick of bad ram. also have you tried the mb on a flat table with just the video card??? one thing to check is the cpu heat sink if it an after market one make sure it not shorting out the mb.
Share
May 27, 2012 5:49:51 AM

Did you make sure to plug in both power connectors? And are you sure the power button on your case isn't faulty?
m
0
l
Related resources
May 27, 2012 6:04:28 AM

well as far as i can say everything is properly connected and i think everything is compatible. runnng the gigabyte z77 mobo, i5-3750k, geforce gtx550ti video card, with the tx750 psu. but literally no power at all no response from the psu when plugged in. i guess i should try and check the cases power button incase thats it but as a check is the setup good?
m
0
l
May 27, 2012 6:12:53 AM

Tell us how/where you are pluggin the power into.
m
0
l
May 27, 2012 6:18:21 AM

power is plugged into the atx12v porperly and main power, but running the psu cord right into my outlet. i thought the outlet may have been the issue but plugged in a few other things into it and it works fine... it frustrating not being able to get this system functional. :?
m
0
l
May 27, 2012 6:26:46 AM

smorizio u are my new best friend!!!!!! been working on this now for 3 days and i guess it is a bad ram using vengence 4x4gig(16gig total) and oh man you have no idea how much youve helped me!!!!! thank you all for the help so much!!!
m
0
l
May 27, 2012 6:27:06 AM

Best answer selected by flowin119.
m
0
l
!