Sign in with
Sign up | Sign in
Your question

4 Users connected remotely to the same server concurrently?

Last response: in Networking
Share
June 4, 2011 6:50:28 AM

The server is running Microsoft Windows Server 2008 R2.

The four other systems connecting to the server are running Microsoft Windows XP.

Is it possible to have all four users connected at the same time remotely using a remote desktop client to the server? I'm using Teamviewer right now, but not sure if it will work with that. Please help! I'd appreciate it.
June 4, 2011 5:05:07 PM

I've only ever used VNC on Unix based servers, but I know you can configure it to start a new session for each connection. That way, there wouldn't be X people fighting for control of the one desktop.
m
0
l
June 5, 2011 11:15:24 AM

I believe W2K8 is limited to two RDP connections, one to the console session and another one to a non-console session. I'm not 100% sure on this, though, you might want to try it out, you might just get lucky.

Now, there is something interesting you might want to try: the Remote Desktop Services service. Even the Standard version supports up to 250 connections, so you should be OK.

Also, if I remember correctly, there was a modded RDC DLL that allowed XP machines (that usually could only handle one or two RDP connections) to act as an RDP server for unlimited connections (well, it was Registry-controlled, but same thing, basically).

If I were you, I'd stick to RDP if at all possible. I have yet to see a remote desktop connection protocol with as much integration and as little bandwidth usage...

Good luck.

Miguel
m
0
l
June 12, 2011 3:17:14 AM

Yeah! I figured this out a few days ago, not I can have unlimited connections to the server using User Accounts. I'm just using LogMeIn Hamachi VPN and using those IPs with the RDP.

With Windows Server 2008 R2, the default connections at one time are only two, so I kept only being allowed two people connected at once. I also had to make sure that every remote service was installed and every featured and every role that had the word 'remote' in it was installed. Then I went to the Remote Desktop Session Host Configuration and right clicked on the connection and went to the properties then set the connections concurrently to unlimited in the Network Adapter tab.

Hope this helps somebody that is having the same problem in the future. Very glad I figured it out! Thanks for all the answers here though, they did help.
m
0
l
!