Sign in with
Sign up | Sign in
Your question

GTX 570 not recognized in ASRock Z68 Extreme4

Last response: in Graphics & Displays
Share
March 27, 2012 1:23:28 AM

I'm not getting video from a GTX 570, and there's no display adapters shown in device manager other than the onboard video. The fan spins, but that's it.

I tried putting the card in another slot. I checked the UEFI to make sure that display priority was set to PCI-E. I cleared CMOS. I swapped out the 6-pin PSU connector ports on the modular PSU, I tried using different 6-pin wires. The onboard video worked fine, got nothing from the GPU.

After that, I pulled a 9800GT from an old build and put it in the ASRock build. It recognized the card and defaulted to it. I figured I got a bad card and RMA'd it. Got a new card today, uninstalled the 9800GT drivers, dropped it in, still have the same problem. If I put the 9800 in the same slot it works fine, but I get nothing from the GTX 570.

Anything I should try before RMA'ing the board (which I already had to do because the first one was DOA)? Probably going to stay away from ASRock in the future.

Full build:
OS - Windows 7 Home 64-bit
MB - ASRock Z68 Extreme4 Gen3
GPU - EVGA GTX 570
CPU - Core i5 2500k
PSU - Corsair HX750
RAM - 8GB (2x 4GB) Corsair Vengeance DDR3 1600
SSD - OCZ Revodrive 3 120GB

Thanks for your help.
a b U Graphics card
March 27, 2012 1:44:12 AM

Assuming you have everythign properly seated and the power cords are connected to the 570, as well as the monitor is plugged in. Also assuming you disabled the integrated graphics when you installed the 570?
m
0
l
Related resources
March 27, 2012 2:11:10 AM

Yes, I've seated it multiple times in multiple slots, haven't gotten anything. The two 6-pins are connected, I've tried multiple cables and multiple ports on the PSU. I just tried using two molex to 6-pin adapters in case there was something wrong with the 12V rail, still got nothing.

I don't think I can disable the onboard video, there doesn't seem to be an option for it. The UEFI only lets my choose display priority, which is set to PCI-E, and when I put the 9800 in it uses the PCI-E slot.

I thought about the slot bus being bad, but what's confusing me is that the 9800 works.
m
0
l
a b U Graphics card
March 27, 2012 2:33:42 AM

I have read somewhere this can happen with these motherboards. Try a BIOS update and see if that works, otherwise I would RMA the board again. So glad mine works with no probs :) 
m
0
l
March 27, 2012 3:13:22 AM

I disabled the onboard video in device manager, still nothing from the 570 and obviously nothing from the onboard video. I put the 9800 back in and it defaulted to that right away.

ASRock has a bios 1.7 for Z68 Extreme4, but only has 1.2 for Z68 Extreme4 Gen3. My current bios is 1.4. Should I give the 1.7 a shot?
m
0
l
a b U Graphics card
March 27, 2012 3:22:28 AM

Ummm.... That's interesting... Are you sure you have a gen3 board? It seems odd to have 1.4 when the latest is 1.2 ? I'll check mine tonight and see what it says, probs v1.0 :p 
m
0
l
March 27, 2012 4:50:29 AM

In BIOS, you also need to disable the multi-monitor function for the integrated graphics (I think it's listed as IGN or similar).

If that doesn't fix it, then HERE IS a link to my thread with the same problem on an ASRock Ext3 Gen3 board. I got mine to work by inserting a second graphics card in the other pcie slot (but no crossfire bridge). After doing that, the main discrete video card was immediately detected and working, although the sacrificial second video card was not. Eventually I'll replace the motherboard, but not going to rma it since my computer is working well as is. But I would like to get my other video card out of the board since it is just going to waste, aside from allowing the first gpu to function properly...

If my understanding is correct, from reading other threads on the subject, the problem is caused by defective capacitors for the pcie slot that won't hold a charge. Or something like that. I should also mention that I am using ATI cards, not NVIDIA.
m
0
l
a b U Graphics card
March 27, 2012 10:19:19 PM

So I checked my BIOS, it was version 1 and upgrading to version 1.2 solved the mouse and keyboard issue not working with the BIOS (had to use a ps2 keyboard to get into bios). Plus there is a few new options, A worthy update, I really recommending checking your version again.
m
0
l
April 2, 2012 8:01:07 PM

I tried adding a second GPU to see if that forced it to recognize the 570, but that didn't work. I put the card in a friend's old build to make sure nothing was wrong with it - no issues. RMA'd the MB to newegg for a refund, bought the ASUS P8Z68-V PRO instead. Thanks.
m
0
l
Anonymous
a b U Graphics card
May 28, 2012 8:25:19 AM

I bring update to this issue. I tried everything that can be found on forums about this issue and was almost packing my card for RMA. And then i noticed that there is new bios update for my Extreme6 ASRock. I flashed it and it worked. So bad news for many ppl that they have to wait for appropriate bios update to be able to run their video card.
m
0
l
!