Sign in with
Sign up | Sign in
Your question

Intel Ivy Brdge, VERY heavy load

Tags:
Last response: in CPUs
Share
September 19, 2012 6:53:39 PM

Hello,

I recently built my own computer:
Parts:
i5 Ivy Bridge
MSI 660ti OC
8G Corsair RAM
Z77 Extreme MOBO

Everything works great! When idle, CPU usage shows at 1-10% (which is normal).
My PROBLEM is that when I run Crysis 2 or Borderlands 2 (1 monitor setup), my CPU usage SKYROCKETS to 100% usage during loading sequences, and it maintains an average of 70-80% during gameplay :/  This seems like an unnecessarily high load for the CPU.

I downloaded coretemp, and the temps are fine (25-30C idle, 40C during gameplay [I do have a liquid cooling unit, Corsair H100]).

I thought maybe my Processor was being overworked because the GPU wasn't contributing enough, so I downloaded a GPUtemp and the usage on THAT shows about 99%...(temps fine as well).

I DO have current drivers for mobo and GPU...I'm just wondering why on earh my computer is running at nearly 100% usage...Nothing is overclcoked, but with my current setup, it shouldnt have to be just yet.

Any thoughts/ideas on how to increase efficiency on my setup?

Thanks for the help! :) 
a c 80 à CPUs
September 19, 2012 7:00:21 PM

is it at 70-80% at full clock speed. I'm not really sure what your problem is.

my 3570k at 4.3 runs at 60% on BF3, I'd estimate that to be nearly 100% at stock.
m
0
l
a c 196 à CPUs
September 19, 2012 7:05:59 PM

use cpu-z look at your ram speed. with new mb you have to turn on xmp profile for the ram to run at it max speed. also check that you have the newest mb bios installed when the z77 chipset dropped there been bios updates on a lot of mb for gpu..ram patches and cpu code. on my sabertooth asus been dropping bios updates for windows 8.
m
0
l
September 19, 2012 9:09:18 PM

13thmonkey said:
is it at 70-80% at full clock speed. I'm not really sure what your problem is.

my 3570k at 4.3 runs at 60% on BF3, I'd estimate that to be nearly 100% at stock.


Hey thank you for the response!

I apologize if I wasn't clear; It is NOT overclocked yet, currently running at stock speed (3.4). I will up the speed soon enough, but just to reiterate my original problem for you: When I am running a game (crysis/Borderlands) the CPU Load shoots up to 70-80% average use. I asumed this number would be a lot lower with the build I have, and I am here to see 1) if that's normal, and 2) if there's anything I can do about it :) 

Thanks for your time!
m
0
l
September 19, 2012 9:11:26 PM

smorizio said:
use cpu-z look at your ram speed. with new mb you have to turn on xmp profile for the ram to run at it max speed. also check that you have the newest mb bios installed when the z77 chipset dropped there been bios updates on a lot of mb for gpu..ram patches and cpu code. on my sabertooth asus been dropping bios updates for windows 8.


Hey thank you for the reply!

I will most certainly take a look at that when I get home. cpu-z I'm assuming is a free download? I will use it tonight and make sure everything is running correctly.

And as far as snagging those updated drivers for the mobo, just going to Asus's website should be sufficient correct? (The ones that are installed now are the ones that came on the CD).

Thanks for your time!
m
0
l
a c 196 à CPUs
September 19, 2012 9:16:39 PM

intel has the newest drivers even newer then asus web page. cpu-z is free. the spd tab will show the speed your ram can run at the main tab will show the speed your ram is running now.
m
0
l
September 19, 2012 9:17:52 PM

I have a 2500 and normally see over 50% load for a lot of games, I don't think what you're seeing is particularly disturbing or unusual.
m
0
l
a c 80 à CPUs
September 19, 2012 9:32:53 PM

Drupac said:
Hey thank you for the response!

I apologize if I wasn't clear; It is NOT overclocked yet, currently running at stock speed (3.4). I will up the speed soon enough, but just to reiterate my original problem for you: When I am running a game (crysis/Borderlands) the CPU Load shoots up to 70-80% average use. I asumed this number would be a lot lower with the build I have, and I am here to see 1) if that's normal, and 2) if there's anything I can do about it :) 

Thanks for your time!


thats my point, my OC'd is at 60% usage, which would translate to near 100% for non OC. so I think what you are seeing is normal.
m
0
l
September 19, 2012 9:34:30 PM

That is fine. The CPU doesn't just sit on its ass twiddling its electronic thumbs when you game. It will be used and the usage varies depending on game/application.
m
0
l
!