Sign in with
Sign up | Sign in
Your question

Radeon 6870 Problems

Last response: in Graphics & Displays
Share
March 27, 2012 11:52:21 AM

So, I recently purchased a Sapphire Radeon HD 6870, and installed it in my PC, here are my components

BIOSTAR H61MGC
http://www.newegg.com/Product/Product.aspx?Item=N82E168...

Intel Core i3-2130
http://www.tigerdirect.com/applications/SearchTools/ite...

G.SKILL Value 4GB 240-Pin DDR3 x 2
http://www.newegg.com/Product/Product.aspx?Item=N82E168...

and of course
Sapphire 100314-3L Radeon HD 6870 Video Card
http://www.tigerdirect.com/applications/SearchTools/ite...

(I also have a 775W PSU).

Now,After installing all the drivers and windows updates, my graphics card seems to be having trouble with certain things. when I first boot (I use a 720p 22" Vizio TV as my monitor, never had problems like this before I upgraded from a Radeon x1900 XTX, so I doubt its the monitor), the resolution starts a 800x600 (indicated at the top right corner of the screen) when it shows the Biostar logo, then it changes to 1024x768 when the "Starting Windows" animation starts, THEN goes to 1360x768 (my nominal resolution) when the login screen appears. Normally this wouldn't be a big deal, but like I said, my x1900 XTX never did that, and I only recently upgraded from that about 10 days ago. This however is not the problem, I just found that odd, and thought I should mention it.

I've included a diagram to help explain my problem since I can't seem to screen cap the problem



The problem is that whenever I drag a window around the monitor, on the left and right side of the window, the boarder becomes blocky, where every couple of pixels (on the outer and inner edge) turn a pinkish red in sequence along the white part of the edges, and the inside seems to become slightly discolored (think watching a youtube video in 240, it seems to have less quality). And the other thing is, sometimes, for no apparent reason, I will go to watch a video on the internet (the player dosen't seem to matter, it's happend on youtube, dailymotion and facebook video so far) the screen will suddenly flash to orange with sporadic black lines through it for a split second, then the screen will go black, there will still be audio playing from the video, but the screen is black, and it never comes back. As far as gaming goes, I have only seen there be distortion once (I was playing DiRT 3 for the first time, and a large rectangular section near the bottom, had moved to the right a great deal).

What I'm thinking is one of a few possibilities:
1. Some of my components may not be compatible.
2. The video card itself is malfunctioning.
3. Some other part may be malfunctioning, causing graphical errors.

I'm not an expert, so I came here for help. Please feel free to throw Ideas my way as to what the problem may be, and possible fixes. If it comes down to it, I can deal with this problem, Like I said (with exception to that one time with DiRT3) I have no problems whilst gaming, it just bugs the hell out of me, and I would hate to see this become a SERIOUS problem in the future.





More about : radeon 6870 problems

a b U Graphics card
March 27, 2012 12:19:50 PM

The steps you have to take is first try different versions of driver, and you must use Driver Sweeper after uninstalling drivers to completely wipe any of the driver files left with the system. If driver changing didn't worked, try mail the issue to AMD customer support. If the problem is still not getting solved you may consider RMA the card.............
m
0
l
Related resources
a b U Graphics card
March 27, 2012 12:31:03 PM

spp85 said:
The steps you have to take is first try different versions of driver, and you must use Driver Sweeper after uninstalling drivers to completely wipe any of the driver files left with the system. If driver changing didn't worked, try mail the issue to AMD customer support. If the problem is still not getting solved you may consider RMA the card.............

Don't use Driver Sweeper - it deletes way too many things at default. Just uninstall/reinstall per AMD's instructions here: http://support.amd.com/us/gpudownload/Pages/index.aspx
m
0
l
March 27, 2012 12:35:05 PM

I think you should just do a Fresh install.
This is will actually be very helpful for you to see whether the problems are because of driver issue or the card is malfunctioning.
m
0
l
March 27, 2012 12:44:46 PM

mitunchidamparam said:
I think you should just do a Fresh install.
This is will actually be very helpful for you to see whether the problems are because of driver issue or the card is malfunctioning.


Define "Fresh install".
m
0
l
March 27, 2012 12:45:56 PM

spp85 said:
The steps you have to take is first try different versions of driver, and you must use Driver Sweeper after uninstalling drivers to completely wipe any of the driver files left with the system. If driver changing didn't worked, try mail the issue to AMD customer support. If the problem is still not getting solved you may consider RMA the card.............


This is going to sounds stupid but, what does RMA mean exactly? "Request Manufacturer Assistance"
m
0
l
a c 291 U Graphics card
March 27, 2012 12:51:51 PM

Beekeepa said:
Define "Fresh install".


Installing windows on an empty partition.
m
0
l
a b U Graphics card
March 27, 2012 1:39:08 PM

Beekeepa said:
This is going to sounds stupid but, what does RMA mean exactly? "Request Manufacturer Assistance"

http://en.wikipedia.org/wiki/Return_merchandise_authori...

Looks like your card may be faulty - you aren't using a VGA connection to your monitor, are you? Mine used to have those type of problems. But it was a 9-year-old LCD.
m
0
l
March 27, 2012 10:20:44 PM

Sunius said:
Installing windows on an empty partition.


so I have to buy a new hard drive?
m
0
l
March 28, 2012 12:51:05 AM

Also, when ever the Catalyst logo appears this is what I see



notice the "Y" and "S" are slightly distorted.

Today I uninstalled the Drivers, removed the video card, reinserted it, and the problems remain.
m
0
l
a c 291 U Graphics card
March 28, 2012 4:29:50 AM

Beekeepa said:
so I have to buy a new hard drive?

No, just empty your drive C:/, you can back everything up on drive D:/, and just install Windows on drive C again.
m
0
l
!