6870-insufficient power(?)

Hey there all, I've posted in the CPU section a week or so back about my Hyper Transport Sync Flood Error (Which seems to be gone [for now] since I've increased the voltage on my brother's rig). We still get that error on his pc, but that's for another day.

We have a new problem - his screen would randomly turn orange out of nowhere. The system doesn't automatically restart, so I'm assuming it's not the Sync Flood Error, but it just stays orange, and the system does not respond at all. Here's a pic -


As the title says, we're not sure if his power supply is lacking, or if it's a faulty card, psu, motherboard, whatever. I ran Memtest86+ overnight, and it passed everything, so I'm positive it's not the RAM.

He's currently using a Corsair TX650w PSU, so I /think/ it's enough for this card. But, we only got this PSU recently, and we've experienced the same issue using a el-cheapo 530w Raidmax PSU. Thank god I convinced him to change...but this error still persists which is bugging me.

Thanks in advance to any that may help :)

***Miscellaneous Information****
-Pc wouldn't show Sync Flood Error OR the current issue with old Radeon HD 4670
-Purchased Xfx Double D HD6870 on Feb 22nd.
-System Specs (If needed) : Phenom II X4 955@3.5Ghz (1.425v), Biostar A880g+, G.Skill Ripjaws 1333mhz CL9, HD6870, 500GB Hitachi HDD, Corsair TX650w PSU
3 answers Last reply
More about 6870 insufficient power
  1. try different graphics?
  2. refillable said:
    try different graphics?


    woops, seems i forgot to add some information :sweat:

    We tried using the 4670 again, it works fine (although it did seem to show this same error when we did certain things...just RARELY happens). Also, we ran benchmarks with the 6870 (3dmark, furmark, you name it) heck you name it, we ran it on this system to TRY and purposely make this error show up. But the thing is, it goes through all those benchmarks fine. We get this orange screen whenever we do some basic tasks. That picture was taken after we went on newegg to look at shinies, and when clicking on a picture to enlarge it, BAM that happened.

    Also another random time this happened, was when we opened our DVD drive to burn a cd. So we're both confused as to WHY something like this would happen with as something as simple as opening the DVD drive or even opening a web page.

    Though if the 6870 is at fault, we'll RMA it. But I just wanted to clarify that it was really the 6870 at fault (Even if it IS obvious...lol) since I'm the type to always want 100% confirmation.
  3. did you ever find the problem? I am also using a 6870 which runs fine for everything I do but I get the same exact problem during skyrim even though more demanding games dont cause this to happen so just wondering if you figured anything out

    mocchan said:
    woops, seems i forgot to add some information :sweat:

    We tried using the 4670 again, it works fine (although it did seem to show this same error when we did certain things...just RARELY happens). Also, we ran benchmarks with the 6870 (3dmark, furmark, you name it) heck you name it, we ran it on this system to TRY and purposely make this error show up. But the thing is, it goes through all those benchmarks fine. We get this orange screen whenever we do some basic tasks. That picture was taken after we went on newegg to look at shinies, and when clicking on a picture to enlarge it, BAM that happened.

    Also another random time this happened, was when we opened our DVD drive to burn a cd. So we're both confused as to WHY something like this would happen with as something as simple as opening the DVD drive or even opening a web page.

    Though if the 6870 is at fault, we'll RMA it. But I just wanted to clarify that it was really the 6870 at fault (Even if it IS obvious...lol) since I'm the type to always want 100% confirmation.
Ask a new question

Read More

Radeon Graphics