Sign in with
Sign up | Sign in
Your question

AMD 6850 Faulty DVI Port? (dual monitor setup)

Last response: in Graphics & Displays
Share
March 27, 2012 6:21:32 PM

A couple of months ago i built a new pc,

Key specs:

Asus P8H61-M PRO motherboard
Intel i5 2500
MSI Radeon HD6850 (2 x DVI ports, hdmi, display port)
2 x Dell 2209WAf monitors (both connected via dvi)


Shortly after building the pc i had many unexplained blue screens and start up freezes. It turned out i had a faulty motherboard so i sent it back (great customer service from ebuyer). Since rebuilding the pc with the new mobo it has been working flawlessly until one day the second dvi port just stopped working on the graphics card. After testing every cable/monitor configuration i could it refused to work. I reinstalled and updated drivers and even tried re-seating the card in the mobo. The only way i could get an output to both monitors was using 1 dvi port and one hdmi port with a dvi adaptor on the monitor.Then inexplicably a week or so after the problem first occurred it seemed to fix itself. Magically both dvi ports were working again.

However since moving my computer home from uni last weekend the problem has returned. One dvi port is refusing to work again. Exactly the same problem as last time, all cables checked, drivers updated and reseated card. Nothing has fixed it.

Anybody know of a fix? Or have i had a dodgy dvi port since i bought the card?

Hope you can help
March 27, 2012 6:44:52 PM

Sounds like a short in the wiring of the graphics card. If it is under warranty have the company get you a new card otherwise you might be able to get the parts to replace the DVI port.
March 27, 2012 7:13:53 PM

Thanks for the reply. Hmm, that's annoying, was hoping it might've been a software issue so i wouldn't have to send the card back.
!