Sign in with
Sign up | Sign in
Your question

Gigabyte Z68AP-D3 basised system power up but nothing on screen

Last response: in Systems
Share
May 28, 2012 4:52:03 PM

Hi, I just put together a Computer with a Z68AP-D3 motherboard. Currently have put in i5 3550 CPU, 4GB RAM and a HD. When I power up CPU fan and power LED lights. Disk seems to spin up but then nothing. I have plugged into a Plasma TV via the HDMI port on the motherboard. The TV senses the connection (The HDMI is not grayed out when I go to select the input) but then I get a no signal message. I plugged in a USB keyboard into the back plate but don't seem to be getting any power (caps lock light does not come on).

I have tried another HD and even put in a graphics card. I don't even get a bleep when I power up. There are some 'phase' LEDs and I have 2 green, 1 amber and one red. Not sure what this means.

Any ideas,
Ben

More about : gigabyte z68ap basised system power screen

May 29, 2012 7:29:47 PM

Just a quick note to say the motherboard/processor combination are not comparable.
May 29, 2012 7:31:30 PM

Lol, you do realize Ivy bridge works with Z68 motherboards, right?
May 29, 2012 10:53:49 PM

Not without a bios upgrade and guess what, I cant do one unless I can boot up the computer so effectively this MB/CPU combination is incomparable.

Strangely it seems if I have the rev 1 version and a CPU like a 2500K I could flash MB but strangely I don't have a spare CPU and anyway I have the rev 2. version.

Ivy Bridge works with Z68 seems a bit of a blanket statement.

Ben
!