Closed Solved

Forceware

good day guys, ive learn bout the newest driver from nvidia the 301.10. though its designed for the gtx600, can i use for my gts450, i just want some of your opinions before i install this! tnx guys!!
2 answers Last reply Best Answer
More about forceware
  1. Best answer
    296.10 is the WHQL driver you should be using. There are no newer drivers for your card. Not even betas.

    The 301.10 is for the GTX680 only.
  2. Best answer selected by gene_11.
Ask a new question

Read More

Graphics Cards Nvidia Graphics