Sign in with
Sign up | Sign in
Your question

Display driver AMD has stopped responding and has recovered

Last response: in Graphics & Displays
Share
April 2, 2012 6:09:38 AM

I am having an issue when ever trying to play a few games. I was able to play them earlier today but now i keep getting this error. "Display driver AMD has stopped responding and has recovered" I have checked my drivers more than once and they are all up to date as far as i can see. I have only had this computer since early February. So i don't know as to why it would be doing this. When i built it i had multiple people look over the build and double checked all that everything was compatible. This is the first time this has happened to me and instead of trying to sift through the other posts about this i decided to make my own.
The games (World of tanks, League of Legends, Team fortress 2 and other Steam games) i am playing are not that graphic intense as to cause my gfx card to blow or anything. As i said i was able to play all of these games since i built my comp in Feb and now all of a sudden they aren't running. I have also tried a system restore but as i suspected it didn't fix it.


This is my build
Mobo= GIGABYTE GA-Z68XP-UD3P LGA 1155 Intel Z68 HDMI SATA 6Gb/s USB 3.0 ATX Intel Motherboard

GFX= XFX Double D HD-687A-ZDFC Radeon HD 6870 1GB 256-bit GDDR5 PCI Express 2.1 x16 HDCP Ready CrossFireX Support Video Card with Eyefinity

PSU= CORSAIR Enthusiast Series TX650 V2 650W ATX12V v2.31/ EPS12V v2.92 80 PLUS BRONZE Certified Active PFC High Performance Power Supply

CPU= Intel Core i7-2600 Sandy Bridge 3.4GHz (3.8GHz Turbo Boost) LGA 1155 95W Quad-Core Desktop Processor Intel HD Graphics 2000 BX80623I72600

Ram(x4)= G.SKILL Ripjaws Series 4GB 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Desktop Memory Model F3-12800CL9S-4GBRL

HDD= Western Digital Caviar Green WD20EARX 2TB SATA 6.0Gb/s 3.5" Internal Hard Drive


Please help!!!
April 2, 2012 6:16:16 AM

Update to the new drivers.
April 2, 2012 6:23:43 AM

I tried to do so but i was confused as to whether i downloaded the correct ones or not. Help in finding the current drivers i should update to would be very helpful! I also forgot to mention i am running windows 7-64 bit if that changes anything. I have the AMD driver Catalyst control 12.1, changing between those drives does nothing.
Related resources
April 2, 2012 6:16:49 PM

I have actually already tried this but it seemed to keep doing it. But i will try it again.
April 2, 2012 6:33:30 PM

Nest time buy an Nvidia card.
April 2, 2012 6:48:57 PM

stach2424 said:
I was able to play them earlier today but now i keep getting this error.

It's clearly not a driver issue unless he changed it.

What are your GPU temps? Did you change anything at all between when it worked and now?
April 2, 2012 7:00:27 PM

I was getting this with 12.2 but not with 12.1. If the new drivers don't work then you could always downgrade. You probably want see any performance decrease by using the old drivers since the new ones are mostly for the HD 7xxx series cards
April 2, 2012 7:22:25 PM

I changed nothing between when i played and when i didn't. I also don't do any overclocking so over heating should not be the problem. Also my case has around 6 fans and the gfx card had 2. But I did find that apparently my mother board chip set was out of date so i am currently downloading that to see if that will fix it. Are there any other drivers that i should also check for? Currently the only ones i am aware of is GFX and Mother Board.
April 2, 2012 7:53:32 PM

jsrudd said:
I was getting this with 12.2 but not with 12.1. If the new drivers don't work then you could always downgrade. You probably want see any performance decrease by using the old drivers since the new ones are mostly for the HD 7xxx series cards



Would you also get it with 12.3? that is what i am currently running.
April 2, 2012 8:23:55 PM

aicom said:
It's clearly not a driver issue unless he changed it.

What are your GPU temps? Did you change anything at all between when it worked and now?



I did try all the drivers but to no avail. Downgrading them didn't work ether. I did get a program to check my temps but they all seem fine here is a screen pic of it.

i am really not sure what else to try. Im sure taking a video of what my screen is doing won't help. (blinking on and off, large squares will appear, display comes back on and windows are different colors...)
!