Performance issues with my build

Hi all!

I am currently experiencing some major performance issues that maybe i shouldn't due to my build. When i play games (non-mulitplayer)on it after 10-15min of gameplay they start to lag.

Computer specs are as follows:

CPU: i7 3820 3.8ghz
RAM: 16GB
GPU:Sapphire 7950 OC 3GB
OS: Windows 7 64bit
HD: 250GB
PSU: 750W

I've almost looked everywhere with no luck on remedies.. anyone want to take a stab at this please?
cheers
11 answers Last reply
More about performance issues build
  1. check the temperature?
  2. Update your GPU drivers, mobo drivers, and BIOS>
  3. rgd1101 said:
    check the temperature?


    Yeah it says 88*c is that normal for my CPU?
  4. That is really bad. 88C is about 190F. Your CPU is overheating. I suggest investing in better cooling. Get a Hyper 212 EVO. It will bring down those temps a lot. And get some case fans.
  5. A good load temp. is 65 degress or less.
  6. obsama1 said:
    That is really bad. 88C is about 190F. Your CPU is overheating. I suggest investing in better cooling. Get a Hyper 212 EVO. It will bring down those temps a lot. And get some case fans.


    Yeah there was an issue with my cooling but the blokes who put it together said it was fine..and when i called them to say that my CPU was about 88*c they said it was also fine..dodgy blokes...
    I have Corsair water cooling H70 and case fans.... I'll have to maybe find someone better in that case.
  7. Got to ask, what cpu cooling are you using just now?
  8. pauls3743 said:
    Got to ask, what cpu cooling are you using just now?


    Corsair H70 at the moment.
  9. Wow, that's is really dodgy. 88C is fine? 0.o

    Anyway, how many case fans do you have? Are there fans on the radiator for your H70?
  10. obsama1 said:
    Wow, that's is really dodgy. 88C is fine? 0.o

    Anyway, how many case fans do you have? Are there fans on the radiator for your H70?

    2 case fans which are located 1 in the front as one on the tops both with options to run high or low speed. And yep 1 on the cooler itself
  11. bad chip maybe? by the looks of it ;

    1. the i7 3820 you got is a bad chip. RMA it.

    2. motherboard is not at optimum settings? e.g : high vcore=1.6v at 3.8 ghz?
Ask a new question

Read More

CPUs Performance Build