Sign in with
Sign up | Sign in
Your question
Closed

SLI and 3D Vision Bug?

Last response: in Graphics & Displays
Share
a b Î Nvidia
April 4, 2012 1:54:50 PM

Well my problem is the following:
I was running 3D Vision with only one 560 ti (MSI Twin Frozr II) and was working normally, so I’ve decided to try the SLI and borrowed another 560 TI (ECS) and SLI'em.

Everything is working great, Games performance increased a lot, and 3D is working.

But on some specific games I noticed that while in 3D Mode the right and left corners of the screen aren't rendering properly almost like the system is not rendering that because it is "out of the monitor" I have taken 2 screenshots of the problem.

(Check the left images to see the problematic frame)
http://photos.3dvisionlive.com/ricardois/image/4f7c517f...
http://photos.3dvisionlive.com/ricardois/image/4f7c51de...

And the strange is that this is fixed when I activate the nvidia 3D AIM (ctrl+f12) so my solution for now is playing with AIM activated at 100% transparency.

But I would really like to know the solution for this problem I hope someone know what is causing this and know or can think in a fix for that problem.

Thanks.

EDIT: This happens in driver version 295.73 so i have it upgraded to 296.10 and the problem continues.

More about : sli vision bug

a b Î Nvidia
April 4, 2012 2:09:44 PM

Could either be drivers, or the cards have different clock speeds.
Score
0
a b Î Nvidia
April 4, 2012 2:12:37 PM

yes they do have different clock speeds, so that is the problem!?!??!? that would explain it all.

noone at nvidia forum answered me anything...

well that would really explain it but i am not going to overclock the ECS video card because there is not enough cooling and also it is not mine... it is just for testing i'm going to buy another MSI.
Score
0
Related resources
a c 80 Î Nvidia
April 4, 2012 2:18:43 PM

Try Ctrl+F11 and see if any of the 3 different fustum modes fixes it.
Score
0
a b Î Nvidia
April 4, 2012 2:19:12 PM

@Rockdpm are you sure different clock speeds can be causing this?

One is at 820mhz and the other is at 880mhz, i just wanted to know if by buying another 560 ti MSI with same clock speeds this is going to be fixed.

Quote:
Try Ctrl+F11 and see if any of the 3 different fustum modes fixes it.


i'll try that when get at home, but i really hope this is clock problem because i don't wan't to invest in another 560ti and get this same problem.

the strange is that it is fixed by activating the nvidia laser sign;
Score
0
a c 80 Î Nvidia
April 4, 2012 2:21:10 PM

ricardois said:
@Rockdpm are you sure different clock speeds can be causing this?

One is at 820mhz and the other is at 880mhz, i just wanted to know if by buying another 560 ti MSI with same clock speeds this is going to be fixed.

Spoiler
Try Ctrl+F11 and see if any of the 3 different fustum modes fixes it.


i'll try that when get at home, but i really hope this is clock problem because i don't wan't to invest in another 560ti and get this same problem.

the strange is that it is fixed by activating the nvidia laser sign;


Why not clock them the same by using MSI Afterburner.
Score
0
a c 80 Î Nvidia
April 4, 2012 2:22:39 PM

ricardois said:
@Rockdpm are you sure different clock speeds can be causing this?

One is at 820mhz and the other is at 880mhz, i just wanted to know if by buying another 560 ti MSI with same clock speeds this is going to be fixed.

Quote:
Try Ctrl+F11 and see if any of the 3 different fustum modes fixes it.


i'll try that when get at home, but i really hope this is clock problem because i don't wan't to invest in another 560ti and get this same problem.

the strange is that it is fixed by activating the nvidia laser sign;


This is partly why I believe Ctrl+F12 will fix it, as there is a good chance you hit Ctrl+F11 when you did activate the laser sight.
Score
0
a b Î Nvidia
April 4, 2012 2:23:53 PM

bystander said:
Why not clock them the same by using MSI Afterburner.


i just don't wan't to overclock the ECS because it is not mine. if any problem happens my friend will be pissed, but if this is the problem it will not be shown when buying another in the same clock.
Score
0
a c 80 Î Nvidia
April 4, 2012 2:57:57 PM

You can downclock your card to match the other.
Score
0
a b Î Nvidia
April 4, 2012 3:51:21 PM

ricardois said:
i just don't wan't to overclock the ECS because it is not mine. if any problem happens my friend will be pissed, but if this is the problem it will not be shown when buying another in the same clock.

which ever card has the lower clock speed. Clock the higher card at the lower clock speed the other card has. that way that won't hurt your loaner card
Score
0
a b Î Nvidia
April 4, 2012 3:54:26 PM

Different Clock speeds between two cards.... Is a cause from Micro stuttering.Also SLI on its own can be unstable depending on LUCK!.
Score
0
a b Î Nvidia
April 4, 2012 4:58:21 PM

thanks for all the info i'll try that when i get home, but do i need to downclock all clocks? shader clock, core clock and memory clock for that to work properly?

EDIT: nice that I am not experiencing any other problem, in 2D gaming even with different clocks the performance is amazinly better and no microstuttering, just noticed this problem in 3D, i'll adjust the clocks when i get home and post my feedback here, hope that is the problem.
Score
0
a b Î Nvidia
April 4, 2012 7:32:57 PM

ricardois said:
thanks for all the info i'll try that when i get home, but do i need to downclock all clocks? shader clock, core clock and memory clock for that to work properly?

EDIT: nice that I am not experiencing any other problem, in 2D gaming even with different clocks the performance is amazinly better and no microstuttering, just noticed this problem in 3D, i'll adjust the clocks when i get home and post my feedback here, hope that is the problem.

Just core and Memory mainly. but i would recommend downclocking them both to same specs
Score
0
a b Î Nvidia
April 4, 2012 8:51:56 PM

well i have downclocked my MSI video card to the same clocks as ECS, even with the SYNC video cards option enabled on MSI afterburner, and the problem still hapenning.

Frustum adjustments (ctrl+f11) first of all any of them totally removes the righ bugged side of the screen, and even if it worked why would i play the game stretched xD?

so i think this is not the problem.

Score
0

Best solution

a b Î Nvidia
April 4, 2012 9:06:57 PM

Could be a defective card, or your SLI just isn't stable
Share
a b Î Nvidia
April 4, 2012 9:14:05 PM

the strange is that both cards ALONE works perfectly (much more lagged but don't loose any sides)

also what do you mean by unstable SLI? how can i stabilize it?

Well i think it may be due to be using 2 different manufacturer video cards, and also different clocks, i am just hoping that if i buy another just like mine msi twinfrozr II, this problem will not be presented... the thing is that, the SLI is very good, in 2D this problem can't be noticed anyway, and just in 3D you can see it, the performance is awesome, just the corners aren't being properly renderized (just in some games like i've said before other games works perfectly already), the thing is that kepping both video cards at different clocks (820-880) and running in 3D with Nvidia laser sight this problem does not occur, so for my testing i am using the nvidia aim (invisible) and everything is working that makes me think that this problem isn't related to hardware and it is more to software... well for now this problem still unsolved.
Score
0
a b Î Nvidia
April 4, 2012 10:50:41 PM

Maybe you don't get enough performance for 3d, 3d eats up high frame rates you would see in 2d
Score
0
a c 75 Î Nvidia
April 5, 2012 12:01:20 AM

ricardois said:
i just don't wan't to overclock the ECS because it is not mine. if any problem happens my friend will be pissed, but if this is the problem it will not be shown when buying another in the same clock.


1. Download MSI Afterburner 2.20 Beta 15
http://downloads.guru3d.com/MSI-Afterburner-2.2.0-Beta-...

2. Open settings, General Tab "Master GFX Processor Selection" and select the slower card.

3. Check the box below telling it to "Synchronize settings for similar GFX cards".

Score
0
a b Î Nvidia
April 5, 2012 12:44:25 AM

JackNaylorPE said:
1. Download MSI Afterburner 2.20 Beta 15
http://downloads.guru3d.com/MSI-Afterburner-2.2.0-Beta-...

2. Open settings, General Tab "Master GFX Processor Selection" and select the slower card.

3. Check the box below telling it to "Synchronize settings for similar GFX cards".


yes i know i already did it both ways, but that was not the cause of the problem, the bug still there like i've said before.


Quote:
@Rockdpm Maybe you don't get enough performance for 3d, 3d eats up high frame rates you would see in 2d


What do you mean not enough performance for 3D? with one video card the performance is much worst (in 3D) but this problem does not happens (in 3D also).

3D don't eat high frame rates, it just shares the refresh rate to each side of the screen, so instead of running my normal 120hz i am running at 60hz in 3D consequently maximum framerate is 60fps (per eye), but my problem isn't performance or any other SLI problem stuttering etc, it is only the corners of the screen that are not being properly rendered:
Relinking:
http://photos.3dvisionlive.com/ricardois/image/4f7c517f...
http://photos.3dvisionlive.com/ricardois/image/4f7c51de...

check for the Left side image, this is just noticable in some games, Deep Black, Koa Reckoning, are the ones that i saw that problem for now and the temporary fix is using the nvidia 3D Aim (this is the really strange part for me lol). i am trying other stuff for now besides this activating 3D Aim could not find any other fix. if someone have other Idea would be nice to share, i will still looking for the problem, if i fix it i'll post here to someone who may get this same problem, i really haven't seen anyone complaining about this so far...
Score
0
a b Î Nvidia
April 15, 2012 1:19:03 PM

Well i still with this problem, but i will select as best answear that was probably more close to the problem.
Score
0
a b Î Nvidia
April 15, 2012 1:20:09 PM

Best answer selected by ricardois.
Score
0
!