Sign in with
Sign up | Sign in
Your question
Closed

Display driver has stopped responding Radeon HD6870

Last response: in Graphics & Displays
Share
April 5, 2012 1:42:18 AM

Hello All,

Here are my specs:
MOBO: MSI 970A-G45
CPU: AMD Phenom II X4 955BE
RAM: Corsair Vengeance 2x4GB PC12800
VIDEO: XFX Radeon HD 6870
HDD w/OS and games and other progams: OCZ 120GB SOLID 3 SERIES SATA III HD
HDD: with programs less used: WD 500GB Green HDD
DVDRW: Sony DVDRW 24x
Ultra LSP 650W PSU
OS: Windows7 x64 w/SP1

I am getting an error more often than I like. The ONLY time it happens is when joining a server in Battlefield 3 or once I am in a server when it switches maps. It does not happen always. Only occasionally.

"Display Driver has stopped responding and has recovered" -> Pretty common error after searching the web for over a week now.

What I have tried:
1. Drivers from 11.0 to 12.3 (uninstalling and reinstalling properly in safe mode using driver sweeper etc.)
2. Disabled antivirus (avast)
3. Under clocked video card
4. Overclocked video card
5. Overclocked CPU
6. RMA'd video card for replacement
7. Tried different PSU (BFG 550w)
8. Reinstalled OS fresh with drivers etc.
9. New motherboard
10. Memtested both sticks of RAM overnight (passed)
11. Tried with only one stick of RAM at a time(same error occasionally)
12. Stood on my head and tried to drink a glass of water
13. Kicked my dog(just kidding)

Temperatures are as follows:
GPU Idle: 39C
GPU Under load : 70C

CPU Idle: 38C
CPU Under load : 51C


I do not overclock and never have. I only over and under clocked recently to see if that would help the problem. It did not.

I have read countless threads and countless articles with others having this same issue. Some have had success with a different PSU, Some have had success with new RAM. Some have had success with replacing the Video Card. I have tried all I can think of and at this point I am out of ideas. I don't usually ask for advice or help since I have been building PC's for almost 20 years now, but I am at my wit's end.

Any magic tricks out there?

April 5, 2012 1:51:30 AM

Tried with only one stick of RAM at a time(same error occasionally) that should lead to a good memtest
Score
0
April 5, 2012 2:01:58 AM

It only happens in BF3? Maybe try uninstalling BF3 and reinstalling. That may have been covered in your reformat and OS install but just a thought. Seems like it should be happening with other applications too if its a hardware or driver issue. Also, I didn't check out your motherboard but is there another PCIe x16 slot you could try?
Score
0
Related resources
April 5, 2012 2:28:21 AM

scout_03 - I tried with one stick at a time during memtest and with both. I also tried with one stick during BF3 gaming. No matter what, I get the error whether I have one stick in or not and memt4est passed all tests with single sticks at a time and with both sticks.

stickg1 - I do have another PCI-e slot. I actually thought about trying that as it is the only thing I can think of to try at this point. I'll give it a shot right now.

EDIT: One thing I just noticed si that I don't seem to get the error as often if I switch to windowed mode in BF3 when joining or switching maps. If in FULL screen, it happens more often.
Score
0
April 5, 2012 2:42:39 AM

Okay try the other slot, check your manual make sure it runs at 16x when its the only slot occupied (some motherboards have additional slots locked at lower speeds.) But try to reinstall BF3 as well. Good Luck!
Score
0
April 5, 2012 3:18:21 PM

MOBO Manual says this:

1 PCIe 2.0x16 slots (PCI_E2 supports up to x16 speed, PCI_E4 supports up to x4 speed)

There's nothing else that says whether one or both slots run at slower speeds when occupied or not.

I placed the card in the second PCIe slot last night and ran a few rounds of BF3 with no problems. However, since the error is not consistent, I can't say for sure that the problem is resolved yet.

BF3 has been reinstalled already once before. I guess I can do it again. Just stinks that it takes a while to do so.
Score
0
April 6, 2012 2:18:08 AM

do you have a older pci-e card that you could try on this board in the pci-e 16 x slot this one could be defective and you will have to rma board
Score
0
April 6, 2012 4:37:48 PM

scout_03 said:
do you have a older pci-e card that you could try on this board in the pci-e 16 x slot this one could be defective and you will have to rma board


Yes, I have an older PCIe card, but it is not powerful enough to run BF3.


@suat - I'll give the link a try.

Also, I moved the card to the other PCIe slot and did not get the error while playing, however, I did get something different where the video locked up and graphics went crazy then booted me out of the middle of a match. Something that never happened with the video card in the upper PCIe slot.
Score
0
April 7, 2012 3:21:17 PM

After applying the fix in the link suat gave, I ran BF3 last night for over 3 hours and never once got the error. Whether it is fixed or not, we shall see. I'll keep an eye on it. If it does not give me the error for a week, then I will consider it probably fixed.

I'm also running the 12.3 drivers after a driversweep in safe mode and reinstalling.
Score
0
April 10, 2012 2:18:42 AM

come back is you need more help
Score
0
April 10, 2012 2:34:08 AM

I'm back.

Still getting the error, even after the above MS fix was applied.


I've tried drivers all the way back to 11.7.
I've reformatted HDD and installed OS
Reinstalled the game
Moved video card to other slot.
Updated MOBO bios
RMA'd video card
Swapped out PSU
MEM tested RAM
Swapped 6 pin power connectors on GPU
Unhooked all USB devices
Unhooked DVDrom and SATA backup drive

At this point I'm at a loss.

Score
0
April 10, 2012 2:44:25 AM

areamike said:
I'm back.

Still getting the error, even after the above MS fix was applied.


I've tried drivers all the way back to 11.7.
I've reformatted HDD and installed OS
Reinstalled the game
Moved video card to other slot.
Updated MOBO bios
RMA'd video card
Swapped out PSU
MEM tested RAM
Swapped 6 pin power connectors on GPU
Unhooked all USB devices
Unhooked DVDrom and SATA backup drive

At this point I'm at a loss.


So you have tried a different video card and no luck? Might be a motherboard issue.
Score
0
April 10, 2012 2:47:02 AM

i would do a test on that sdd for error aslo when you are in the game what are the fps you got when that happens since you play on a network
Score
0
April 10, 2012 4:02:15 AM

My FPS are high. When running Fraps, I see anywhere from 40-90FPS.

I have a guy I can get another MOBO from and try but that will be about a week or so.

One thing I have noticed lately. When I join a certain sever, I get the error more.

EDIT:!!!!
I just noticed something. In between maps in BF3 or when loading maps, FRAPS shows my FPS THROUGH THE ROOF. Like 170 FPS+

Is that normal?
Score
0
April 10, 2012 11:02:04 AM

areamike said:
My FPS are high. When running Fraps, I see anywhere from 40-90FPS.

I have a guy I can get another MOBO from and try but that will be about a week or so.

One thing I have noticed lately. When I join a certain sever, I get the error more.

EDIT:!!!!
I just noticed something. In between maps in BF3 or when loading maps, FRAPS shows my FPS THROUGH THE ROOF. Like 170 FPS+

Is that normal?


Yeh that's not out of the norm because it's not displaying high demanding graphics. Do the direct x updates suggested.
Score
0
April 10, 2012 12:20:14 PM

I have often suggested here increasing core/memory idle clock speeds in case one is experiencing TDR issue. It seems nobody is interested in doing it.

Here is the procedure doing it if anyone is interested:

Open Catalyst Control Center (new version since October 2011. Older versions have a different procedure.).

Make sure Enable Graphics Overdrive is unchecked in Overdrive section.

Click Presets.

Click Add preset.

Give a name to the preset (such as Speedy and note it) and save.

Now go to %USERPROFILE%\AppData\Local\ATI\ACE\Profiles\ (AppData folder is hidden. Select Show all files and folders in Folder Options.).

In Profiles folder, you will see a file called Speedy.xml. This file you have just created.

Open Speedy.xml with notepad.

In this file there is a line

name="CoreClockTarget....."
<Property name="Want_0" value="xxx00" /> (xxx00 is your idle-state core clock. Make it 40000)

and another line

name="MemoryClockTarget....."
<Property name="Want_0" value="yyy00" /> (yyy00 is your idle-state memory clock. Make it 90000)

Change only the Want_0 values. These are the idle-state clocks.

Save the file with the changes you have made.

Now go back to Catalyst Control Center.

Select the Preset called Speedy and then put a checkmark in the box next to Enable Graphics OverDrive.

Click Apply at the bottom of the Catalyst Control Center window.

Now you can see the new increased idle-state core/memory clock speeds.

Now try to give your card a good TDR if you can.

If your issue is resolved, then you may back off little by little on idle core/memory clock speeds until you find your system's lowest values, just to save energy and help GreenPeace act. If it is not resolved, good luck.
Score
0
April 10, 2012 1:14:36 PM

suat said:
I would also suggest updating your DX drivers because Windows 7 comes with limited DX functionality: http://www.microsoft.com/download/en/details.aspx?id=35

As you will see Windows 7 needs this DX update.


Tried it and the installer came back and said my installation is up to date.

I'm going to try what you suggested with the core and memory clocks, even though I have already tried under and over clocking the video card.


Score
0
April 10, 2012 1:21:21 PM

suat:

Those lines you mention are not there. Here is my Speedy.xml

Quote:
<Profile>
<Caste name="Graphics">
<Groups />
<Adapter name="PCI_VEN_1002&DEV_6738&SUBSYS_31071682&REV_00_4&39319B62&0&0010A" />
</Caste>
<Caste name="Fuel">
<Groups />
<Adapter name="FuelAdapterUDID" />
</Caste>
<Caste name="Platform">
<Groups />
<Adapter name="PlatformAdapterUDID">
<Aspect name="AMDOverDrive">
<Feature name="AMDOverDriveEnableAOD">
<Property name="AMDOverDriveEnableAOD_Control" value="False" />
</Feature>
<Feature name="AMDOverDriveEnableCOD">
<Property name="AMDOverDriveEnableCOD_Control" value="False" />
</Feature>
<Feature name="AMDOverDriveEnableGOD">
<Property name="AMDOverDriveEnableGOD_Control" value="False" />
</Feature>
</Aspect>
</Adapter>
</Caste>
</Profile>
Score
0
April 10, 2012 1:34:56 PM

I can't edit my above post.

I had to delete then re-add the Speedy preset a couple times and now those lines are showing up. I made the changes you suggest and now my idle speeds are 400/900
Score
0
April 10, 2012 1:47:25 PM

Now do what you did previously to get TDR error to show up "Display driver stopped responding..."

By the way, this is not overclocking. You are not above your card's speed limit. This is not under-clocking, either, because you are not underclocking your max set speeds. This is just increasing idle clocks.
Score
0
April 10, 2012 1:57:02 PM

suat said:
Now do what you did previously to get TDR error to show up "Display driver stopped responding..."

By the way, this is not overclocking. You are not above your card's speed limit. This is not under-clocking, either, because you are not underclocking your max set speeds. This is just increasing idle clocks.


Yes, I realized this was idle speeds you were referring to and not actual overclocking once I followed your instructions.

I'll give it a try later on. Have to get some work done first today.

I'll keep ya'll posted.
Score
0
April 10, 2012 4:19:03 PM

Getting similar issues myself with a 6950.
Some people are suggesting that if you have a Realtek onboard sound, then make sure all the drivers on that are fully up to date, and if that doesn't work try disabling.
I'm downloading the latest drivers now in an attempt to fix mine.
Score
0
April 10, 2012 4:24:53 PM

FlyingIrishMan said:
Getting similar issues myself with a 6950.
Some people are suggesting that if you have a Realtek onboard sound, then make sure all the drivers on that are fully up to date, and if that doesn't work try disabling.
I'm downloading the latest drivers now in an attempt to fix mine.



Interesting. I do have Realtak onboard sound. One more thing I noticed. Right before the error happens while a match is loading the sound sort of blips out and loops.

Pretty sure I have updated drivers for the sound, but I'll check. Also disabling the sound would be a good way to see if it is somehow causing the problem or not, so, I'll try that too.
Score
0
April 12, 2012 3:32:37 PM

suat said:
Now do what you did previously to get TDR error to show up "Display driver stopped responding..."

By the way, this is not overclocking. You are not above your card's speed limit. This is not under-clocking, either, because you are not underclocking your max set speeds. This is just increasing idle clocks.


FlyingIrishMan said:
Getting similar issues myself with a 6950.
Some people are suggesting that if you have a Realtek onboard sound, then make sure all the drivers on that are fully up to date, and if that doesn't work try disabling.
I'm downloading the latest drivers now in an attempt to fix mine.



Since applying suat's suggestion of increasing the idle clock speeds and then also updating my onboard Realtek sound drivers, I have not had the error since(knock on wood).

I will now play around with decreasing the idle clock speeds.
Score
0
April 13, 2012 7:08:05 AM

I am glad to know that you seem to have sorted out your problem.

For your info, I have increased my idle clock speeds from core / memory 157 / 300 MHz to 234 / 400 MHz for my Radeon HD 5770 to avoid getting TDR error.

By the way, I am no gamer. I was having the issue while browsing the internet or dragging a file / folder on the desktop or opening a word document.

I learned the trick on the internet and make the suggestion, courtesy of the anonymous guy.

At this time I suggest that you set back your card's default idle clocks to see if the Realtek driver is the sole cause of the issue. My computer has VIA sound chip on the motherboard.

Regards
Score
0
April 13, 2012 2:22:32 PM

I've backed the idle speeds back down to normal and will keep an eye on it to see if by chance the Realtek driver was related or not.
Score
0
April 13, 2012 4:53:30 PM

suat said:
I have often suggested here increasing core/memory idle clock speeds in case one is experiencing TDR issue. It seems nobody is interested in doing it.

Here is the procedure doing it if anyone is interested:

Open Catalyst Control Center (new version since October 2011. Older versions have a different procedure.).

Make sure Enable Graphics Overdrive is unchecked in Overdrive section.

Click Presets.

Click Add preset.

Give a name to the preset (such as Speedy and note it) and save.

Now go to %USERPROFILE%\AppData\Local\ATI\ACE\Profiles\ (AppData folder is hidden. Select Show all files and folders in Folder Options.).

In Profiles folder, you will see a file called Speedy.xml. This file you have just created.

Open Speedy.xml with notepad.

In this file there is a line

name="CoreClockTarget....."
<Property name="Want_0" value="xxx00" /> (xxx00 is your idle-state core clock. Make it 40000)

and another line

name="MemoryClockTarget....."
<Property name="Want_0" value="yyy00" /> (yyy00 is your idle-state memory clock. Make it 90000)

Change only the Want_0 values. These are the idle-state clocks.

Save the file with the changes you have made.

Now go back to Catalyst Control Center.

Select the Preset called Speedy and then put a checkmark in the box next to Enable Graphics OverDrive.

Click Apply at the bottom of the Catalyst Control Center window.

Now you can see the new increased idle-state core/memory clock speeds.

Now try to give your card a good TDR if you can.

If your issue is resolved, then you may back off little by little on idle core/memory clock speeds until you find your system's lowest values, just to save energy and help GreenPeace act. If it is not resolved, good luck.



cann u do me a huge favor and tell me this in a more datailed begginers way because im lost and i need the help
Score
0
April 14, 2012 4:26:31 PM

suat said:
I am glad to know that you seem to have sorted out your problem.

For your info, I have increased my idle clock speeds from core / memory 157 / 300 MHz to 234 / 400 MHz for my Radeon HD 5770 to avoid getting TDR error.

By the way, I am no gamer. I was having the issue while browsing the internet or dragging a file / folder on the desktop or opening a word document.

I learned the trick on the internet and make the suggestion, courtesy of the anonymous guy.

At this time I suggest that you set back your card's default idle clocks to see if the Realtek driver is the sole cause of the issue. My computer has VIA sound chip on the motherboard.

Regards


After backing the idle speeds for the video card back down to normal, the Display adapter error came back. So I increased the idle speeds up to 300/800 and no more error again. I will now just try backing the idle speeds down a little at a time until I hit the sweet spot.
Score
0
April 15, 2012 6:18:59 AM

Dear andY biersack,

I do not know what else I can say to make the procedure clearer so you can apply it.

Perhaps you should tell us where you are lost so maybe someone or I can be of more help.

Hope this helps.

Dear areamike,

I am glad you are up and running again. Thanks for the feedback. I am sure your experience will help others sort out their issues.
Score
0
April 15, 2012 3:11:50 PM

suat said:
Dear andY biersack,

I do not know what else I can say to make the procedure clearer so you can apply it.

Perhaps you should tell us where you are lost so maybe someone or I can be of more help.

Hope this helps.

Dear areamike,

I am glad you are up and running again. Thanks for the feedback. I am sure your experience will help others sort out their issues.

OH sorry im lost in the part after you save the speeedy preset and the you say to do

Now go to %USERPROFILE%\AppData\Local\ATI\ACE\Profiles\ (AppData folder is hidden. Select Show all files and folders in Folder Options.).

i do not get where to go plus i no this would help becauese yesterday i left my game l4d2 running in the back round and the core clock was 300 but the memory was 1050 and the display driver has recoverd message all day
Score
0
April 15, 2012 4:00:40 PM

andY biersack said:
OH sorry im lost in the part after you save the speeedy preset and the you say to do

Now go to %USERPROFILE%\AppData\Local\ATI\ACE\Profiles\ (AppData folder is hidden. Select Show all files and folders in Folder Options.).

i do not get where to go plus i no this would help becauese yesterday i left my game l4d2 running in the back round and the core clock was 300 but the memory was 1050 and the display driver has recoverd message all day


If you are running Windows 7

Go to Computer\C-Drive\YOURUSERNAME\AppData\Local\ATI\ACE\Profiles

You will need to click 'Organize' in the top left of the window and then click Folder and Search Options. Then click the VIEW tab and click to Show Hidden Files and uncheck Hide Protected Operating System Files before you will be able to navigate to the above path.

Then you can navigate to the above path and edit the file suat refers to.
Score
0
June 27, 2012 10:51:55 AM

suat said:
Dear andY biersack,

I do not know what else I can say to make the procedure clearer so you can apply it.

Perhaps you should tell us where you are lost so maybe someone or I can be of more help.

Hope this helps.

hey Suat! I happen to have this problem too! HD 6870. I followed what you said but it doesn't change my idle GPU clock and Memory clock as seen AMD Vision Engine Control Center. What am I doing wrong? :(  please help I am really annoyed with this problem! :??: 
Score
0
June 27, 2012 12:19:17 PM

madmeatballs said:
hey Suat! I happen to have this problem too! HD 6870. I followed what you said but it doesn't change my idle GPU clock and Memory clock as seen AMD Vision Engine Control Center. What am I doing wrong? :(  please help I am really annoyed with this problem! :??: 



You must have missed something.

Do you have the preset created?
Did you modify the Speedy.xml file correctly?
Once you did the above, did you start CCC and then click the preset to select it, then enable Overdrive?

"Select the Preset called Speedy and then put a checkmark in the box next to Enable Graphics OverDrive.

Click Apply at the bottom of the Catalyst Control Center window.

Now you can see the new increased idle-state core/memory clock speeds. "
Score
0
June 27, 2012 1:29:54 PM

areamike said:
You must have missed something.

Do you have the preset created?
Did you modify the Speedy.xml file correctly?
Once you did the above, did you start CCC and then click the preset to select it, then enable Overdrive?

"Select the Preset called Speedy and then put a checkmark in the box next to Enable Graphics OverDrive.

Click Apply at the bottom of the Catalyst Control Center window.

Now you can see the new increased idle-state core/memory clock speeds. "

Yes I did, its 400/900MHz.

What did you do next? did you uninstall the ATI drivers? and install again?

....oh.. Just had the error again. So increasing the idle clock speeds doesn't work for me...
do you still get the error?
Score
0
August 9, 2012 11:25:54 PM

suat said:
I have often suggested here increasing core/memory idle clock speeds in case one is experiencing TDR issue. It seems nobody is interested in doing it.

Here is the procedure doing it if anyone is interested:

Open Catalyst Control Center (new version since October 2011. Older versions have a different procedure.).

Make sure Enable Graphics Overdrive is unchecked in Overdrive section.

Click Presets.

Click Add preset.

Give a name to the preset (such as Speedy and note it) and save.

Now go to %USERPROFILE%\AppData\Local\ATI\ACE\Profiles\ (AppData folder is hidden. Select Show all files and folders in Folder Options.).

In Profiles folder, you will see a file called Speedy.xml. This file you have just created.

Open Speedy.xml with notepad.

In this file there is a line

name="CoreClockTarget....."
<Property name="Want_0" value="xxx00" /> (xxx00 is your idle-state core clock. Make it 40000)

and another line

name="MemoryClockTarget....."
<Property name="Want_0" value="yyy00" /> (yyy00 is your idle-state memory clock. Make it 90000)

Change only the Want_0 values. These are the idle-state clocks.

Save the file with the changes you have made.

Now go back to Catalyst Control Center.

Select the Preset called Speedy and then put a checkmark in the box next to Enable Graphics OverDrive.

Click Apply at the bottom of the Catalyst Control Center window.

Now you can see the new increased idle-state core/memory clock speeds.

Now try to give your card a good TDR if you can.

If your issue is resolved, then you may back off little by little on idle core/memory clock speeds until you find your system's lowest values, just to save energy and help GreenPeace act. If it is not resolved, good luck.


Just want to thank suat for his advice as I tried this fix and low and behold my crashes on shutdown with my 7970 seem to have gone away. I used the 400mhz / 900mhz setting and haven't messed around with the lowest stable setting as yet. I'd previously tried drivers 12.3 - 12.7 beta to no avail.

But now the question i'm wondering is, what is at fault? is this a fault of the card or is it just flakey drivers? I'm contemplating RMA'ing the card and explaining my findings but if I get the same result it seems a bit fruitless.

My specs are....
Computer Specs
CPU = Intel Core i7 3930K
Motherboard = Gigabyte G1.Assassin2 Motherboard
Ram = Corsair Vengeance CML16GX3M4A1600C9B 16GB (4x4GB) DDR3
HDD = Intel 520 Series 240GB SSD
GPU = Sapphire Radeon HD7970 3GB OC

and i'm using the 12.7 beta drivers at the moment.
Score
0
August 10, 2012 7:20:25 AM

The problem could be drivers or could be hardware. I am not sure, but as a wild guess I can say this:

The new cards are made to operate on multi-clocks in an effort to save energy. Therefore, depending on the load on the card, the card changes clock speed in order to cope with the load. If the load is low, the card reduces clock speeds. If the load is high, the card increases clock speeds. Even in the same game, the clocks may tend to change because there are difficult scenes and easy scenes in the game, therefore different loads exist.

If transition from idle clock to some other clocks of the card is not smooth because of the drivers or because of the card itself, you get TDR issue.

Replacing the card with the exact same model may help or may not help. The card you buy at one time may be different from the same model card you buy at a later time because the cards may have different revisions. Even if the cards may have the same revision number, the tolerances of the components that make up the card may differ. This may improve or deteriorate your TDR issue. You cannot know.

Let me make an anology of the TDR issue in cards to the electrical failures I experienced in my electronic devices in the past.

I was having city electricity problems in the past beyond my control. Due to this, I had several device failures in my electronic home appliances such as amplifiers. City electricity was going off and coming back on almost instantaneously.

If the city wall electricty goes off and comes back on within less than a fraction of a second, you may experience hardware failures in the electronic devices switching off and back on. Likewise, if the load on the graphics card decreases and increases within less than a fraction of a second and the card wants to follow suit by switching clocks, you may have TDR issue. Increasing idle clocks helps transition from idle state to any power state. It is something like jumping over a barrier. If you want to jump over a two-meter high wall, it is much easier for you to jump if you stand on something 1.5 meters high than on something 0.5 meters high.

Please take the above explanation as a simple guess of the phenomenon that is occurring in my mind. It may not be true.

I hoped the card makers had already expressed what was happening.
Score
0
September 26, 2012 4:42:04 PM

For everyone who had those issues on windows and tried Linux after that.. On Linux Ubuntu you can adjust and save the idle clocks by using an third party amd overdrive tool named;
AMDOverdriveCtrl
Score
0
September 26, 2012 6:59:24 PM

This topic has been closed by Mousemonkey
Score
0
!