Sign in with
Sign up | Sign in
Your question

Disabling Right-To-Left Writing...

Tags:
  • Configuration
  • Microsoft
  • Customization
  • Windows XP
Last response: in Windows XP
Share
Anonymous
January 24, 2005 11:27:02 AM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

Hi, I'm Armenian & I like writing Armenian and having Armenian support :) )

In WinXp it's done by enabling "Install files for complex script and
right-to-left languages" checkbox in "Contol Panel > Regioanl Settings >
Languages Tab > Supplemental language support".

1. first problem is that Armenian is NOT a right-to-left writing language,
and the "right-to-left writing" menus that are in notepad's or other apps
mouse right click menu, are truly annoying and sometimes makes a lot of
problems for some lame users.

2. second problem is that when I change language bar to "HY" (Armenian) to
write Armenian unicode, it begans to write right-to-left :( 

I tried to change "intl.inf" in "Windows\Inf" by disabling all other
languages except Armenian, it solves all my problems but Armenian unicode
shows boxes instead of letters :( 

I found that this problem is caused of LPK...
and when i enable LPK >>

[LPK.LGReg.Install.Arabic] ;Arabic can be changed by anything
HKLM,"SOFTWARE\Microsoft\Windows
NT\CurrentVersion\LanguagePack","ARABIC",0x00010001,0 ;here too

<<

armenian unicode shows letters instead of boxes, but again right-to-left is
enabled and problems begin !

Please help...





here is what i made in intl.inf>>>
###############################
[LANGUAGE_COLLECTION.COMPLEX.INSTALL]
CopyFiles = KBD.LGFiles.Armenian,Armenian_Fonts
AddReg =
NLS.LGReg.Install.Armenian,KBD.LGReg.Install.Armenian,Armenian.Fonts.Reg,LPK.LGReg.Install.Armenian

[LANGUAGE_COLLECTION.COMPLEX.REMOVE]
DelFiles = KBD.LGFiles.Armenian,Armenian_Fonts_Remove
AddReg = NLS.LGReg.Remove.Armenian
DelReg =
KBD.LGReg.Remove.Armenian,Armenian.Fonts.Reg,LPK.LGReg.Remove.Armenian
#######################################




#########################
;
; Language Group - Armenian
;

[Armenian_Fonts]
sylfaen.ttf

[Armenian_Fonts_Remove]
sylfaen.ttf

[LPK.LGReg.Install.Armenian]
HKLM,"SOFTWARE\Microsoft\Windows
NT\CurrentVersion\LanguagePack","Armenian",0x00010001,0

[LPK.LGReg.Remove.Armenian]
HKLM,"SOFTWARE\Microsoft\Windows
NT\CurrentVersion\LanguagePack","Armenian",0x00010001,0
#######################################

More about : disabling left writing

Anonymous
March 4, 2005 8:01:41 PM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

> 1. first problem is that Armenian is NOT a right-to-left writing
language,
> and the "right-to-left writing" menus that are in notepad's or other
apps
> mouse right click menu, are truly annoying and sometimes makes a lot
of
> problems for some lame users.
>
> 2. second problem is that when I change language bar to "HY"
(Armenian) to
> write Armenian unicode, it begans to write right-to-left :( 

I guess there is the following key

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\LanguagePack]
"SURROGATE"=dword:00000002

in your registry... If SURROGATE =2, it means that Windows is expected
to support "Unicode supplementary characters". If SURROGATE =0, it
means that Windows is not expected to support "Unicode supplementary
characters".

Some comments on the SURROGATE key can be found at

Setting up Microsoft Windows NT, 2000 or Windows XP to support Unicode
supplementary characters
http://www.i18nguy.com/surrogates.html

Unfortunately, if the key SURROGATE is present and is equal to 0, this
forces Windows to enable the right-to-left writing. For this reason,
there appear additional items in the context menu. By the way, the
standard hot key combination in Windows for switching to the
right-to-left input directions is Right ctrl + shift. If you use the
same key combination for switching to the Armenian language, you switch
the language and the input direction at the same time.

But there is a subtle difference between SURROGATE being equal to 0 and
SURROGATE being absent! Just remove the key SURROGATE from the
registry, and the right-to-left input will be deactivated (and the
corresponding items in the context menu will disappear).
Anonymous
March 7, 2005 4:57:01 PM

Archived from groups: microsoft.public.windowsxp.customize (More info?)

Thanks for help, but it wasn't the thing I was searching :( 

Now I learned a lot about the SURROGATEs, but it doesn't help me...

I want to HAVE the multilanguage support (or only Armenian) but disable the
right-to-left menus, that's all I want...
!