Help New build Error

:hello: Just put together a new PC in my old Case from a long time ago. First off, here's the specs
Case: CoolerMaster Centurion 5
CPU : Intel I5 3570k
Mobo: ASRock Z77 Extreme 4
GPU: ATI Radeon 6870
RAM: Corsair Vengeance 8GB (2x4GB) (9-9-9-24)
HDD: 360GB Seagate SATA i believe
PSU : Thermaltake TR2 600w (I know not a very good PSU, but i bought it last minute at BB)
Optical: HP DVD/RW

So, today i finally got everything in, cleaned & Cleared my old case, did an out-of-case boot and everything went perfect.
Installed everything except GPU into case and got ready. POST looks good, no error codes and Dr.Debug Shows no errors. I go to boot setup and select DVD/RW Drive because I'm doing a clean install(Yes i have Boot CD in) and hit enter. I get This message :
" Reboot and select proper boot device or insert boot media"

So i go into BIOS and change boot order to HDD, Same thing. I even tryed changing the Type from ICHI, to IDE & RAID for sh :non: ts & Giggles, but still the same thing.
I'm thinking, Bad HDD? Nope, i hooked it up to an old tower i had laying around and everything looked good. Again, i switched out the brand new DVD/RW Combo drive for another and still same thing. I even tryed going into the 3GBs sata inputs on motherboard and same thing. I even switched out the new SATA Cables for old ones, and still the same thing.

Also, in the BIOS, both the DVD/RW Drive and the HDD are detected.

Any help would be appreciated, Although I'm not with my PC atm, I'm thinking it might be a jumper setting? Or maybe theres a master SATA Input?


By the way, i'm not quite sure if this is the right category, If it it isn't, I'm terribly sorry.

Thanks in advance,
Zack
2 answers Last reply
More about help build error
  1. I hate it when i hit a Bump in the road.
  2. Anyone? I've tried nearly everything.

    Anyone have any thoughts? Tips?
Ask a new question

Read More

Homebuilt Cases Systems