Sign in with
Sign up | Sign in
Your question

Computer Won't Start!

Last response: in Components
Share
October 7, 2012 6:35:46 AM

I decided I'd restart my computer because my internet was being particularly slow, but after I turned it off, it wouldn't turn on. It started a few days ago where I would turn off my computer and it would be slow to turn, like the fans would have a delayed start. But now, nothing will start at all. No fans at all in my computer run (not even PSU fan). I've noticed my PSU light is dim. I've tried removing RAM and my graphics card, but that doesn't do anything. I've tried disconnecting everything from my PSU except my motherboard, but still nothing will start. At first I thought my PSU might just be dead, but I tried testing it with the paper clip method and the PSU fan started spinning. It won't do anything with my motherboard though. Is my motherboard just dead?

This is my computer right here: http://www.newegg.com/Product/Product.aspx?Item=N82E168...

The psu is 350w, I believe.

Some changes I've made are I've upgraded the OS to Windows 7 Professional 64 bit. I've added an additional 2GB of RAM, and I've added an AMD Radeon HD 5570 graphics card.

All of a sudden, this computer is showing no signs of life at all. Please help! Thanks.

More about : computer start

a b ) Power supply
a b V Motherboard
October 7, 2012 1:34:20 PM

If you have a reset button that's separate from your power button, you could try connecting it (the reset button) to the power button header just to remove the power button itself from the suspect list.
!