Sign in with
Sign up | Sign in
Your question

Performance issue with radeon HD7870

Last response: in Graphics & Displays
Share
April 11, 2012 10:51:00 PM

Hi.
I recently bought a new radeon 7870 (upgrading from a radeon 6770) and installed it myself, I found a slight performance issue while playing world of warcraft. My framerate is all over the place, it jump's from 80 fps to 20 fps and everywhere in between with no real pattern to it. I am running the game on ultra preset, with 4x AA. ( on my old card I could run wow like this on a steady 75 fps, this is why I think there may be something wrong.)

Is there something wrong? and can I fix it?

my system specs are:
AMD phenom II x4 840 3.21GHz
Asus crosshair formula IV
8 Gbs RAM
windows 7 64 bit

a b U Graphics card
April 11, 2012 11:56:50 PM

newbie_22 said:
Hi.
I recently bought a new radeon 7870 (upgrading from a radeon 6770) and installed it myself, I found a slight performance issue while playing world of warcraft. My framerate is all over the place, it jump's from 80 fps to 20 fps and everywhere in between with no real pattern to it. I am running the game on ultra preset, with 4x AA. ( on my old card I could run wow like this on a steady 75 fps, this is why I think there may be something wrong.)

Is there something wrong? and can I fix it?

my system specs are:
AMD phenom II x4 840 3.21GHz
Asus crosshair formula IV
8 Gbs RAM
windows 7 64 bit


No graphics card runs a "steady 75fps" in WoW.....framerate will always vary with detail level (which can vary greatly from 1 zone to the next).
m
0
l
Related resources
!