Sign in with
Sign up | Sign in
Your question

3 monitors in windows 7 only 2 work.

Last response: in Graphics & Displays
Share
April 12, 2012 9:19:30 PM

Dell Optiples 790 Win 7 Professional Have 2 ATI RADEON 6350 installed and show up in device manager, all 3 monitors are connected using DVI. both cards have pigtails for two monitor hookups. using the ATI Graphics properties and in Windows display properties. Detecting monitors doesn't find it. there is no video option in bios either. how can i get the second card to activate and the third monitor to show up?

More about : monitors windows work

April 12, 2012 9:32:53 PM

Foud my own answer. you need to open the catalyst controll center, select peformance option and disable the Crossfire then windos will auto dect the screen.
m
0
l
a c 216 U Graphics card
a c 128 C Monitor
April 12, 2012 9:41:21 PM

That's one way, assuming you aren't trying to game with that setup. If you are trying to game, one of those connections must go through the displayport and all 3 monitors hooked up to the primary card.
m
0
l
Related resources
August 24, 2012 5:34:56 AM

cgrinder21 said:
Foud my own answer. you need to open the catalyst controll center, select peformance option and disable the Crossfire then windos will auto dect the screen.



AND how do I get into this catalyst controll center?

Anyway the manufacture tells me I can only run TWO monitors at a time, after all the problems I had getting the right cables
m
0
l
February 14, 2013 2:49:32 PM

Firstly, profuse thank yous to cgrinder71 for having the same problem as me and for providing the solution. I would never have got there on my own.

And secondly, to answer moneynow7's question, I did the following:
(in baby steps, sorry if it's too much detail, but better too much than too little)

Right click on desktop, select "Screen resolution"
- brings up display settings, with however many monitors are working (ie on one card)
right click on one of the displays shown in the "Change the appearance of your displays" box
select "properties"
select "Catalyst (TM) Control Center" tab
click on the button to bring up the Control Center Window
choose the advanced settings
- if you end up in basic you can switch to advanced using the relevant button on the bottom left
switch to the "CrossFire(TM)" screen by using the "Graphics" menu in the top left
- this menu is kind of tucked up above the header bar and it took me a few moments to discover it
untick the box to disable CrossFire(TM)
click apply, and smile as, after a brief pause, all your screens spring into glorious technicolor.

I'm assuming this will only work for people who have this problem caused by having two CrossFire compatible display adapters (like the RADEON 6350s) and the CrossFire software is (by default) combining the cards so they work like one more powerful card, so only the output from one of the cards is working. My clue to this was that only the PCI Bus 1 card seemed to be working (with two VGA monitors plugged in via a splitter cable, but when I disabled the PCI Bus 4 card (which shouldn't have made any difference, since no monitor was connected to it) all the settings went pear shaped.


m
0
l
!