SWTOR Help

According to my friend, My PC should be able to run SWTOR fine, but for some reason, im experiencing lag issues when i play with other characters and when I open my inventory or character sheet.

I have no clue what could be wrong, everyone else I have asked for help ends up being stumped.

AMD Phenom(tm) 9500 Quad-Core Processor
Installed Physical Memory (RAM) 8.00 GB
NVIDIA GeForce GTX 550 Ti
Windows 7 Operating system

My friend can play the game fine when hooked up to my internet, so I doubt that is the problem.

Help anyone Please?
9 answers Last reply
More about swtor help
  1. Do you have the same patches as your friend?
  2. yes all my patches are drivers are up to date
  3. make sure all your mb/sound and network drivers are up to date. also check to see what running in the background. things like apple update can be turned off to save memory. i would also run ccleaner and run malware scan and see if your anti virus is out of date or expired. malware and some virus can use a lot of your network bandwith. also if your running wifi check that no one leaching.
  4. The problem is most likely your CPU. The phenoms were not very good, and the one you have has an extremely low clock
  5. I just reinstalled windows on the comp. Only thing installed is SWTOR and no viruses or anything of the sort. Already did a defrag.

    Should I still run the CCcleaner? How do I test of CPU to see if that is the issue?
  6. Your hardware is not too bad. You didn't give any information on your screen resolution or how low your framerate is dipping.

    Have you tried tweaking your game settings?

    1. Lower or turn off your anti-aliasing setting in the game.

    2. Lower your in-game resolution.

    Adjusting these two settings can drastically improve your performance at the cost of visual quality.
  7. Even when i run the game on the lowest resolution, I still have the same issue. Im getting 20-30 FPS while im by myself, but it can drop to as low as 3-5 FPS when im intertacting with other player or NPC graphics.

    And I seem only to get a slight game performance increase when I go from high to low graphics settings
  8. The Phenom 9500 runs at 2.2 GHz which is at the very low end of the system Minimum req. Most MMOs in the first place struggle when running with AMD CPUs. More then likely it is your CPU causing the problems. Look at the SWTOR support forums. SOOO many of the problems are with AMD rigs. EA really optimized the game for Intel / Nvidia.
  9. SO if my processor runs at 2.2 GHz? what should the recomended processor run at? found a used one that runs at 2.6 GHz? Is that a big upgrade?
Ask a new question

Read More

Graphics Cards Graphics