Sign in with
Sign up | Sign in
Your question

Poor performance with high end PC. help

Last response: in Graphics & Displays
April 14, 2012 6:21:00 AM

cpu: amd 1090T
gpu: 7850 by club3d
ram: 4GB ddr3 1333mhz

the computer has been formatted recently, im using windows 7 x64, and i always use driver sweeper to change drivers

I have very low performance in all games and its the same even if i have very low settings or very high, for example in battlefield frames drop from 60 to 3-4 or 14-15 in nice fights even with very low settings. in 3dmark 2006 i got 12877 score. Help me please

When i install drivers i always get a : warnings occured during installation and in log its :
Hardware information
Name AMD Radeon Graphics Processor
Manufacturer Advanced Micro Devices, Inc.
Device ID 0x6819
Vendor ID 0x1002
Class Code 0x030000
Revision ID 0x00
Subsystem ID 0x2320
Subsystem vendor ID 0x1787
Other hardware
Existing packages
Microsoft Visual C++ 2010 Redistributable
Packages for install
AMD Catalyst Install Manager
Final Status: Success
Version of Item: 3.0.868.0
Size: 20 Mbytes
Final Status: Success
Version of Item: 10.0.898.1
Size: 90 Mbytes
AMD Display Driver
Final Status: Success
Version of Item: 8.951.0.0000
Size: 90 Mbytes
AMD Steady Video Plug-In
Final Status: Success
Version of Item: 2.06.0000
Size: 1 Mbytes
AMD Accelerated Video Transcoding
Final Status: Success
Version of Item: 2.00.0002
Size: 3 Mbytes
AMD Drag and Drop Transcoding
Final Status: Success
Version of Item: 2.00.0000
Size: 1 Mbytes
AMD Media Foundation Decoders
Final Status: Success
Version of Item: 1.0.70309.0018
Size: 1 Mbytes
AMD VISION Engine Control Center
Final Status: Success
Version of Item: 2012.0309.43.976
Size: 150 Mbytes
Related resources
April 14, 2012 6:59:39 AM

600W power supply and no change by enabling/disabling vsync
April 14, 2012 7:37:49 AM

rhapsody6666 said:
66 celcius is bad?

no with your card
also i dont know if games you play use physx but if they do disable it
I played Sacred 2 with physx enabled and i got unplayable FPS even at low resolutions .
After disabling it i could play the game with no problem at very high
April 14, 2012 7:45:01 AM

I also at first though that ATI was a *** because games i could play with GT 430 (i think it was) were playing smooth at high res but then i found that problem was with AMD catalyst settings .
There was one option , i think it was morphologic filtering and it caused all games to lagg . Disable it and also try to change all settings to auto or lowest .
April 14, 2012 7:52:31 AM

already disabled, everything is at use applications settings.. I EVEN GET 50 FPS sometimes in CS 1.6.. then in cs source i get about 32 in some fights... ffs ati must be closed
April 14, 2012 7:53:02 AM

ill never believe that an ATI card can play good all games, until i see it in front of me