Sign in with
Sign up | Sign in
Your question

Bad FPS

Last response: in Graphics & Displays
Share
April 14, 2012 10:42:09 PM

I recently bought a http://www.tomshardware.com/forum/349245-33-upgrading-g... with a 550W power supply that was recommended to me on this forum, both of them actually. This thing runs Skyrim on Ultra with no hiccups, anything. Perfect.

BUT, when I try Ultra settings in WoW I only get 40-50 FPS, and even with that the screen will freeze every few seconds, maybe 10-20 intervals, kind of like it hiccups. I don't understand how it can run Skyrim but not WoW, I thought
Skyrim was a more demanding game to begin with?

EDIT : I tried OC'ing the clocks to 1000 core and 1300 memory clock, made a 10-20 FPS difference

More about : bad fps

a c 291 U Graphics card
a b Ý World of Warcraft
April 14, 2012 10:45:38 PM

WoW is way worse optimized. Are you using any addons? They usually cause you to lose a lot of frames per second.
m
0
l
April 14, 2012 11:10:27 PM

I use recount, healbot, tidyplates, somtimes and Auctionhouse addon. My friend had a 6870 or somthing like that and he runs 100+ on Ultra. His is also Oc'd would OC'd mine help at all? A noticeable effect anyway
m
0
l
Related resources
a c 120 U Graphics card
April 14, 2012 11:20:42 PM

did you disable the on board video ?... and you're not trying to select hybrid crossfire are you ? ( disable on board video and disable hybrid crossfire )
m
0
l
a b U Graphics card
April 14, 2012 11:32:34 PM

List your system specs and update your drivers.
m
0
l
a c 83 U Graphics card
April 14, 2012 11:37:37 PM

swifty_morgan said:
did you disable the on board video ?... and you're not trying to select hybrid crossfire are you ? ( disable on board video and disable hybrid crossfire )


What? that would only apply to apus. and again... WHAT?

Also it worth noting WoW is crapware and should be immediately unistalled. It consumes a huge amour of your life resource then spits you out alone and pathetic.(LOL sorry couldn't help Myself)
m
0
l
a c 120 U Graphics card
April 14, 2012 11:39:12 PM

what do you mean, what ? ever hear of conflicts ?
m
0
l
April 14, 2012 11:39:27 PM

@ swifty, how do I do that? And here are my specs.
AMD A6-3650
Cores 4 Core Speed 2599.9 MHz
8.00 GB DDR3 @ 666MHz (9-9-9-24)
Gigabyte Technology Co., Ltd. GA-A75M-D2H (Socket M2)
ZORAN TV (1920x1080@60Hz)
AMD Radeon HD 7800 Series--- 7850
977GB Seagate ST31000524AS ATA Device (SATA)




m
0
l
a b U Graphics card
April 14, 2012 11:44:49 PM

Go into the BIOS to disable it.

AMD Support & Drivers - Did you install the latest drivers?
m
0
l
April 14, 2012 11:52:45 PM

I am downloading the drivers, the card came witht he sapphire disc and I installed w/e was on that.. maybe it didnt atually work though, we'll see. IS that a normal FPS for WoW?
m
0
l
April 14, 2012 11:59:51 PM

I am now getting 100 FPS after instaling that on Ultra, with resolution maxed. I also disabled ALL addons though.

This is also while idling in wow around no major city, alone, without combat or using spells.
m
0
l
a b U Graphics card
April 15, 2012 12:00:53 AM

That's your problem. Old drivers are filled with problems. You never want to use the discs that came with the card. Throw it away and get your drivers online.
m
0
l
a c 120 U Graphics card
April 15, 2012 12:15:48 AM

AustinA said:
@ swifty, how do I do that? And here are my specs.
AMD A6-3650
Cores 4 Core Speed 2599.9 MHz
8.00 GB DDR3 @ 666MHz (9-9-9-24)
Gigabyte Technology Co., Ltd. GA-A75M-D2H (Socket M2)
ZORAN TV (1920x1080@60Hz)
AMD Radeon HD 7800 Series--- 7850
977GB Seagate ST31000524AS ATA Device (SATA)


you need to hit the del key on boot up. this will bring you to the BIOS.......... READ the booklet that came with your mother board. ALL the information is there. Take your time and don't let it overwhelm you. Not as hard as you might think. If not sure don't touch anything. Just read and look around. ( you are looking for Hybrid Crossfire/disable it........ and you are looking for anything related to enabling/disabling on board video/disable ) then I think you need to hit F10 and then enter to save. That information should be at the bottom of the screen in the BIOS or in the booklet.

READ 10 times before you do anything. Hit the delete key and just look around the BIOS....... you don't have to change anything just look to get familiar.

also, the "on board video/disable"........ you can also select "auto" or pci-e or peg......... not familiar with thaT BOARDS bios.... YOU HAVE TO LOOK.
m
0
l
a c 83 U Graphics card
April 15, 2012 12:18:32 AM

^agree. usually. LOL. sometimes they make a mistake and you need to roll back. sounds like you are good though?

Edit: meant to point to e56imfg. taylor_swift_Morgan makes zero sense. he's whining about stuff that does not matter. crossfire (which is called dual graphics with apus) is controlled by the drivers
m
0
l
a c 120 U Graphics card
April 15, 2012 1:40:35 AM



Edit: meant to point to e56imfg. taylor_swift_Morgan

guess the cats out of the bag................ LOL
m
0
l
a c 83 U Graphics card
April 15, 2012 5:43:42 AM

swifty_morgan said:
Edit: meant to point to e56imfg. taylor_swift_Morgan

guess the cats out of the bag................ LOL


sorry. LOL couldn't help myself. my brain gets weird when.iys sleep deprived.
m
0
l
a c 291 U Graphics card
a b Ý World of Warcraft
April 15, 2012 10:45:48 AM

The addons were probably your problem, if you're running @ 100 fps without them. Of course, they will always reduce your fps by 40%-50% or so, but if you update them you could minimize that number. Also, being in the city will break your fps a lot. I'm personally getting around 40 fps at peek hours on my GTX 560 Ti.
m
0
l
April 15, 2012 7:54:24 PM

Will turning Shadows off completley increase my fps greatly? idc.. about.. shadows..
m
0
l
April 15, 2012 9:55:36 PM

I also sometimes get these faint white lines that run across my screen when wow is open, kind of like static white lines, but they aren't noticeable until you actually look
m
0
l
!