Sign in with
Sign up | Sign in
Your question

Wake on Lan

Last response: in Networking
Share
October 18, 2005 8:30:18 PM

Hardware:
pc4800-e deluxe
- bios "s3/str" enabled
- bios "power on by pci devices" enabled
onboard intel gbit network card (192.168.0.6) - LAN
2nd compaq 100mbit card (192.168.1.9) - WAN
dlink g4300 gbit gaming router
BOth network cards are connected to the router.

First, after activating the "power on by pci devices" my computer couldn't be turned off anymore (or rather, it automatically turned on every time). I figured it had to be a pci-card, so I removed all of them - and discovered that the dlink g520+ was causing the problem (so I put backthe others and removed the g520+).
This makes me sure that WOL should work with my mainboardand the settings in the bios are correct.

However, when I send the "magic" packet from my 2nd
computer "Magic Packet Utility" it doesn't turn on the other computer. Couldn't get it to work with any other
simular program either.

I check in the control pannel that both network cards
"are allowed to bring the computer out of standy"
"wake on link settings" is "forced"
"Wake on settings" is set to "wake on magic and direct"

Maybe the router is blocking the broadcast?
I tried with a standard switch (des-1008d) and it didn't
work either, so don't think it's a config problem with
the dgl 4300...

... so I tried everything I could think of and I'm out of ideas... :( 

Does anyone have suggestions on what I can still try?

Thanks!
Roger

More about : wake lan

October 18, 2005 8:47:44 PM

Do you have the wake on lan adapter for your NIC?

Here, I typed in "wake on lan" in google and I got all the info you'll need instead of me typing it all out.

<A HREF="http://www.annoyances.org/exec/show/article04-101" target="_new">your link to wake on lan</A>
October 18, 2005 9:08:29 PM

>Do you have the wake on lan adapter for your NIC?
Uh... I'm not sure what you mean here? I read sth about
older cards needing a cable to connect the network card
to the mainboard for wol to work. However, WOL doesn't
work with either the pci-card, nor with the onboard lan-card (I assume the onboard card wouldn't need an extra cable?) The mainboard manual is also really vague about the entire thing.

Hehe, I googled for some time, your link is one of the
sites which I got some info from :) 

Concerning
"wake on link settings" is "forced" (was disabled)
"Wake on settings" is "wake on magic and direct" (was OS controlled)
He describes to set it 'appropriately'... I assume
my current settings are correct?

However I can't find the NDIS settings he describes...

Oh, one more thing. When I power down my computer the onboard network-card has 2 yellow led's which remain on. When I start the computer the bottom one turns to yellow...

The site describes the lights should remain on... I assume that it's correct with the 2 yellow leds?


<P ID="edit"><FONT SIZE=-1><EM>Edited by rboerdijk on 10/18/05 05:13 PM.</EM></FONT></P>
Related resources
October 18, 2005 9:21:47 PM

To check the yellow light thing, I turned off all windows options (allow this device to power on, wake on link and wake on settings) ie put them back to default.

Then I turned of the computer - the two orange lights are
still blinking...

What I also noticed. I I completely remove power (pull the
plug) and then put it back, then the computer turns on for a few seconds and turns back off automatically - just like
if it's checking the networkcards or sth.
October 19, 2005 12:51:18 PM

What Brand/Model is your motherboard?

The 3com NICs, 3905x mentioned in the article come with a cable, 2 wires, white & yellow. It attaches to the motherboard to enable onboard LAN. Considering this card is older, it may be built in and running across the PCI bus now.

I'm guessing your computer meets the other requirements, which I think mentioned having an APCI v2.1 power supply? That just means your computer can turn off on it's own without you needing to push the power button.

The lights should stay on I believe. I don't really use WOL, but I've messed with it here and there. Let's do a little research to make sure your motherboard and NICs support it though.
October 19, 2005 5:58:34 PM

>What Brand/Model is your motherboard?
p4c800-e deluxe, from asus. According to the asus website
it should support WOL. It has an onboard intel networkcard.


>That just means your computer can turn off on it's own >without you needing to push the power button.
Well, if I have the Dlink g520+ card, it does turn on
by itself (actually it's more or less impossible to shut
it down, since it will automatically keep turning on).
I removed that card from the computer to solve that
problem (wasn't using it anyway).

So I guess the powersupply will meet acpi 2.1 - since
it _did_ turn itself on by itself.
And if I shutdown the computer from win2k, it does turn
off without me hitting the power button.



>Let's do a little research to make sure your motherboard
>and NICs support it though.
I'd be happy with any help I can get!
How can I check if the network cards support it?
I'm guessing that since the asus site says WOL is
supported, the onboard intel card should work?
Not sure about my 2nd network card though...
I'll open the case to get the exact serial and look it up.


Some more info:
- the onboard card runs on 192.168.0.6,
- the pci-nic runs on 192.168.1.9.
- the gateway is on 192.168.1.1
- 2nd pc is on 192.168.1.100

Will a wake-up broadcast from the second pc reach the
onboard card on the first pc, since it is on another
subnet?
October 19, 2005 6:43:10 PM

Update:
Power supply: Be Quiet BGT-p4-400W-S1.3
Compaq nic: compaq 10/100TX PCI Netelligent intel
utp controller...

The compaq is a bit older. Although I did hit some
links which had 'wol' behind it, i'm not 100% sure
that my card supports it...

I'm going to continue my experiments with the onboard card :) 



<P ID="edit"><FONT SIZE=-1><EM>Edited by rboerdijk on 10/19/05 02:43 PM.</EM></FONT></P>
October 19, 2005 7:16:48 PM

The IP Addresses are different, it won't hit it. Hard set ot set your onboard nic to DHCP and it should pick up the same range, then try it again. That's probably the problem.
October 19, 2005 9:05:06 PM

Yay, that fixed it - I can now start my computer over the LAN !!! :) 
On a sidenote, I thought that ip wasn't loaded yet since there is no OS (hence the need for the MAC-adress), so it's a bit strange that changing the subnet mask makes a difference..


Next step, Wake up over Internet (which obviously didn't work at once either, lol).
So I'm currently scourging the internet to find some info
on wake-on-lan and dgl-4300, but info is really scarce.


I downloaded the new firmware for the dgl-4300 (1.4) which
mentions in the changelist "4. New: Wake-on-LAN ALG".
I enabled it in the router under "advanced/special apps".

The router docs now state the following (note: amazing that they also updated the webfrontend docs with the firmware!)

Wake-On-LAN
This feature enables forwarding of "magic packets" (that is, specially formatted wake-up packets) from the WAN to a LAN computer or other device that is "Wake on LAN" (WOL) capable. The WOL device must be defined as such on the Advanced -> Virtual Server page. The LAN IP address for the virtual server is typically set to the broadcast address 192.168.0.255. The computer on the LAN whose MAC address is contained in the magic packet will be awakened.

So I added a virtual server
- name "Wakup vserver"
- ip adress: 192.168.1.255 (broadcast)
- protocol: both (tcp-ip and udp)
- private port: 9 (you have to enter sth, blank not allowed)
- public port: 9

I'm using the following websites to send the adress to my
router (using the wan-ip adress, as reported by the router)

http://www.depicus.com/wake-on-lan/woli.aspx
http://www.dslreports.com/wakeup
http://stephan.mestrona.net/wol/#

... but no wake-up :( 

any ideas?
October 20, 2005 1:08:43 PM

You'll need to set your PC up in the DMZ on your router, or you'll have to set your router to forward the ports to the PC you want to wake up.

Meaning you'll want to forward port 9 to the IP address of the computer that you want to wake up, 192.168.0.x - OR if you have port triggering (I think that'll do it) you can set it to a range of IP addresses to forward to multiple, or wake multiple computers via WOL.

Currently, your router is blocking that outside request because nothing internally requested it.
October 20, 2005 6:57:25 PM

>Currently, your router is blocking that outside request >because nothing internally requested it.
I don't think that's the case, because I did set up the port forwarding (called virtual server in dlink-language).

"The Virtual Server option allows you to define a single public port on your router for redirection to an internal LAN IP Address and Private LAN port if required. This feature is useful for hosting online services such as FTP or Web Servers."



It's actually setup just like I did my port21-ftp server,
only I forwarded port 9 to 192.168.1.255 for a broadcast..

I'm going to play around with the setting to see if I can
get it to work somehow :) 
October 20, 2005 8:58:40 PM

I don't think forwarding it to the broadcast IP will work. If you can, I'd set it to a physical port, if not, I'd hardcode the IP on the PC and set the forward to that IP.
October 21, 2005 8:07:19 AM

>I don't think forwarding it to the broadcast IP will work.
YOu are right, it doesn't work - Although in the router-help, it states the following:
"...The WOL device must be defined as such on the Advanced -Virtual Server page. The LAN IP address for the virtual server is typically set to the broadcast address 192.168.0.255. The computer on the LAN whose MAC address is contained in the magic packet will be awakened. "

=> so according to the manual, a broadcast should be possible (they only do it on 192.168.0.255 instead of 192.168.1.255)... or maybe it really _has_ to be 192.168.0.255 - even if I want to broadcast on another subnet (would be strange, but still I'll try when I get back home)..

>If you can, I'd set it to a physical port,
I don't quite understand what you mean here, could you elaborate?


>if not, I'd hardcode the IP on the PC and set the forward to that IP.
Do you mean DHCP, where the router will always assign the same IP to a certain mac-adress?
I did set it up to always assign the 192.168.1.9 ip to the PC I want to remotely wakeup.
Or do you mean that in the network-properties I should
manually set it to always use the 192.168.1.9 ip-adress?

Oh, and I also tried port-forwarding the the 192.168.1.9 ip,
(instead of 192.168.1.255 broadcasting) didn't work either.
October 21, 2005 12:29:54 PM

In your program that is issuing the WOL command, you have the MAC address listed in there for the computer you want to wake up?

Anything, x.x.x.255 is always broadcast, on any range.

Physical port meaning 1-4 on the back of your router, where you can assign anything connected to this port gets X. I haven't seen this option in SOHO stuff yet, only in corporate level stuff.

I wouldn't use DHCP for the WOL Computer, but according to what you C&P'd, it doesn't need the IP, only the MAC to make it work.
October 21, 2005 6:18:11 PM

>In your program that is issuing the WOL command, you have the MAC address listed in there for the computer you want to wake up?
Yes - and it does work in LAN, so the MAC I used in
the online version should also be correct (copy & paste).

>Physical port meaning 1-4 on the back of your router,
It's a consumer router, except 4 lan ports, 1 wan
port, power & reset, there is no fancy stuff in the
back :) 

>I wouldn't use DHCP for the WOL Computer, but according to what you C&P'd, it doesn't need the IP, only the MAC to make it work.
tcp/ip is an operating system protocol - that won't be available when the computer is turned off...
So it makes sense to use the MAC.

But since I can't forward to a MAC, I think I need to broadcast the entire 192.168.1.x ip-range - and the
computer which happens to have that MAC adress should wake up.

However either the router blocks the incoming message,
or the broadcast doesn't work for some reason.
October 21, 2005 6:36:32 PM

Take the router out of the picture and try doing the WOL.. that'll be the major test to figure out if it's getting blocked.

Use a network sniffer to see if the broadcast is working from outside too. Ethereal or other programs will tell you if the broadcast is working from outside. Compare it to the broadcast on your LAN to the one of the WAN.
October 21, 2005 8:53:05 PM

>Take the router out of the picture and try doing the WOL.. that'll be the major test to figure out if it's getting blocked.
It's a bit difficult to test this, since without router, my 2nd pc can't send the packet.

>Use a network sniffer to see if the broadcast is working from outside too. Ethereal or other programs will tell you if the broadcast is working from outside. Compare it to the broadcast on your LAN to the one of the WAN.
Woah, new frontiers are opening here :) 

I downloaded & installed ethereal, and just send this
'magic packet' to my own computer. From internet I know that the packet should contain the following datablock:
FFFFFFFFFFFF<16*mac-adress> => 6 + 16*6 = 102 bytes

<edit removed some lines, going to do more packet capturing>
<P ID="edit"><FONT SIZE=-1><EM>Edited by rboerdijk on 10/21/05 05:33 PM.</EM></FONT></P>
October 21, 2005 10:49:52 PM

Okay, got it to work!

The website sending the packet lets you
enter a subnet-mask. Apparently it should be 255.255.255.255 (instead of 255.255.255.0).

So port forwarding on the broadcast ip works :) 

I also found another option in the dgs4300 under
virtual server, you can select 'wake-on-lan' as
a predefined, then you only have to enter your
192.168.x.255 broadcast adress.

If I get some time, I'll try to write a little manual.

Thanks for the Help and Advices!!!

Regards,
Roger
October 24, 2005 1:23:47 PM

Makes sense, with the subnet 255.255.255.255, it's on broadcast itself.

At least we have an indepth article on getting it setup to work properly, should someone ever need it.
!