Sign in with
Sign up | Sign in
Your question

Problems with atheros ar5b97 and wifi on windows 7

Last response: in Wireless Networking
Share
Anonymous
a b F Wireless
a b $ Windows 7
August 13, 2011 9:13:26 AM

Hi,
I have a problem with atheros ar5B97 wireless connection on wifi. Irregularly it drops the connection (it probably gets lost) and then reconnects to the same network. That takes too long. (there are quite some other wireless networks in range)
The current driver version configured is 9.0.0.202 (dated 6-5-2010)
OS is Windows 7.
I have windows firewall and microsoft security essentials.
My home-network to which I want to connect is one that hides the SSID and uses both WEP encryption and MAC-filtering. I can connect, so that's not the problem. (On some other laptop with XP and a broadcom wireless connection it is absolutely no problem! There the connection is never dropped.)

What I did after occurring (don't know if it originally already was a problem, since the computer had not been used very much before, so it might have been unnoticed, but it seemed like somewhere after some windows update around 11.00 on august 12th 2011 ):
- Tried to solve it increasing the scan valid interval to 120. That doesn't seem to solve it. So set it back to the original 60.
- Installed Windows update: service pack 1
- Disable bluetooth, because I thought it might have been interfering. Didn't solve it.

Is this a known problem ?

Now, what should I do:
- Try to install latest version of the drivers or a specific version ?
- Revert windows updates ?
- Maybe try some other setting of the adapter?
- Is there a better way to solve this problem and if so, what is it ?

TIA,
Ronald

Anonymous
a b F Wireless
a b $ Windows 7
August 13, 2011 1:45:15 PM

I guess I accidentally solved it myself!
It may seem strange, but what did the trick was just plainly installing the already installed drivers again! Manually, that is, but after that: problem seems disappeared.

So for anyone with a similar problem: try re-installing your drivers if your guess is that the disruption was caused by a windows update.

Thanks anyway for anyone who may have been looking at this problem!
Cheers!
Ronald





Quote:
Hi,
I have a problem with atheros ar5B97 wireless connection on wifi. Irregularly it drops the connection (it probably gets lost) and then reconnects to the same network. That takes too long. (there are quite some other wireless networks in range)
The current driver version configured is 9.0.0.202 (dated 6-5-2010)
OS is Windows 7.
I have windows firewall and microsoft security essentials.
My home-network to which I want to connect is one that hides the SSID and uses both WEP encryption and MAC-filtering. I can connect, so that's not the problem. (On some other laptop with XP and a broadcom wireless connection it is absolutely no problem! There the connection is never dropped.)

What I did after occurring (don't know if it originally already was a problem, since the computer had not been used very much before, so it might have been unnoticed, but it seemed like somewhere after some windows update around 11.00 on august 12th 2011 ):
- Tried to solve it increasing the scan valid interval to 120. That doesn't seem to solve it. So set it back to the original 60.
- Installed Windows update: service pack 1
- Disable bluetooth, because I thought it might have been interfering. Didn't solve it.

Is this a known problem ?

Now, what should I do:
- Try to install latest version of the drivers or a specific version ?
- Revert windows updates ?
- Maybe try some other setting of the adapter?
- Is there a better way to solve this problem and if so, what is it ?

TIA,
Ronald

Anonymous
a b F Wireless
a b $ Windows 7
February 19, 2012 12:10:05 PM

Quote:
Hi,
I have a problem with atheros ar5B97 wireless connection on wifi. Irregularly it drops the connection (it probably gets lost) and then reconnects to the same network. That takes too long. (there are quite some other wireless networks in range)
The current driver version configured is 9.0.0.202 (dated 6-5-2010)
OS is Windows 7.
I have windows firewall and microsoft security essentials.
My home-network to which I want to connect is one that hides the SSID and uses both WEP encryption and MAC-filtering. I can connect, so that's not the problem. (On some other laptop with XP and a broadcom wireless connection it is absolutely no problem! There the connection is never dropped.)

What I did after occurring (don't know if it originally already was a problem, since the computer had not been used very much before, so it might have been unnoticed, but it seemed like somewhere after some windows update around 11.00 on august 12th 2011 ):
- Tried to solve it increasing the scan valid interval to 120. That doesn't seem to solve it. So set it back to the original 60.
- Installed Windows update: service pack 1
- Disable bluetooth, because I thought it might have been interfering. Didn't solve it.

Is this a known problem ?

Now, what should I do:
- Try to install latest version of the drivers or a specific version ?
- Revert windows updates ?
- Maybe try some other setting of the adapter?
- Is there a better way to solve this problem and if so, what is it ?

TIA,
Ronald



Hi found this web site http://www.atheros.cz/getfile.php ou will get the 9.2 driver try this see if that helps ok
Related resources
March 12, 2012 3:02:57 PM

Quote:
Hi found this web site http://www.atheros.cz/getfile.php ou will get the 9.2 driver try this see if that helps ok


I just downloaded it.

Thanks.

Did it help you?

Mine just dropped again. real pain. could it be related to my ACER Laptop?


I am wondering if the problem is my netgear wndr3400.
I am going to install an asus rt-n53 today.

March 12, 2012 4:06:18 PM

I just found a guy that recommended disabling the bluetooth high speed under the 'advanced tab' of the device manager for the adapter.

I did it also.

Time will tell.
March 20, 2012 2:41:33 PM

I resolved my problem by disabling MAC adress filtering in Linksys router options. Use another USB wireless network card to access internet, then type 192.168.1.1 in your URL bar, go somewhere ...like Security tab of your router options, disable MAC adress filtering.

It worked immediatelly. I needed 3 days or about 10 hours to resolve this problem for me. I hope this simple solution works for U. You can add new MAC adress to your filtering list, too.
March 20, 2012 2:43:07 PM

U should turn off bluetooth too, maybe, or maybe it work with it turned of too, but that is not the important thing. Many greetings guys & girls
!