Sign in with
Sign up | Sign in
Your question

Computer displays mobo's logo briefly then blank screen

Last response: in Systems
Share
June 15, 2012 11:00:42 PM

My specs:

Asus P5n-t
Intel core 2 quad q9450
4gb DDR2 1066 corsair dominator ram ( 4X1gb )
Corsair 500w PSU
XFX HD 4870 1gb
Monitor: HP w1907 19"


When I press the power button, the motherboard's logo displays for a few seconds, then abruptly goes blank. The monitor says no signal.

Can you please help???? This is very frustrating because it is my first computer build and i just dont know what the problem is.

Btw: I tried putting the graphics card into my old computer, and the same thing happens on that as well.

Do I need a new graphics card?

More about : computer displays mobo logo briefly blank screen

June 15, 2012 11:51:50 PM

Do you have external power hooked to the HD4870? Was the PC working then stopped working or did you just add the video card?

BIOS is not completing power on self test (POST). Is it making any beeping noises (google beep codes) ? If it's beeping then it's telling you the part that failed its test. If it's not beeping then the failed part is hanging the BIOS (not uncommon).

If the PC cannot tell you the failed part by beeping standard debugging is to remove parts until the machine posts (beeps) , then add back in parts until it stops posting. The last part usually have something to do with the problem.

IF the graphic card is installed correctly with power, and the power supply on the PC is big enough to support the card (300-350w min) and two different PCs both failed to post then it sure seems the video card is bad.

EDit: forgot to ask, if you pull the video card from the PC and boot does the PC correctly post and beep the "no graphics card" beep pattern ?
m
0
l
June 16, 2012 12:41:52 AM

Yes, I connected the required two 6pin cables to the video card. The computer was working until I added the video card.
There are no beeping sounds, however it does POST because it displays the motherboard's logo for a split second then the monitor says no signal. All the fans are running ( including video card ). The power supply is sufficient ( 500w ).

I tried putting the card in my old pc ( intel 945gct hm mobo ) and the same thing happens on that.

What can I do now? the p5n-t doesn't have onboard video so I'm stuck with using my old pc.
m
0
l
June 16, 2012 2:50:55 AM

"however it does POST because it displays the motherboard's logo for a split second then the monitor says no signal."

I was guessing this was a POST fail after the BIOS splash, and that removing parts would allow a post. If post worked it would be beeping (assuming a speaker).
m
0
l
Related resources
!