6950 drop in performance

Hey fellow geeks,

I run CF with 2 6950 (non reference) card on my wife's PC. I noticed that her FPS were much lower in BF3 than before. I took the CF apart and tested each card separably.
The XFX695X-CNFC scored only 3471 in 3DMark11 and the Sapphire 6950 scored 5112. The both run the same clocks, GPUs and memories.

I asked XFX to send me a BIOS to re-flash the card. And that is all that I can think of might work without me sending the card back.
PSU is fine I tested my CF 6970 on that system it runs perfectly.

Any ideas what could it be? GPU Z shows about the same thing for both cards...all core units are there...the only thing missing is performance.
I got the ticket with XFX but it is taking them too long to answer as usually. So I'm asking you what else do you think might fix this issue. Am I missing something?

Thanks, Max
6 answers Last reply
More about 6950 drop performance
  1. Have you monitored the xfxs temps? could be getting hot and could have a broken fan. Blow out the heatsink too.
  2. The fan is spinning and the temps in CF are idling at 38 and 72 under load. A single card idle is 36 and 68 load. So that is normal
  3. If it was working fine and now its low fps,A bios flash will do nothing.what drivers are you using?on hers and your rig?
    try her cards in your rig.
    I find the 12.1's and 12.2 caps are right for BF3 for my setup.
  4. Earnie said:
    If it was working fine and now its low fps,A bios flash will do nothing.what drivers are you using?on hers and your rig?
    try her cards in your rig.
    I find the 12.1's and 12.2 caps are right for BF3 for my setup.


    The drivers are all the same 12.3.
    For some reason it is underperforming. When it was new the score was 4800's and now no matter what system I use the score is in 3400's
    The CF score is 6500's( which is low low low) and it used to be around 10k. Just alone the other 6950 scores well above 5k.

    Why do you think that flash would not work? Perhaps it might have got corrupted in some paranormal way. You know PC, 101 is the charm! Something like Edison and a bulb. Sometimes things don't work and you just don't know why...a spec of dust or whatever and it throws everything apart...and then suddenly they work.

    I mean what else could it be other than the bios. Perhaps bad memory module? it is weird...but based on GPU Z everything checks out.
  5. I've been experiencing problems with my GPU too, I'm also using the Radeon HD 6950. By any chance is it HIS Ice-Q?
  6. It is XFX. I'm sending the card back for analyses. I'll update if they find out what is wrong.
Ask a new question

Read More

Radeon Graphics