Sign in with
Sign up | Sign in
Your question

Default gateway problem! help!!!

Last response: in Networking
Share
June 27, 2011 4:28:44 PM

Ok here is my problem.

I have a Fios wireless modem/router with an ip of 192.168.1.1 (Wireless G)

I have a Wireless - N router with an ip of 192.168.1.2 that is directly connected to a port on the G router/modem.


The wireless is disabled on the "G" router and all wireless computers/devices connect to the "N" router. All devices have static ip addresses and the default gateway is set to 192.168.1.1. This is because that is the modem and the device directly connected to the internet. I just use the "N" router for expanded coverage.

Everything works totally fine. Every device can get to the internet without any problems EXCEPT for my Roku player (enables me to watch netflix). For whatever reason Roku decided they would not allow static ip addressing. Because it is wirelessly connecting to my "N" router, it is pulling the ip address of 192.168.1.2 as the default gateway. So, it connects to my local network just fine, but has no access to the outside world. I cannot figure out out to change the default gateway to 192.168.1.1. If there is a way to do it on the Roku player, I haven't found it...

So then my question becomes: How do I force devices that connect to my "N" router to use 192.168.1.1 as the default gateway???? I'm sure there must be a way but I don't know what it is. How do I tell the N router to route all traffic destined for the internet to 192.168.1.1??? If I could change the default gateway on the Roku, that would solve the problem but I can't. So now that it thinks the "N" router is the gateway, how do I make this work?

Thank you in advance for any help!!!
a b F Wireless
June 28, 2011 3:21:43 AM

Disable DHCP on the "N" router and make sure DHCP is enabled on the "G" router.

Also, make sure the cable connected to the "N" router is NOT connected to the WAN port, but a regular port.
m
0
l
!