Sign in with
Sign up | Sign in
Your question

Sony Bravia TV sound problems on PC

Last response: in Graphics & Displays
Share
April 28, 2012 6:47:07 AM

Hi all,

I recently purchased a 40" Sony Bravia TV that I have connected to my PC and my PS3, both by HDMI cables so that I can use my speakers to output sound from both devices. Until the other day, after I reset the CMOS on my PC, they worked fine. I could switch easily between both devices and got sound.

Now, apparently after the CMOS reset, I get sound from my PC and if I switch to my PS3, from that as well. The issue is that when I switch back to my PC I get no sound. In the "Sound Devices" setting on my PC it has defaulted to "Digital Audio HDMI" instead of "AMD Digital Audio HDMI" which is grayed out. The sound is obviously coming from the HDMI via my graphics card which is why the AMD options need to be active. It always used to be but like I said, since the CMOS reset it doesn't seem to work anymore after I go back to my PC from having used the PS3. I can fix it relatively easily by unplugging the HDMI cable from the back of the PC and plugging it back in but this is not ideal. I've checked settings on the TV and nothing has changed, and after I plug the HDMI cable back in to the PC, it immediately sets the default sound to AMD.

Any ideas why this is? Could it have anything to do with the CMOS reset or is that just a coincidence? Thanks for any help.
April 28, 2012 7:39:28 AM

Well if you just did a CMOS reset and this has changed, then there must be a setting in BIOS that handles the sound, that was changed by the reset.
The "Digital Audio HDMI" tells me that the on-board GPU is still in use even though you are using a Graphics Card.
Try disabling the on-board graphics from BIOS, this will disable the on-board HDMI port allowing the AMD HDMI port to take priority.
You may also be able to disable the HDMI audio through Windows.
m
0
l
April 28, 2012 10:16:15 PM

I don't think there is an on-board GPU, the only HDMI port I have in my tower comes from the AMD/ATI graphics card I have. I tried your suggestion of disabling any relevant items in the BIOS but it hasn't worked. Problem persists. I also tried disabling "Digital Audio HMDI" through Windows in the hopes that the computer would be forced to default to the AMD HDMI audio if it had no other options, but that has not worked either. I still get the same error, which is that the AMD HDMI device is "not plugged in" which it clearly is because I'm using the monitor.
m
0
l
Related resources
April 29, 2012 7:57:38 AM

That's pretty weird, but if it worked before then there should a setting somewhere in the BIOS that controls it.
Could you post you Mobo and graphics card models?
Have you checked for an update for GPU?
m
0
l
April 30, 2012 2:06:25 AM

I think I may have fixed it, maybe. The only option in the BIOS that was relevant to the problem was the "Onboard Audio" setting that was set to "Enable" when I first went in there and I set it to "Disable". Now I have set it to "Auto", and I shut down my computer and turned off the TV. When all was booted up again, the sound works without me having to mess with the HDMI cable. Which it wasn't doing before. Same if I switch between the PC and the PS3. Fingers crossed that actually turns out to fix it.
m
0
l
April 30, 2012 7:29:04 AM

Glad to hear it!
It had to be something in there! When it comes to Sound and Audio devices MS hasn't done the greatest of jobs.
m
0
l
May 1, 2012 5:04:25 AM

Maybe I spoke to soon. Everything was fine today. Booted up the PC and the sound worked, which it usually wouldn't from boot up. Then I switched to the PS3, played for an hour or so, switched back and BINGO no sound on the PC again. Have to unplug the HDMI to get it to work. I don't get it it.

So in answer to your question earlier, if this is of any help, my motherboard is a Pegatron X58 and the GPU is ATI Radeon HD 6700.
m
0
l
May 2, 2012 7:57:30 AM

The only thin I can think of is to try turning off "sleep mode", so your gpu doesn't go to sleep (from power settings). My monitor does that sometimes, after going to sleep for a long time, I sometimes need to turn it off then on again. Check your power plan and select "Never" in the option "Turn Monitor off".
m
0
l
May 9, 2012 12:04:57 AM

I tried that. The problem still seems to persist but it's very inconsistent now, or seems to be. Sometimes when I boot up the computer it's fine, other times it's not. Maybe it is the HDMI cable? Although if it were, presumably I'd be having video trouble too? Which I'm not.
m
0
l
May 9, 2012 7:10:24 AM

Dude, sorry but I'm out of ideas.
One last thing I can suggest is to download the latest AMD driver, a new one just came out a couple days ago. Give that a shot, I hope it helps!
Sorry I couldn't be of more assistance..
m
0
l
!