Sign in with
Sign up | Sign in
Your question

Tried to enable pci-e gpu through bios= black screen

Last response: in Graphics & Displays
Share
April 28, 2012 5:18:38 PM

i just received my gtx 550 ti in the mail. when i tried to install it, all i got was a black screen. when i took it out however, the onboard graphics worked just fine. after reading online, i found out i needed to enable the pci-e thingy through the bios. i tried to to do that and it still didnt work. then i took the gpu out and tried to use the onboard graphics and now i get a black screen with that too! ive tried reseting the cmos, taking out the battery, taking out the ram, but nothing works. all i get is a black screen. i cant even get into the bios to reset anything =[.

please help, ive worked so hard to get this computer up and running just to play this one game.
a c 251 U Graphics card
April 28, 2012 5:53:58 PM

You did connect the 6 pin power plug to the card? You shouild have a cmos reset button on the motherboard somewhere or removing the battery should have reset the bios. When you took out the cmos battery did you unplug the power supply from the wall socket?
April 28, 2012 6:12:02 PM

yes, i did connect the 6 pin to the card. When its plugged in, i got the black screen. when its unplugged, the screen works fine. The cmos reset on my mobo are the 3 pins, but i took the battery out too just to be safe, and yes i did have the psu unplugged. even after all that i still cant get the screen to come one.
Related resources
a c 251 U Graphics card
April 28, 2012 6:23:59 PM

You may have redieved a card that is DOA and you should contact the place you purchased the card from for a RMA. If it'd not the card and it's the slot on the motherbaird then that's a whole different story and a lot more complicated. Do you have a way to test the card , another computer , a friend or relative who will let you test the card in thier computer or a place you can take it to, computer repair shop , Best Buy Store , someplace that you can verify the card is either working or not.
April 28, 2012 6:40:41 PM

ggkronicgg said:
yes, i did connect the 6 pin to the card. When its plugged in, i got the black screen. when its unplugged, the screen works fine. The cmos reset on my mobo are the 3 pins, but i took the battery out too just to be safe, and yes i did have the psu unplugged. even after all that i still cant get the screen to come one.


In the stupid question category, you did move the data cable from the MB to the PCI-E card? (I did / din't do that once...)
April 28, 2012 6:41:24 PM

it might be the mobo(i hope it isnt) because i tried to use an old gpu from my old dead PC and when i put it in the pci-e slot, the computer wouldnt boot at all(no fans, no nothing) i guess i will have to take the gpu to best buy and see if it works. aside from that though, is there anyway for me to get my screen to work through the onboard graphics again? it was working fine until i tried to use my new GPU =[
April 28, 2012 6:44:32 PM

data cable? like the sata one? there is a spot on top of the gpu for something, but i havent plugged anything into it, i dont think i have anything that fits either....>__>
a c 251 U Graphics card
April 28, 2012 6:52:50 PM

I believe he's refering to the cable from the motherboard to the monitor. Did you move the cable from the motherboard connector to the cards connector?
April 28, 2012 6:53:12 PM

The data cable that runs between the monitor and the PC. In your case you need to remove it from the MB port and attach it to the port on the new card
April 28, 2012 7:06:05 PM

Oooohhhh! Yes. Yes of course I plugged that in.(the blue cord that goes to the monitor) but I still got the blank screen. I figured that didn't work because I needed to install drivers first.


Thank you all for the help so far, I appreciate it.
April 28, 2012 7:18:13 PM

Windows will get the new card running until you install the specific drivers.

All you need to do is power down, install new card with correct power connections and cable to monitor. Power up into bios and update it for the new card. Let Windows start. Update drivers.

In your situation now to get the internal GPU running again: With the PC off - return the monitor cable to the MB port, remove the card, make sure none of the other power cords have been dislodged from any of the other components. Power up into BIOS, re-enable MB graphics.

Let us know what happens....
April 28, 2012 7:36:08 PM

Okay, i just got done trying to do both of those. problem is, i cant even get into bios. when i power on, the bios screen doesnt even pop up, it just a blank screen...

this is so frustrating and depressing....lol everything was fine until i tried to put in this new gpu. now i cant get things back to normal.
April 28, 2012 7:44:34 PM

What beeps do you get during the attempted startup?
April 28, 2012 7:51:23 PM

hehe i dont have an external speaker, so i wouldnt know =/
a c 251 U Graphics card
April 28, 2012 8:01:58 PM

During a normal start up you should get one post beep. If there is a video problem there will be a series of beeps and it varies according to the bios. But if you had a MB speaker and you got more than the one beep then you would know that something is wrong.
Having been doing things in the installing and taking out of the card you may have affected the ram sticks , so you could make sure that they are seated and have not become loose , also recheck all the power connections because you are focused on the video card and it could actually be something else that has become loose from all the work going on inside the case.
April 28, 2012 8:10:48 PM

im going to take everything out and reassemble and see if that solves the problem. and im going to have to pick one of those up.....because at this rate i feel like i just wasted my hard earned 600 dollars.
April 28, 2012 8:13:37 PM

ggkronicgg said:
im going to take everything out and reassemble and see if that solves the problem. and im going to have to pick one of those up.....because at this rate i feel like i just wasted my hard earned 600 dollars.



What is the MB you are installing the gtx 550 ti into? What is the PSU?
April 28, 2012 8:16:15 PM

mobo is a Biostar A780L3G. and my PSU is Antec 25 450W
April 28, 2012 8:16:27 PM

ggkronicgg said:
yes, i did connect the 6 pin to the card. When its plugged in, i got the black screen. when its unplugged, the screen works fine. The cmos reset on my mobo are the 3 pins, but i took the battery out too just to be safe, and yes i did have the psu unplugged. even after all that i still cant get the screen to come one.



You stated that when the 6 pin was unplugged, you had output to the monitor? From the video card? That does not seem right. Might be a clue... but does not get you going on the MB video.
a c 251 U Graphics card
April 28, 2012 8:21:10 PM

Traildriver said:
You stated that when the 6 pin was unplugged, you had output to the monitor? From the video card? That does not seem right. Might be a clue... but does not get you going on the MB video.



I tended to think that was odd also and made me think that the monitor cable was connected to the motherboard and if it was not then there was a definite problem with the card.
April 28, 2012 8:21:22 PM

oh, no. When i had the 6 pin unplugged i had the monitor in the mobo output. sorry if i was unclear.
a c 251 U Graphics card
April 28, 2012 8:23:37 PM

Hmmmmm!! :non:  :pfff:  :pfff:  :o 
a b U Graphics card
April 28, 2012 8:29:26 PM

There is almost no reason to ever manually set the BIOS to use pcie. The board will always be set to automatically detect the pcie card if available unless you tell it not to or its faulty. You could tell it was doing so by the fact that with a card in the onboard disabled. So you probably caused this problem by telling it to only use the pcie card. I dont kniw why everyone likes to say to do this. theres nit now and never has been a reason to do so unless the board is faulty. and if the board is faulty send it back. Try to reset the BIOS again and give it a few minutes.

Also have you tried using the DVI out instead of the VGA on the 550ti
April 28, 2012 8:31:48 PM

unksol said:
There is almost no reason to ever manually set the BIOS to use pcie. The board will always be set to automatically detect the pcie card if available unless you tell it not to or its faulty. You could tell it was doing so by the fact that with a card in the onboard disabled. So you probably caused this problem by telling it to only use the pcie card. I dont kniw why everyone likes to say to do this. theres nit now and never has been a reason to do so unless the board is faulty. and if the board is faulty send it back. Try to reset the BIOS again and give it a few minutes.

Also have you tried using the DVI out instead of the VGA on the 550ti


Any of the MBs I've used required the BIOS change....
April 28, 2012 8:35:22 PM

Just to eliminate it as a new possible source of aggravation due to the switching around of cables. Can you try a different data cable between the PC and the monitor or try your cord on another unit
April 28, 2012 8:37:50 PM

oddly enough, i pushed in everything on the mobo, and unplugged everything from the back except the keyboard, and now its working. Yea.... i probably did mess something up, im no expert and i probably shouldnt have went into the bios anyway(probably never will again, im scarred for life) unfortunately i dont have a DVI cord( i wish i did so i could hook it up to my TV) so im stuck using this. now if i go to the device manager on windows and disable the onboard mobo, will the 550 ti work?
April 28, 2012 8:52:44 PM

First off. Without changing anything in the BIOS, go into it and tell us what options it has regarding video output - disabling , changing etc. Don't do it at this time, but can you also state if you tried installing any of the new cards drivers/software (prob not since that is done after the card is installed and running - but I have to ask)

For myself, I have always had to go into the bios and disable onboard graphics.

Also beside the bios, let me know where the new card is physically at the moment and what the MB and power supply is.
!