Sign in with
Sign up | Sign in
Your question

ATI 12.4 Drivers

Tags:
  • Graphics Cards
  • Drivers
  • Graphics
Last response: in Graphics & Displays
Share
April 28, 2012 5:34:03 PM

Hello All,

Has anyone else seen a dramatic increase in GPU usage on their overclocked cards?

I have a 7970 Sapphire reference model and watching Afterburner version 2.2.0 latest full release, it climbs for instance anytime say a banner changes whilst browsing a web page? I seem to remember it happening on 12.2 or 12.1 too?!

It's driving me nuts, as it increases the temps to as high as 65 degrees when just browsing!! And playing Crysis 2 at 1920 x 1080 only raises it to a max of 78 degrees, and thats will hi res textures and DX11?!

One of the main reasons I bought the card other than the horsepower improvement over my 5870 was the 28nm energy saving?!

Has anyone else noticed this?!

Thanks!!

More about : ati drivers

a c 181 U Graphics card
April 29, 2012 2:41:30 AM

I have not seen any changes in my temps and I use MSI Afterburner and my little cards are OC'd. But every two weeks I take them out and use air on them to lean out any dust.
April 29, 2012 3:17:32 AM

dm don't you have 550 ti's.

i have noticed that and it does bother me, specially when i am on youtube or any other flash video. I've watched the gpu usage jump from zero to 16 sometimes 30 percent. my 5770 never went above 3 percent while browsing.
Related resources
a c 143 U Graphics card
April 29, 2012 3:40:29 AM

I built a high end pc for my friend last week, bought the sapphire HD 7970..after 1 weak of usage and hardcore gaming, it idles @ 51C drops to 48C and it reaches 80C if it's fully loaded by a game.

When the PC starts up temps are just 34-36C, but after you play some games for hours it will idle @50C never gets back to thirties unless you start tweaking up fan speed, and once you exceed 50% it's noisy as hell.

The bottom line is that most of the AMD ref designed cards behave and act that way but it will perform very strong and efficient even @ 100C, so don't worry..you just might feel some noise in the future.

If you feel a problem with the drivers, revert back to the most stable one. 12.3 seems to be the most stable.
April 29, 2012 9:18:04 AM

Hey Guys,

Thanks for the reassurance!

I have also read that Firefox has an issue with some GPU's. I was also getting very high GPU usage whilst just being on a page with say animated banner, up to maybe up to 75 percent?! I read others were having their GPU's spin up just because they were scrolling a page?! I have since began to run Firefox in Windows XP SP3 comparability mode, and my temps when surfing stay below 60, whilst still in my opinion high, not up there in the mid 60's!?

I to have noticed that once up there, the temps never really come back down unless I revert back to the desktop, and leave it for 5 to 10 mins, it goes down to 40 degrees. I suppose I need to just accept that as my card is a reference model, the temps may be higher than say a 2nd gen updated model.

Cheers,

E
a c 181 U Graphics card
April 29, 2012 11:04:16 PM

zakattak80 said:
dm don't you have 550 ti's.

i have noticed that and it does bother me, specially when i am on youtube or any other flash video. I've watched the gpu usage jump from zero to 16 sometimes 30 percent. my 5770 never went above 3 percent while browsing.


Yes to your question. If that is happening then some thing is out of wac. I could be in your CCC But I am not sure since I have nVidia cards and I don't get that problem. It could be just your drivers. Not sure though.
!