Sign in with
Sign up | Sign in
Your question

Uninstalled/deleted my RealTek ALC 892 codec

Last response: in Components
Share
October 28, 2012 11:55:54 PM

At some point I completely removed RealTek from my system. By that I mean, when I go to Device Manager, the device isn't even there anymore (I thought I remember a device being listed there somewhere). I remember doing it, but I don't remember why. I need to get it back, if there is any way to do that.

I tried downloading the drivers from my motherboards webpage (ASUS P8P67 PRO), but after installing, nothing has changed. Under "Audio" on the ASUS P8P67 PRO webpage this is listed:
Realtek® ALC 892 8-Channel High Definition Audio CODEC

I really know nothing about codec's or audio in general. Is there anything I can do, or am I screwed?


EDIT: I just want to add that I did this over a year ago, but my audio has been working fine. So either that means that it isn't gone, or it could be because I am using something else maybe?

If I go to "Device Manager", what is listed under "Sound, video and game controllers" is:

Logitech G330 Headset
NVIDIA High Definition Audio
NVIDIA High Definition Audio
NVIDIA High Definition Audio
NVIDIA High Definition Audio
NVIDIA High Definition Audio
NVIDIA High Definition Audio
NVIDIA High Definition Audio
NVIDIA High Definition Audio

I have been getting audio through either my headset or through the HDMI connection on one of my GTX 570's. As far as I know, the GPU itself needs a sound device correct? The headset is a USB headset.

EDIT 2: After some searching, the NVIDIA High Definition Audio seems to be its own audio "device" or codec. Like I said, I have no idea what I am doing when it comes to anything audio, haha. Even though my audio has been working fine, I still need Realtek back, mainly to access the "Audio Manager".
October 29, 2012 1:25:03 AM

in the control panel uner peripheral for the sound audio and vido,game controller if you open it do you see only the nvidia or the realtek is in
m
0
l
October 29, 2012 1:57:32 AM

I'm not sure what you mean by peripheral, but under the "Sound" window like this one http://www.windows7update.com/images/Microsoft-Windows-... all I see is NVIDIA High Definition Audio" and "Logitech G330 Headset".

I've made sure to right click and select "Show Disabled Devices" and "Show Disconnected Devices".
m
0
l
Related resources
October 29, 2012 3:19:40 AM

Went into my BIOS and looked through my onboard devices to find that the High Definition Audio had been disabled. I enabled it and logged back in to find it was now there.

Now Realtek is showing up in my sound options like in the picture I linked above, however there is still no audio coming through.

I'm going to keep messing with it to see if I can fix it, but if anybody has any suggestions, please let me know. Thanks for your help scout_03!

EDIT: OK solved the problem! Thanks again scout_03!
m
0
l
October 29, 2012 11:19:24 PM

what was the last thing you made to get sound ?
m
0
l
!