Sign in with
Sign up | Sign in
Your question
Solved

GTX 560 TI Issue

Last response: in Graphics & Displays
Share
April 30, 2012 3:02:21 AM

Hello guys, I am having an issue with my new gtx 560 ti.

The problem is, whenever I connect the PCI-E cables from my psu to the card, the computer still boots up and i hear the windows sound go on. However, there is no video display. When I plug OUT the power cables from the card, everything works fine, but I have to use the on-board graphics.

My specs are:
ASRock H61 mobo
Gigabyte GTX 560 TI
Raidmax 630 PSU
Intel i3 2120

More about : gtx 560 issue

a b U Graphics card
April 30, 2012 3:17:50 AM

Right. Well, in b4 replace your PSU. It's perfectly adequate.

Brand new eh?
Does the GFX fan spin up?
Does the computer beep? (if it has an onboard buzzer)

Do you have a mate with a different gfx card you can use temporarily?

Honestly, take the gfx card back and say it doesn't boot.
m
0
l

Best solution

a c 181 U Graphics card
April 30, 2012 3:20:15 AM

Have you disabled the on board GPU in the bios? Some systems you have to do that with and is your on board GPU a nVidia or a AMD one?

If it is a AMD one you will have to use a driver sweeper to get rid of those drivers so you can run the nVidia card.
Share
Related resources
a c 181 U Graphics card
April 30, 2012 3:20:27 AM

When you have the power cables in the gpu and you have the monitor in the gpu, check you bios to see if the 560ti is set to primary.
m
0
l
April 30, 2012 3:30:04 AM

@Teh Gerbuil
Yes the the fan is spinning.
And no it does not beep.

@DM186
I will try and disable the gpu, and im not entirely sure if it's nVidia or AMD

@k1114
I can't when I plug the power cables in the gpu the monitor doesn't display
m
0
l
a b U Graphics card
April 30, 2012 3:38:32 AM

Try doing this:
Power off.
Plug out the 560 Ti power cables.
Connect the mobo to your monitor.
Power on.
Go into the BIOS and look for an option that lets you choose your Primary Display Adapter.
Choose PCI-e 2.0 x16.
Power off.
Plug in power cables to 560 Ti.
Connect 560 Ti to monitor.
Power on.

Report back to see if it fixes your problem :D 
m
0
l
April 30, 2012 3:58:44 AM

Thanks everyone for your responses!

Turns out, DM186's suggestion did the trick!

For anyone having the same problem as me and looking for an answer, follow this instruction:
http://www.wikihow.com/Disable-the-Onboard-Graphics-and...

After it is disabled, turn it off and plug your graphics cards and turn it on and install the drivers.

Thanks guys!
m
0
l
April 30, 2012 4:12:40 AM

You should select DM186 as the best answer then.
m
0
l
April 30, 2012 5:00:19 AM

Best answer selected by jaehwanie.
m
0
l
!