Sign in with
Sign up | Sign in
Your question

AMD 12.4 beta CCC stopped working - new problem

Last response: in Graphics & Displays
Share
April 30, 2012 1:57:02 PM

Hey guys,

I'm having a problem that's REALLY starting to piss me off, lots of hair pulling has been done and I'm finally at my wits end...

I can't get into the CCC for love nor money, everytime I run it (and at OS boot) it comes up saying the Host application has stopped working...

Annoying.

Now, I installed (just before they came out, annoyingly, if I'd waited 2 days I would be fine...) the 12.4 beta drivers, and that's what caused the problem, I made sure everything was backed up and I had restore points set and all that, but now, after everything I've done to try and fix it, I cannot get into the CCC.

I have tried restoring to an earlier point, I've tried uninstalling the drivers, I've tried rolling back the drivers then updating them, I've tried uninstalling and reinstalling the CCC, I've tried registry cleaners, I've tried various .NET installations and I've tried even the whacky and zany fixes people have had (including uninstalling Windows Media Center) and I'm just about short of reinstalling Windows, it's infuriating.

And I'm desperate for help...

Has anyone encountered anything roughly the same? Any tips?

Thanks guys.
April 30, 2012 2:00:27 PM

Forgot to mention, but I'm now on the stable 12.4 release and it's still not working... (I tried editing)
m
0
l
April 30, 2012 2:07:53 PM

Did you try using Atiman uninstaller? I was having issues a couple weeks ago with driver sweeper not really doing its job correctly, and someone mentioned that Atiman uninstaller is much better/more thorough - I would recommend giving that a try if you haven't already.

Also, what hardware are you running?
m
0
l
April 30, 2012 2:14:17 PM

Sorry, forgot to mention...

I'm running:

AMD 955BE @ 3.7
Asus M4A77T
XFX 7950 DD
8GB Corsair Vengeance
Win 7 64-bit

I've looked at these ATi wipers, and I've been a bit sceptical as I saw a post somewhere saying not to use if you have an AMD CPU, now, I should be upgrading to IB very soon, but I don't fancy these problems going on... Will still take a look though, cheers
m
0
l
!