Control Turbo Boost multiplier/power

Hi guys!
I wanted to know if there's an app for controlling the behavior of Turbo Boost (NOT disabling it) on my i7 740QM. When performing lightly threaded tasks, Turbo Boost kicks in, pushing the clock speed too high, making the temps shoot to 85C+.
ThrottleStop doesn't work, the Turbo Power Limits and Turbo Ratio Limits options are greyed out.
Any help would be appreciated :D
12 answers Last reply Best Answer
More about control turbo boost multiplier power
  1. Best answer
    The 2nd and 3rd Generation Core i CPUs let you adjust the amount of Turbo Boost the CPU is using but unfortunately the first generation, non-Extreme CPUs, don't have this feature available. The 920XM has the TRL and TPL features unlocked but they are locked in the 720QM/740QM and 820QM/840QM by Intel.

    With ThrottleStop about all you can do is set up 2 different profiles; one with Turbo Boost enabled and one with it disabled. Then set up an Alarm based on the CPU core temperature and have ThrottleStop switch profiles based on the CPU core temperature. It would be far from ideal but it might give you some control over the way Intel designed these CPUs.

    ThrottleStop 5.00
  2. Clearing the dust that may have accumulated around the fan and inside the heatsinks might help.

    My sister's laptop started randomly shutting down a few weeks ago. After installing HWMonitor, I found out her CPU was hitting 75C idle so I investigated the heatsink and although the fan seemed clean at first glance, removed it revealed that the heatsink's fins were actually packed with dust.

    After thoroughly clearing the dust, the CPU temperatures dropped to 45C idle and 65C full-load.
  3. Thanks for the replies!
    The computer is dust-free; it was cleaned a few days ago.
    For now, I'll try unclewebb's suggestion and let a few more posts roll in.

    EDIT: Is there any way that I can control the TDP of the processor? Dropping it even a few watts would help massively with temps.
  4. I finally got around to setting up ThrottleStop, works like a charm. Unfortunately, it seems to cause a BSOD once I resume from sleep. What's the problem?
    My OS is Win 7 Home Premium SP1.
  5. Try turning off C1E if you are using that. A BSOD when resuming is often a sign that the CPU is not getting enough voltage and that can be caused by one of the C sleep states. There might not be any solution for that problem.
  6. Turn off Turbo Boost in the bios.
  7. No option in BIOS.
  8. Typically, I think there should be because if you have a CPU capable of HT, overclocking, turbo etc., there is actually no better place to turn those options on, off or adjust them other than the BIOS.
  9. I don't think you could use software through the OS to adjust such options, anyway.
  10. The BIOS only has options for VT-x and C1/C1E. I wish there were an option for HT though, I have no use for it.
    Disabling C1E still BSOD's the comp.
    EDIT: The error message is 0x0000001E (4 sets of zeroes).
  11. This thread has split into several questions, so I think I'll make different threads for them. Thanks for the help!
  12. Best answer selected by thenoob53.
Ask a new question

Read More

CPUs Intel i7 Turbo Boost Power