Computer won't start

So, today after waking up I decided that I wanted to print something for a project I am doing. So as I always do, I started up my desktop, watched it go through the Bios screen, and then immediately display "No Signal" across my monitor before shutting off. I tried a few more times and it happened again. I noticed that the MemOK light on my MB was still on, so I held it down until it blinked and registered everything as fine, but the same thing happened

Next I reseated all the ram, and then tried with single channel, duel channel and quad channel, still nothing.

Any ideas what to do?

My build:
CPU: AMD FX-8150
Mainboard: ASUS M5A88-V EVO
RAM: 16GB G.SKILL Ripjaws X Series
Monitor: 2x Acer V243HAJbd Black 20" Widescreen
Graphics card: EVGA GTX570 HD
5 answers Last reply
More about computer start
  1. Try checking that your CPU fan is seated correctly on your CPU itself. If it is, then try using another, working PSU to see if that's what's causing it to turn off.
  2. Do you have at least version 0707 of the BIOS? That board will not support that CPU with older BIOS.

    http://www.asus.com/Motherboards/AMD_AM3Plus/M5A88V_EVO/#CPUS

    Make and model of your power supply?
  3. I upgraded the BIOS to the latest one using the software that came with the board

    My power supply is a Corsair HX750W PSU
  4. Ok here is our standard checklist. Try going step by step even if you think you did it.

    http://www.tomshardware.com/forum/261145-31-perform-steps-posting-post-boot-video-problems
  5. I went through the list, nothing seems to be changing
Ask a new question

Read More

Homebuilt Systems