Sign in with
Sign up | Sign in
Your question

Sapphire HD 5850 boot problem

Last response: in Graphics & Displays
Share
May 1, 2012 4:26:12 PM

After a long wait and research and more research.
I finally finished my new build as follow:

CPU: i5 3570K
CPU Cooler: Zalman CNPS9900MAX-B
Mobo: AsRock z77 Extreme4
RAM: Corsair Vengeance DDR3 1600 8GB (2X4GB) CL 9-9-9-24 @ 1.5V
GPU: Sapphire HD 5850 (2 years old)
PSU: OCZ Fatal1ty 750W Modular (using 6pins to 6+2pins pci-e cable)
Case: Corsair Carbride 500R
Additional: 2 X Coolermaster R4 intake fan blue, LG DVD drive, Seagate 1TB SATA III 6Gb/s 7200RPM 64MB Cache

Voila, done, but not yet.
Upon first boot, the GPU fan ran at full speed and became insanely loud.
It won't die down and the PC just won't boot and no display of the asrock screen or whatsoever, just black and blank.
In fact, my HD 5850 had done that before while not seating properly and while my old PSU was dying. After reseating it and got a new PSU, it was running smoothly without problem in my old PC until now.

So I figured it might either be GPU, PSU or MOBO problem.
I tried a few things,

1.) update BIOS and drivers of the MOBO - NO LUCK
2.) reseat GPU, reconnect pci-e power cable - NO LUCK
3.) check for wires shorting the MOBO - NO LUCK
4.) switch pci-e cable to 8pins to 6+2pins pci-e cable - NO LUCK

What the ???, still no luck
So I did the followings,

5.) using EVGA GTX 460 from my other system (1 year old) instead of HD 5850 in the new system - WORKS
6.) tried HD 5850 in my other system with EVGA X58 SLI mobo and Antec True Power 750W - NO LUCK

So I am done, and so is the Sapphire HD 5850 (I think).
I am not a tech expert and I might be missing some important points.
So now I am stucked with the onboard Intel HD Graphic 4000.
With that I can boot and installed windows but not games.

So is there still any hope that I could fix it myself or I must RMA the card. (Sapphire has bad RMA service...they shipped the card back to HK for repair. insanely pricey maybe about $45-$75 incl labour, parts and shipping =.=)
If I have to RMA the card i might as well get a new one.

Any suggestions and comments will be greatly appreciated. Thanks a lot.

More about : sapphire 5850 boot problem

a b U Graphics card
May 1, 2012 5:07:08 PM

is the Primary Graphics Adapter in the BIOS set to PCI Express?
m
0
l
May 1, 2012 5:34:36 PM

Interesting, I never had a mobo with onboard graphic so I guess I am missing that. I will check it tonight. The default value should be set to PCI-Express but who knows. Thanks!!!
m
0
l
May 2, 2012 7:27:41 PM

I checked and the primary graphic adapter is already set to PCI-E. I think the card is hopeless.
m
0
l
!