Sign in with
Sign up | Sign in
Your question

Damage from Visible Dust wet cleaning solution

Last response: in Digital Camera
Share
August 3, 2005 10:23:49 AM

Archived from groups: rec.photo.digital (More info?)

It seems that Visible Dust's Sensor Clean solution for cleaning CCDs
may cause some serious damage to your camera -
http://dazza101.blogspot.com/2005/07/danger-of-cleaning...


Be careful out there folks!
Anonymous
August 3, 2005 10:49:44 PM

Archived from groups: rec.photo.digital (More info?)

"DD" <dioxindude@canada.com> wrote in message
news:1123075428.958384.212170@z14g2000cwz.googlegroups.com...
> It seems that Visible Dust's Sensor Clean solution for cleaning CCDs
> may cause some serious damage to your camera -
> http://dazza101.blogspot.com/2005/07/danger-of-cleaning...

It seems that ANY fluid could damage a sensor, Visible Dust's Sensor
clean is not unique in that sense.

Bart
Anonymous
August 3, 2005 10:49:45 PM

Archived from groups: rec.photo.digital (More info?)

"Bart van der Wolf" wrote...

> It seems that ANY fluid could damage a sensor, Visible Dust's Sensor
> clean is not unique in that sense.

Especially if you are squirting in there like you are hosing off your car.



Rita
Anonymous
August 4, 2005 6:33:55 AM

Archived from groups: rec.photo.digital (More info?)

"DD" <dioxindude@canada.com> wrote in message
news:1123075428.958384.212170@z14g2000cwz.googlegroups.com...
> It seems that Visible Dust's Sensor Clean solution for cleaning CCDs
> may cause some serious damage to your camera -
>
http://dazza101.blogspot.com/2005/07/danger-of-cleaning...
l
>
>
> Be careful out there folks!

Reading things like this sure makes me glad that I bought the Olympus E300
with the automatic supersonic wave filter dust removal system. It works,
too.


--
Take care,

Mark & Mary Ann Weiss

VIDEO PRODUCTION . FILM SCANNING . DVD MASTERING . AUDIO RESTORATION
Hear my Kurzweil Creations at: http://www.dv-clips.com/theater.htm
Business sites at:
www.dv-clips.com
www.mwcomms.com
www.adventuresinanimemusic.com
-
Anonymous
August 4, 2005 12:24:47 PM

Archived from groups: rec.photo.digital (More info?)

>> Mark & Mary Ann Weiss wrote ...
>>
>>glad that I bought the Olympus E300 with the automatic
>>supersonic wave filter dust removal system.

> Marcel replied ...
>
> there seems to be a few problems (with the E300) ... (snip list from a - n)

Should also mention that the Oly imaging division lost 24 billion yen
last quarter (the rest of the company made 12 billion yen ... hmmm) and
4/3 has not exactly set the world on fire when compared to Canon and
Nikon sales, so there is a reasonable doubt as to whether or not this
format will survive. For sure it won't survive many more quarters with
losses in the billions of yen range.

It's a nice little camera but there's a real question as to whether or
not it's a dead end, given the slow sales, handicap of the small
sensor, and lack of support from other makers (it's an open standard,
any one can make lenses and bodies for the system without paying
royalties, yet no one else has taken the leap of faith yet).

Bill
Anonymous
August 4, 2005 2:42:54 PM

Archived from groups: rec.photo.digital (More info?)

Mark,

Not to damp your enthusiasm, but the main thing about a camera is not "the
automatic supersonic wave filter dust removal system", but how well photos
turn out. There's the proof of the pudding.

I turned to Dpreview, not knowing about your particular model. It is rated
as "Recommended", but there seems to be a few problems related to metering
and image processing. Although, there are many good things about this
camera, the following are listed as cons:
a.. Recommended sensitivity ISO 100 - 400, images at ISO 800 usable, ISO
1600 not really
b.. Demosaic artifacts on JPEG and Olympus Master processed RAW
c.. Images not per-pixel as 'crisp' as from other D-SLR's (image
processing / low pass?)
d.. Moire artifacts can be detected in fine repeating detail
e.. Noise tends have the appearance of color mottle not 'film like' grain
f.. Metering bug sometimes left under-exposed images (isolated issue?)
g.. Auto focus provides just three focus points, although AF performance
good
h.. Viewfinder slightly darker than E-1, seems smaller than EOS 300D / 20D
i.. Over-saturated Adobe RGB images
j.. Poor continuous shooting capability, small buffer
k.. No focus distance indicator on kit lens
l.. Flash must be raised for AF assist
m.. Potential to lose images if CF door is opened during write
n.. Only USB 1.1 (no USB 2.0 Hi-Speed?)
I know that many of the above are moot points, but in my estimation, weigh
far more than the "the automatic supersonic wave filter dust removal
system".

Just my 2 cents

Marcel


"Mark & Mary Ann Weiss" <mweissX294@earthlink.net> wrote in message
news:n8fIe.562$RZ2.19@newsread3.news.atl.earthlink.net...
>
> "DD" <dioxindude@canada.com> wrote in message
> news:1123075428.958384.212170@z14g2000cwz.googlegroups.com...
> > It seems that Visible Dust's Sensor Clean solution for cleaning CCDs
> > may cause some serious damage to your camera -
> >
>
http://dazza101.blogspot.com/2005/07/danger-of-cleaning...
> l
> >
> >
> > Be careful out there folks!
>
> Reading things like this sure makes me glad that I bought the Olympus E300
> with the automatic supersonic wave filter dust removal system. It works,
> too.
>
>
> --
> Take care,
>
> Mark & Mary Ann Weiss
>
> VIDEO PRODUCTION . FILM SCANNING . DVD MASTERING . AUDIO RESTORATION
> Hear my Kurzweil Creations at: http://www.dv-clips.com/theater.htm
> Business sites at:
> www.dv-clips.com
> www.mwcomms.com
> www.adventuresinanimemusic.com
> -
>
>
>
August 4, 2005 5:30:58 PM

Archived from groups: rec.photo.digital (More info?)

"DD" <dioxindude@canada.com> wrote in
news:1123075428.958384.212170@z14g2000cwz.googlegroups.com:

> It seems that Visible Dust's Sensor Clean solution for cleaning CCDs
> may cause some serious damage to your camera -
> http://dazza101.blogspot.com/2005/07/danger-of-cleaning...
> r.html

Except that this is only one example, maybe that sensor was faulty?

Got FUD?


--
Mark Heyes (New Zealand)
See my pics at www.gigatech.co.nz (last updated 25-June-05)
"There are 10 types of people, those that
understand binary and those that don't"
Anonymous
August 4, 2005 9:35:44 PM

Archived from groups: rec.photo.digital (More info?)

MarkH wrote:
> "DD" <dioxindude@canada.com> wrote in
> news:1123075428.958384.212170@z14g2000cwz.googlegroups.com:
>
>
>>It seems that Visible Dust's Sensor Clean solution for cleaning CCDs
>>may cause some serious damage to your camera -
>>http://dazza101.blogspot.com/2005/07/danger-of-cleaning...
>>r.html
>
>
> Except that this is only one example, maybe that sensor was faulty?
>
> Got FUD?


SO is the filter completely sealed with the sensor? That is what I would
think but what is the FACT?
August 5, 2005 1:12:34 AM

Archived from groups: rec.photo.digital (More info?)

l e o <someone@somewhere.net> wrote in news:QlsIe.1294$RS.510
@newsread3.news.pas.earthlink.net:

> MarkH wrote:
>> "DD" <dioxindude@canada.com> wrote in
>> news:1123075428.958384.212170@z14g2000cwz.googlegroups.com:
>>
>>
>>>It seems that Visible Dust's Sensor Clean solution for cleaning CCDs
>>>may cause some serious damage to your camera -
>>>http://dazza101.blogspot.com/2005/07/danger-of-cleaning...
>>>r.html
>>
>>
>> Except that this is only one example, maybe that sensor was faulty?
>>
>> Got FUD?
>
>
> SO is the filter completely sealed with the sensor? That is what I would
> think but what is the FACT?

Yes, I am curious about that too. I certainly wouldn't conclude anything
from the experience of one isolated blogger. My own experience is nil, I
have only had my D-SLR for 2 years and have not yet had a need to use any
wet cleaning methods. In fact dust on the sensor has not really been an
issue to me, regardless of whether there is any on the sensor I have not
noticed any spots on the pictures I take. Maybe I'll check and give it a
blast with my rocket blower.


--
Mark Heyes (New Zealand)
See my pics at www.gigatech.co.nz (last updated 25-June-05)
"There are 10 types of people, those that
understand binary and those that don't"
Anonymous
August 5, 2005 1:18:18 AM

Archived from groups: rec.photo.digital (More info?)

G'day Rita,

Well as I AM the blogger who posted the story, I can tell you that I
didn't use the Sensor Clean liquid like I was "mopping a hospital
floor."

Far from "pure carelessness", I used two drops of Visible Dust's Sensor
Clean liquid on the sterile swabs they provide. This is the exact
amount they recommend in their instructions and it barely coats the
swab. I waited for it to soak into the fibres of the swab before wiping
the sensor.

The one thing that distinguishes Sensor Clean from other cleaning
solutions, is that it is not methanol based. This means that it
evaporates much more slowly and I believe this is how it managed to
wick down under the IR-filter and spread across the CCD sensor. It may
have happenned because of a pinhole defect in the seal between the
IR-filter and the CCD sensor, but the result is still the same - my
camera is wrecked and using Visible Dust's Sensor Clean according to
their instructions is the principle cause.

cheers,
darryl
Anonymous
August 5, 2005 1:52:19 AM

Archived from groups: rec.photo.digital (More info?)

"Mark & Mary Ann Weiss" <mweissX294@earthlink.net> wrote in message
news:n8fIe.562$RZ2.19@newsread3.news.atl.earthlink.net...
>
> "DD" <dioxindude@canada.com> wrote in message
> news:1123075428.958384.212170@z14g2000cwz.googlegroups.com...
>> It seems that Visible Dust's Sensor Clean solution for cleaning CCDs
>> may cause some serious damage to your camera -
>>
> http://dazza101.blogspot.com/2005/07/danger-of-cleaning...
> l
>>
>>
>> Be careful out there folks!
>
> Reading things like this sure makes me glad that I bought the Olympus E300
> with the automatic supersonic wave filter dust removal system. It works,
> too.
>
>
> --
> Take care,
>
> Mark & Mary Ann Weiss

I've been using Pec Pads and Eclipse solution wrapped around a wand. I only
use about three drops of solution, not enough to seep into anything, and
have never followed up the procedure with a dry pad. Works like charm. I
would think it would take quite a bit of solution to seem under the filter.
Never had much luck with other methods, except a hand blower that I always
use first.
Anonymous
August 5, 2005 10:50:17 AM

Archived from groups: rec.photo.digital (More info?)

Rita Ä Berkowitz wrote:
> <dazza101@gmail.com> wrote...
>
> > G'day Rita,
> >
> > Well as I AM the blogger who posted the story, I can tell you that I
> > didn't use the Sensor Clean liquid like I was "mopping a hospital
> > floor."
>
> I don't want it to sound like I am coming down too hard on you, as this
> wasn't my intention. I just see too much misuse of products on a daily
> basis where the product gets blamed instead of the person *possibly*
> misusing it.

No worries, I guess that careless use of products is often a primary
cause of problems...

>
> > Far from "pure carelessness", I used two drops of Visible Dust's Sensor
> > Clean liquid on the sterile swabs they provide. This is the exact
> > amount they recommend in their instructions and it barely coats the
> > swab. I waited for it to soak into the fibres of the swab before wiping
> > the sensor.
>
> Was this use in accordance to the camera manufacturer's recommendations or
> was this the instructions on the cleaning product? I feel that there are
> too many variables between camera manufacturer's and models that following
> the instructions on the cleaning product without doing research for other
> information is putting your sensor at risk.

Visible Dust have written instructions as well as instructional videos
on their website, I studied both before proceeding. As for Canon, they
only recommend using a blower brush on the CCD or returning it to Canon
for cleaning (as I explained in the blog post).

>
> > The one thing that distinguishes Sensor Clean from other cleaning
> > solutions, is that it is not methanol based. This means that it
> > evaporates much more slowly and I believe this is how it managed to
> > wick down under the IR-filter and spread across the CCD sensor. It may
> > have happenned because of a pinhole defect in the seal between the
> > IR-filter and the CCD sensor, but the result is still the same - my
> > camera is wrecked and using Visible Dust's Sensor Clean according to
> > their instructions is the principle cause.
>
> I would highly doubt that there would be a "pinhole defect" in the IR
> sensor. What I've seen when I researched the IR mods (Nikon D70) the
> filter is simply a flat piece that is sandwiched in place without seals. I
> can't say that all manufacturers do it this way, but I don't see a need for
> extra seals.

The suggestion isn't that there is a pinhole defect in the IR filter
itself, but rather that there is a pinhole or liquid path on the edge
of the seal between the two. i.e. it would have wicked down the side of
the two then along a gap between them by capilliary action. BTW, it was
the Visible Dust tech guy that kept insisting that this was a result of
a "defect" and therefore Canon's problem and not a result of using
their product. As Canon don't recommend using a liquid cleaner, I am
not convinced that this can necessarily be called a defect, but maybe a
more widespread concern with cleaning using liquids on the 300D and
possibly other cameras.


>
> What I have found by reading and personal experience is that the sensor is
> more durable and forgiving than one was lead to believe. I did my first
> cleaning with a PEC-PAD and distilled water since I was somewhat leery of
> using methanol based cleaners. I found that it wise to touch the PEC-PAD
> wrapped swab/wand to a separate PEC-PAD with a drop or two of liquid on it
> to load the proper amount of moisture. In most situations you should be
> looking for moisture instead of wet for your cleaning needs. Doing this
> yielded perfect results for me. After my comfort lever and skills increased
> I tried the ethanol based Eclipse cleaner using the same method. I prefer
> to error on the side of caution by keeping the liquid down to the bare
> minimum since, generally, electronics and liquids don't mix well.
>
> Anyway, good luck and I hope you get your camera repaired so you can start
> enjoying it again. Please keep us informed about the repairs.

Canon Canada aren't going to speculate on repairs until they see the
camera, so it'll probably be a couple of weeks before I hear back from
them...

cheers,
darryl
Anonymous
August 5, 2005 12:33:52 PM

Archived from groups: rec.photo.digital (More info?)

<dazza101@gmail.com> wrote...

> G'day Rita,
>
> Well as I AM the blogger who posted the story, I can tell you that I
> didn't use the Sensor Clean liquid like I was "mopping a hospital
> floor."

I don't want it to sound like I am coming down too hard on you, as this
wasn't my intention. I just see too much misuse of products on a daily
basis where the product gets blamed instead of the person *possibly*
misusing it.

> Far from "pure carelessness", I used two drops of Visible Dust's Sensor
> Clean liquid on the sterile swabs they provide. This is the exact
> amount they recommend in their instructions and it barely coats the
> swab. I waited for it to soak into the fibres of the swab before wiping
> the sensor.

Was this use in accordance to the camera manufacturer's recommendations or
was this the instructions on the cleaning product? I feel that there are
too many variables between camera manufacturer's and models that following
the instructions on the cleaning product without doing research for other
information is putting your sensor at risk.

> The one thing that distinguishes Sensor Clean from other cleaning
> solutions, is that it is not methanol based. This means that it
> evaporates much more slowly and I believe this is how it managed to
> wick down under the IR-filter and spread across the CCD sensor. It may
> have happenned because of a pinhole defect in the seal between the
> IR-filter and the CCD sensor, but the result is still the same - my
> camera is wrecked and using Visible Dust's Sensor Clean according to
> their instructions is the principle cause.

I would highly doubt that there would be a "pinhole defect" in the IR
sensor. What I've seen when I researched the IR mods (Nikon D70) the
filter is simply a flat piece that is sandwiched in place without seals. I
can't say that all manufacturers do it this way, but I don't see a need for
extra seals.

What I have found by reading and personal experience is that the sensor is
more durable and forgiving than one was lead to believe. I did my first
cleaning with a PEC-PAD and distilled water since I was somewhat leery of
using methanol based cleaners. I found that it wise to touch the PEC-PAD
wrapped swab/wand to a separate PEC-PAD with a drop or two of liquid on it
to load the proper amount of moisture. In most situations you should be
looking for moisture instead of wet for your cleaning needs. Doing this
yielded perfect results for me. After my comfort lever and skills increased
I tried the ethanol based Eclipse cleaner using the same method. I prefer
to error on the side of caution by keeping the liquid down to the bare
minimum since, generally, electronics and liquids don't mix well.

Anyway, good luck and I hope you get your camera repaired so you can start
enjoying it again. Please keep us informed about the repairs.




Rita
Anonymous
August 6, 2005 5:42:08 PM

Archived from groups: rec.photo.digital (More info?)

On Thu, 04 Aug 2005 17:35:44 GMT, l e o <someone@somewhere.net> wrote:

>SO is the filter completely sealed with the sensor? That is what I would
>think but what is the FACT?

I don't know about that particular DSLR model, but look carefully at
http://www.astrosurf.org/buil/d70/ircut.htm . This page (which is not
mine) shows how to remove the IR filter from a Nikon D70. It is
clearly seen that (1) the IR filter sits in front of the chip carrier
housing the sensor, (2) the IR filter itself is a thin bluish film
attached on the external surface of a thicker transparent glass plate,
and (2) no liquid-tight seal is visible around the IR filter (the
black frame that holds the IR filter in place is metal).

So, any liquid spill can work its way between the IR filter and the
optical-glass window of the chip carrier. Cleaning solution spilled on
the edges of the filter can also potentially seep between the glass
and the film/coating of the IR filter (which means a permanent
damage). The underlying window of the chip carrier must be sealed to
avoid moisture from damaging the chip - a standard procedure with all
ICs - so the inside of the chip carrier is probably safe.

This also means that, at least in a D70, if you scratch anything while
"cleaning the sensor", it will be the surface of the IR filter, not
the colour-separation microfilters in front of the Bayer sensor or the
surface of the sensor chip as I have seen stated more than once on web
sites. I don't know where the antialiasing filter sits, but I would
expect it to be very close to the chip and therefore also not
vulnerable when "cleaning the sensor". Does anyone know for sure?
Anonymous
August 7, 2005 1:39:14 AM

Archived from groups: rec.photo.digital (More info?)

dazza101@gmail.com writes:

>The suggestion isn't that there is a pinhole defect in the IR filter
>itself, but rather that there is a pinhole or liquid path on the edge
>of the seal between the two. i.e. it would have wicked down the side of
>the two then along a gap between them by capilliary action.

Are you sure it's between the filter and CCD cover glass? I suspect
it's more likely wicking into the space between layers in the filter.
The filter actually contains 4 layers; see
http://www.canon.com/technology/d35mm/01.html

>BTW, it was
>the Visible Dust tech guy that kept insisting that this was a result of
>a "defect" and therefore Canon's problem and not a result of using
>their product. As Canon don't recommend using a liquid cleaner, I am
>not convinced that this can necessarily be called a defect, but maybe a
>more widespread concern with cleaning using liquids on the 300D and
>possibly other cameras.

Lots of finger-pointing going on. Canon doesn't claim you should use
liquid cleaner at all, so they don't guarantee that the filter is sealed
along the edges. Visible Dust claims that the filter should be sealed
(and probably is sealed in most cameras) so their recommended procedure
is safe. But in the end, they won't warranty the procedure if it causes
a problem even if you follow their instructions.

Dave
Anonymous
August 7, 2005 3:10:04 AM

Archived from groups: rec.photo.digital (More info?)

>This also means that, at least in a D70, if you scratch anything while
>"cleaning the sensor", it will be the surface of the IR filter, not
>the colour-separation microfilters in front of the Bayer sensor or the
>surface of the sensor chip as I have seen stated more than once on web
>sites. I don't know where the antialiasing filter sits, but I would
>expect it to be very close to the chip and therefore also not
>vulnerable when "cleaning the sensor". Does anyone know for sure?

It's probably sandwiched with the IR filter, and all of them mounted
just in front of the sensor package. That's what Canon does, and I
don't see any reason for Nikon to be any different. The AA filter
doesn't need to be registered with the pixels of the sensor (unlike the
Bayer filter) so there's no need to put it inside the sensor package.

See http://www.canon.com/technology/d35mm/01.html for how Canon does it.

Dave
Anonymous
August 7, 2005 2:20:44 PM

Archived from groups: rec.photo.digital (More info?)

"Dave Martindale" <davem@cs.ubc.ca> wrote in message
news:D d3g0c$3c2$1@mughi.cs.ubc.ca...
> >This also means that, at least in a D70, if you scratch anything while
>>"cleaning the sensor", it will be the surface of the IR filter, not
>>the colour-separation microfilters in front of the Bayer sensor or the
>>surface of the sensor chip as I have seen stated more than once on web
>>sites. I don't know where the antialiasing filter sits, but I would
>>expect it to be very close to the chip and therefore also not
>>vulnerable when "cleaning the sensor". Does anyone know for sure?
>
> It's probably sandwiched with the IR filter, and all of them mounted
> just in front of the sensor package. That's what Canon does, and I
> don't see any reason for Nikon to be any different. The AA filter
> doesn't need to be registered with the pixels of the sensor (unlike the
> Bayer filter) so there's no need to put it inside the sensor package.

Minor quibble: The Bayer filter isn't a separate unit but is manufactured
into the chip during the chip fabrication process, so there's never a
question of registration with the pixels. At least for the consumer dcam
sensors from Sony, so I presume also for the Canon CMOS sensors.

See the figure on page 2 here (although this is a video camera chip):
http://www.sony.net/Products/SC-HP/cx_news/vol20/pdf/ic...

David J. Littleboy
Tokyo, Japan
Anonymous
August 7, 2005 2:20:45 PM

Archived from groups: rec.photo.digital (More info?)

"David J. Littleboy" <davidjl@gol.com> writes:

>> It's probably sandwiched with the IR filter, and all of them mounted
>> just in front of the sensor package. That's what Canon does, and I
>> don't see any reason for Nikon to be any different. The AA filter
>> doesn't need to be registered with the pixels of the sensor (unlike the
>> Bayer filter) so there's no need to put it inside the sensor package.

>Minor quibble: The Bayer filter isn't a separate unit but is manufactured
>into the chip during the chip fabrication process, so there's never a
>question of registration with the pixels. At least for the consumer dcam
>sensors from Sony, so I presume also for the Canon CMOS sensors.

I don't see how that's a quibble. I was saying that the Bayer filter
needs to be manufactured with the chip and inside the chip package
because registration of the filters with the sensels is critical.
It's effectively part of the sensor; I didn't suggest it was a separate
device.

In comparison with that, the AA filter *doesn't* need to be registered
in this way, so there's no reason to put it inside the package - just in
front of the package window will do fine.

Dave
!